delight email

 Top Next

Handbücher für delight email

Mit delight email können personalisierte Serien-Emails und -SMS versendet werden. Entweder an das komplette Adressbuch, nur an eine einzelne Person oder an eine speziell zusammengestellte Liste von Personen.


Adressverwaltung

 Top Letztes Next

In der Adressverwaltung können alle Adressen (Kunden, Lieferanten, Partner, usw.) zentral verwaltet werden.

Jede Adresse kann einer oder mehreren Zuordnungen zugeordnet werden. Über diese Zuordnungen können die Adressen in einer Baumstruktur kategorisiert und geordnet werden.


Adressen

Im Bereich Adressen können die einzelnen Adressen verwaltet und erfasst werden.

Hier können alle Aktionen die mit einer einzelnen Adresse zu tun haben vorgenommen werden.

Im linken Bereich des Fensters befindet sich die Adressliste sowie der Selektions- und Filterbereich.

Im grösseren rechten Bereich befinden sich alle Informationen und Angaben zur Adresse, die in der Adressliste ausgewählt ist.

Der rechte Bereich ist in folgende Unterbereiche aufgeteilt:

Details | Details zur ausgewählten Adresse. Es sind nur Felder, die für die Zuordnungen der Adresse eingestellt wurden, sichtbar.
Notizen | Notizen zur ausgewählten Adresse.
Zuordnungen | Zuordnungen, denen die ausgewählte Adresse zugeordnet ist.
Informationsfluss | Informationsfluss, welcher auf der ausgewählten Adresse stattgefunden hat.


Adressliste

Die Adressliste beinhaltet alle erfassten Adressen.

Über Filter und Selektion können die Adressen nach ihren Zuordnungen und weiteren Kriterien gefiltert werden.

siehe auch:

Adresse erfassen

Filter und Selektion

Allgemeine Dokumentation:

Tabellen


Filter und Selektion

Im Filter- und Selektionsbereich kann die Adressliste nach verschiedenen Kriterien gefiltert werden. Durch klicken/markieren auf den gewünschten Eintrag werden in der Adressliste nur noch Adressen angezeigt, die auf den markierten Eintrag zutreffen. Durch Mehrfachauswahl können mehrere Einträge gleichzeitig ausgewählt/markiert werden.

Beispiel: Um in der Adressliste nur Adressen einer bestimmten Zuordnung zu sehen, kann in der Baumansicht die gewünschte Zuordnung markiert werden. Werden mehrere Zuordnungen gleichzeitig markiert, werden in der Adressliste entsprechend alle Adressen, die in einer der markierten Zuordnungen sind, angezeigt.

Über dem obersten Eintrag in der Baumansicht (<Alle Adressen>) werden in der Adressliste alle im Programm vorhandenen Adressen angezeigt (sofern keine anderen Filter gesetzt sind).

Zusätzlich können Sie die Adressliste über die Spaltenüberschrift, über den Experten Filter sowie über den Schnellfilter nach weiteren Suchbegriffen filtern.

siehe auch:

Schnellfilter


Schnellfilter

Über den Schnellfilter können Sie sehr schnell nach Adressen suchen.

Geben Sie hier den gewünschten Suchbegriff ein. Sobald Sie für kurze Zeit keine Eingabe mehr machen, wird die Adressliste automatisch nach dem eingegebenen Begriff gefiltert. Über das kleine Bild (links im Eingabefeld) kann der gewünschte Such-Modus ausgewählt werden.

Über die Schaltfläche [image] oder die Tastenkombination Ctrl+F in der Adressliste kann auf den detaillierten Schnellfilter gewechselt werden.

In der Schnellfilter-Ansicht können Kriterien, nach denen die Adressliste gefiltert werden soll, definiert werden.

Wenn man z.B. in der Adressliste nur Adressen mit der Postleitzahl 9000 sehen möchte, kann man im Eingabefeld PLZ: die Zahl 9000 eintragen. Um das Fenster zu schliessen und die eingetragenen Filterkriterien zu aktivieren, drücken Sie [Enter].

Es kann nach mehreren Kriterien gleichzeitig gefiltert werden, das heisst, es kann zum Beispiel nach Land und Name gleichzeitig gefiltert werden. In diesem Fall würden nur Adressen, die dem Land UND dem Namen entsprechen, angezeigt werden.

Wenn in einem Textfeld gefiltert wird, werden alle Adressen, die den angegebenen Text in diesem Feld beinhalten angezeigt.

Wenn z.B. im Feld Name: nach dem Text "pe" gefiltert wird, werden alle Adressen in deren Namen "pe" vorkommt angezeigt.

siehe auch:

Erweiterte Suche

Filter über Spaltenüberschrift

Allgemeine Dokumentation:

Schnellfilter


Filter über Spaltenüberschrift

Über die Spaltenüberschrift können Sie sehr schnell und einfach die gewünschten Datensätze filtern.

Weitere Informationen, wie man über die Spaltenüberschrift filtert, finden Sie in der Allgemeinen Dokumentation unter Filter über Spaltenüberschrift.

siehe auch:

Erweiterte Suche

Schnellfilter

Allgemeine Dokumentation:

Filter über Spaltenüberschrift


Experten Filter

Über das erweiterte Suchen kann die Adressliste detailliert gefiltert werden.

Weitere Informationen zur Verwendung der erweiterten Suche finden Sie in der Allgemeinen Dokumentation unter Erweiterte Suche.

siehe auch:

Schnellfilter

Filter über Spaltenüberschrift


Adresse erfassen

Über die Schaltfläche Hinzufügen in der Adressliste kann eine neue Adresse erfasst werden.

Wenn die Adressliste unter Filter und Selektion auf eine Zuordnung gefiltert ist, wird die neue Adresse automatisch mit dieser Zuordnung erfasst.

Welche Felder im Fenster zum Erfassen der neuen Adresse verfügbar sind, hängt von der unter Filter und Selektion ausgewählten Zuordnung ab. Ist keine Zuordnung ausgewählt, werden die Standard-Felder angezeigt.

Durch klicken auf die Schaltfläche Speichern wird die neue Adresse gespeichert.

Hinweis:

Ist die Telefonbuch-CD-Erweiterung installiert, kann eine Adresse direkt aus dieser importiert werden (z.B. TwixTel).

Klicken Sie dazu auf das entsprechende Symbol.

Allgemeine Dokumentation:

Datensatz hinzufügen

Tabellen


Adresse löschen

Über die Schaltfläche Löschen in der Adressliste kann die ausgewählte Adresse gelöscht werden.

Allgemeine Dokumentation:

Datensatz löschen

Tabellen


Details

Im Bereich Details sind die Detailangaben der Adresse ersichtlich.

Es sind nur Felder sichtbar, die für die Zuordnungen der Adresse eingestellt wurden. Falls die sichtbare Adresse keiner Zuordnung zugeordnet ist, werden die Standard-Felder angezeigt. Durch klicken auf die Daten eines Feldes kann das Feld bearbeitet werden.

Oben links ist der Status der markierten Adresse sichtbar, durch klicken kann dieser jederzeit geändert werden.

Rechts im Feld Bemerkungen können kurz gefasste (max. 250 Zeichen) Anmerkungen zur Adresse erfasst werden. Längere Bemerkungen können in den Notizen notiert werden. In Kontaktpersonen können der Adresse Kontaktpersonen zugeordnet werden. In Steht in Verbindung mit Adressen ist ersichtlich, auf welchen anderen Adressen die aktuelle Adresse als Kontaktperson eingetragen ist.

Im Bereich Klassifikation kann die Adresse anhand von verschiedenen Kriterien klassifiziert werden. Eine Klassifikation könnte z.B. sein: "Im Vorstand als Geschäftsführer".

Weitere Informationen finden Sie in der allgemeinen Dokumentation unter Detailanzeige eines Datensatzes.

siehe auch:

Einstellungen Zuordnungen


Kontaktpersonen

Im Bereich Kontaktpersonen können neue Kontaktpersonen erfasst oder bereits bestehende Adressen als Kontaktperson verknüpft werden.

Über die Schaltfläche Hinzufügen kann eine neue Kontaktperson erfasst werden.

Eine bereits im Programm erfasste Adresse kann über Bestehende Adresse verknüpfen als Kontaktperson hinzugefügt werden.

Über den Menüpunk Neue Adresse kann eine neue Adresse erfasst und als Kontaktperson gespeichert werden.

Mit Doppelklick auf eine Adresse wird diese geöffnet.

Im Bereich Steht in Verbindung mit Adressen wird angezeigt, auf welchen anderen Adressen die aktuelle Adresse als Kontaktperson eingetragen ist.

siehe auch:

Kontaktperson verknüpfen

Kontaktperson erfassen


Kontaktperson verknüpfen

Über Kontaktperson verknüpfen kann eine bestehende Adresse als Kontaktperson auf eine andere Adresse verknüpft werden.

Eine Adresse kann auf beliebig viele verschiedene Adressen verknüpft werden.

1. Wählen Sie die Adresse, die als Kontaktperson hinzugefügt werden soll.

2. Wählen Sie unter Verknüpfen als mit welcher Beziehung diese Adresse verknüpft werden soll.

(Im oben gezeigten Bild wird "Frau Susi Schnell" als "Ehefrau" verknüpft)


Kontaktperson erfassen

Über Neue Adresse kann eine neue Adresse erfasst und als Kontaktperson auf eine andere Adresse verknüpft werden.

Die neu erfasste Adresse kann später zusätzlich (über Kontaktperson verknüpfen) auf beliebig viele andere Adressen verknüpft werden.

1. Wählen Sie unter Typ mit welcher Beziehung die neue Adresse verknüpft werden soll.

2. Geben Sie Anrede, Name, Vorname und Geburtsdatum für die neue Adresse ein. Alle anderen Adressdaten werden automatisch von der aktuellen Adresse kopiert.


Zuordnungen

Im Bereich Zuordnungen kann die Adresse beliebig vielen Zuordnungen zugeordnet werden.

Über die Zuordnungen kann die Adresse logisch, in einer Baumstruktur kategorisiert und eingeordnet werden.

Die Adressliste kann über Filter und Selektion nach diesen Zuordnungen gefiltert werden.

Über die Zuordnungen wird bestimmt, welche Felder der Adresse in den Details sichtbar sind.

siehe auch:

Einstellungen Zuordnungen


Foto/Logo

Im Bereich Foto/Logo kann ein Passfoto oder ein Firmenlogo auf der Adresse hinterlegt werden.

Über die Schaltfläche Hinzufügen kann ein neues Foto/Logo aus einer Grafikdatei importiert werden.

Falls Sie einen Scanner oder eine Digitalkamera an ihrem PC angeschlossen haben, können Sie das Bild direkt über Einscannen vom entsprechenden Gerät importieren.

Mit Löschen kann das Bild entfernt werden.

Hinweis:

Die Funktion Einscannen steht erst ab den Professional-Versionen (oder höher) zur Verfügung.


Klassifikation

Im Bereich Klassifikation kann die Adresse anhand verschiedener Kriterien klassifiziert werden.

Über die Schaltfläche Hinzufügen kann eine neue Klassifikation zur Adresse hinzugefügt werden.


Notizen

Im Bereich Notizen können beliebig viele Notizen auf einer Adresse erfasst werden.

Kurze Notizen können in den Text Notizen erfasst werden. Grössere Notizen mit Bildern und Formatierung werden in Erweiterte Notizen erfasst.

siehe auch:

Text Notizen

Erweiterte Notizen


Text Notizen

In den Text-Notizen können Sie kurze Notizen ohne Bilder und Formatierungen erfassen.


Erweiterte Notizen

In den erweiterten Notizen können Sie detaillierte Notizen mit Bildern, Tabellen usw. erstellen.

Die einzelnen Notizen müssen in Ordner abgelegt werden. Auf den einzelnen Ordner kann ebenfalls eine detaillierte Beschreibung hinterlegt werden.


Informationsfluss

Dieser Bereich ist nur im Produkt "delight address" verfügbar.

Im Bereich Informationsfluss können alle Aktionen, die mit der Adresse stattgefunden haben, erfasst werden.

Anmerkung:

Der Informationsfluss ist sehr einfach gehalten. Ein ausführliches und umfangreiches Journal mit vielen erweiterten Funktionen

und Möglichkeiten ist erst in den umfangreicheren Programmpaketen wie z.B. delight crm enthalten.

siehe auch:

Einstellungen Informationsfluss


Adresslisten

Im Bereich Adresslisten können Auszüge aus der Adressliste erstellt und weiterverarbeitet werden.

Hier können alle Aktionen, die mit mehreren Adressen zu tun haben, vorgenommen werden.

Im oberen Bereich des Fensters befindet sich die Adressliste sowie der Selektions- und Filterbereich.

Im linken Bereich befindet sich die Liste mit allen Zuordnungen der markierten Adresse. Die Zuordnungen können auch für mehrere Adressen gleichzeitig bearbeitet werden. Markieren Sie dazu die gewünschten Adressen in der Adressliste. Das Bearbeiten mehrerer Adressen gleichzeitig ist ebenfalls möglich.


Berichte

Hier können Berichte wie z.B. Adresslisten, Serienbriefe, Etiketten usw. für alle Adressen, die in der Adressliste sichtbar sind, erstellt werden.

Um eine bestimmte Auswahl an Adressen für den Bericht zu verwenden, können Sie über Filter und Selektion die Adressliste filtern.

siehe auch:

Einstellungen Berichte


Import/Export

Hier können alle in der Adressliste sichtbaren Adressen importiert und exportiert werden.

Mit der Schaltfläche VCard für alle Adressen können alle Adressen in die Formate VCard oder LDIF exportiert werden.

Mit der Schaltfläche Adressliste im Bereich Export können alle Adressen, wie sie in der Adressliste angezeigt werden, mit dem Datenexport-Modul exportiert werden.

Mit der Schaltfläche Adressliste im Bereich Import können Adressen aus externen Datenquellen (Dateien, Datenbanken usw.) mit dem Datenimport-Modul in die aktive Zuordnung importiert werden.

Hinweis:

Wenn Sie mehrere Adressen selektiert haben, werden nur die selektierten Adressen exportiert (gilt nicht beim VCard-Export).

Falls eine Funktion nicht verfügbar ist, steht das benötigte Erweiterungs-Modul nicht zur Verfügung.


VCard Export

Klicken Sie im Bereich Export auf die Schaltfläche Einzelnen VCard, um das Fenster für den Export zu öffnen.

Es gibt zwei verschiedene Möglichkeiten die VCards zu exportieren:

Export in eine Datei

Alle VCards werden in eine Datei gespeichert.

Geben Sie einen Dateinamen an, unter dem die VCards gespeichert werden sollen.

Export in einzelne Dateien

Jede VCard wird in eine einzelne Datei gespeichert.

Markieren Sie alle Felder, die für den Dateinamen verwendet werden sollen.

Durch Klicken auf die Schaltfläche Exportieren wird der VCard Export gestartet.

Hinweis:

MS OutlookTM unterstützt nur VCard Version 2.1 in einzelnen Dateien.


Einstellungen

Im Bereich Einstellungen können Einstellungen und Stammdaten zur Adressverwaltung konfiguriert und auf Ihre Wünsche angepasst werden.

Die Einstellungen werden in der Backstage-Ansicht unter Konfiguration aufgerufen.

Verfügbare Einstellungen:

Zuordnungen | Konfiguration der sichtbaren Felder und Verwaltung der Zuordnungen.
Informationsfluss | Informationsfluss-Arten verwalten.
Anreden | Anreden verwalten.
Ausweisformen | Ausweisformen verwalten.
Zivilstände | Zivilstände verwalten.
Branchen | Branchen verwalten.
Interessen | Verfügbare Werte des Feldes "Interessen" verwalten.
Eigenschaften | Verfügbare Werte des Feldes "Eigenschaften" verwalten.
Externe Feldeinstellungen | Zuordnungen der Adressfelder für den Import.
Outlook Import | Zuordnungen der Outlook-Felder zu den verfügbaren Adressfeldern.
Berichte | Verwaltung der Vorlagen für die Berichte der Adressverwaltung.
Länder | Verwaltung der Ländertabelle.
Sprachen | Verwaltung der Sprachen
Postleitzahlen/Regionen | Verwaltung des Postleitzahlenverzeichnisses.
Banken | Verwaltung der Bankentabelle.
Status | Status der Adressen verwalten.
Kontaktpersonen | Typen von Kontaktpersonen verwalten.
Eigene Adresse | Eigene Adresse definieren.
Makros | Makros für Adressen verwalten.
Schnellfilter | Felder für den Namen-Schnellfilter definieren.
Klassifizierung | Klassifizierungen für Adressen verwalten.
Tätigkeitsstatus | Die verschiedenen Tätigkeitsstatus verwalten.


Zuordnungen

Hier können Zuordnungen erstellt und bearbeitet werden. Es können beliebig viele Zuordnungen erfasst werden.

Die Zuordnungsart bestimmt, welche Art von Adressen eine Zuordnung enthält. Ist es z.B. irgendwo im Programm erforderlich, dass alle Mitarbeiter angezeigt werden, so werden an dieser Stelle alle Adressen aus den Zuordnungen mit der Zuordnungsart "Mitarbeiter" angezeigt.

siehe auch:

Zuordnung hinzufügen

Details

Adresse erfassen

Allgemeine Dokumentation:

Tabellen


Zuordnung hinzufügen

Durch klicken auf die Schaltfläche Hinzufügen kann eine neue Zuordnung hinzugefügt werden.

Geben Sie einen Namen für die neue Zuordnung ein und klicken Sie auf die

Schaltfläche Speichern um die Zuordnung zu erfassen.

Allgemeine Dokumentation:

Datensatz hinzufügen


Informationsfluss

Dieser Bereich ist nur im Produkt "delight address" verfügbar.

Hier können die Informationsfluss-Arten definiert werden.

Diese stehen als Kategorie unter Informationsfluss zur Verfügung.

Über die Schaltfläche Auf allen Adressen löschen können alle Einträge im Informationsfluss auf allen Adressen gelöscht werden.

Achtung: Die Einträge werden unwiderruflich gelöscht!

Allgemeine Dokumentation:

Tabellen


Anreden

Hier können die verfügbaren Anreden für die Adressen definiert werden.

Diese stehen z.B. unter Details in der Auswahlliste des Feldes Anrede zur Verfügung.

Allgemeine Dokumentation:

Tabellen


Ausweisformen

Hier können die verfügbaren Ausweisformen für die Adressen definiert werden.

Diese stehen z.B. unter Details in der Auswahlliste des Feldes Ausweis zur Verfügung.

Allgemeine Dokumentation:

Tabellen


Zivilstände

Hier können die verfügbaren Zivilstände für die Adressen definiert werden.

Diese stehen z.B. unter Details in der Auswahlliste des Feldes Zivilstand zur Verfügung.

Allgemeine Dokumentation:

Tabellen


Branchen

Hier können die verfügbaren Branchen für die Adressen definiert werden.

Diese stehen z.B. unter Details in der Auswahlliste des Feldes Branche zur Verfügung.

Allgemeine Dokumentation:

Tabellen


Interessen

Hier können die verfügbaren Interessen für die Adressen definiert werden.

Diese stehen z.B. unter Details in der Auswahlliste des Feldes Interessen zur Verfügung.

Allgemeine Dokumentation:

Tabellen


Eigenschaften

Hier können die verfügbaren Eigenschaften für die Adressen definiert werden.

Diese stehen z.B. unter Details in der Auswahlliste des Feldes Eigenschaften zur Verfügung.

Allgemeine Dokumentation:

Tabellen


Externe Feldeinstellungen

Hier können die Einstellungen für den VCard Import und Export sowie für die Synchronisation mit externen Adress-Quellen definiert werden.

Feldzuordnungen:

Hier wird definiert, wie die Felder der Datenbank beim Importieren und Exportieren zu den Feldern der VCard zugeordnet werden.

In der linken Spalte sind alle verfügbaren Felder der Adressen ersichtlich. In der rechten Spalte sind alle Felder aufgeführt, die bei einer VCard verfügbar sind.

Wählen Sie in den Auswahlmenüs (rechts) ein VCard-Feld, um es einem Adressfeld zuzuordnen.

Schlüsselfelder:

Die hier markierten Felder werden beim Importieren von Adress-Daten verwendet. Mit diesen Feldern wird geprüft, ob eine Adresse bereits existiert.


Outlook Import

Hier können die Einstellungen für den Outlook Import definiert werden.

Feldzuordnungen:

Hier wird definiert, wie die Felder der Datenbank beim Importieren den Feldern von Outlook zugeordnet werden.

In der linken Spalte sind alle verfügbaren Felder der Adressen ersichtlich. In der rechten Spalte sind alle Felder aufgeführt, die bei Outlook verfügbar sind.

Wählen Sie in den Auswahlmenüs (rechts) ein Outlook-Feld, um es einem Adressfeld zuzuordnen.


Berichte

Dieser Unterbereich ist nur im Produkt "delight address" verfügbar.

Hier können die Einstellungen für die Berichte-Vorlagen der Adressverwaltung verwaltet werden.

Um diese Funktion zu nutzen, muss das Berichte-Modul installiert sein.

Informationsfluss-Art:

Wählen Sie aus der Auswahlliste eine Informationsfluss-Art die beim Erstellen des Berichtes auf einer Adresse erfasst werden soll.

Die Vorlagen können im Vorlageneditor des Berichte-Modules erstellt und bearbeitet werden.

Dokumentation Berichte-Modul:

Berichte-Modul

Vorlageneditor


Länder

Hier können die verfügbaren Länder für die Adressen definiert werden.

Diese stehen z.B. unter Details in der Auswahlliste der Felder Land oder Nationalität zur Verfügung.

Allgemeine Dokumentation:

Tabellen


Sprachen

Hier können die verfügbaren Sprachen für die Adressen definiert werden.

Diese stehen z.B. unter Details in der Auswahlliste der Feldes Korrespondenz-Sprache zur Verfügung.

Allgemeine Dokumentation:

Tabellen


Postleitzahlen/Regionen

Hier können die verfügbaren Postleitzahlen für die Adressen definiert werden.

Diese wird z.B. beim Erfassen einer Adresse verwendet, um nach Eingabe der Postleitzahl automatisch den Ort auszufüllen.

Jede Postleitzahl kann einer Region zugeordnet werden.

Allgemeine Dokumentation:

Tabellen


Regionen

Hier können die Regionen für die Postleitzahlen definiert werden.

Die Regionen können den Postleitzahlen zugeordnet werden.

Optional kann jeder Region ein Kanton/Bundesland zugeordnet werden.

Allgemeine Dokumentation:

Tabellen


Kantone/Bundesländer

Hier können die Kantone/Bundesländer für die Postleitzahlen definiert werden.

Die Kantone/Bundesländer können den Postleitzahlen zugeordnet werden.

Allgemeine Dokumentation:

Tabellen


Banken

Hier können die verfügbaren Banken für die Adressen definiert werden.

Diese stehen z.B. unter Details in der Auswahlliste des Feldes Bank zur Verfügung.

Allgemeine Dokumentation:

Tabellen


Status

Hier kann der verfügbare Status für die Adressen definiert werden.

Diese stehen z.B. unter Details in der Auswahlliste des Feldes Status zur Verfügung.

Allgemeine Dokumentation:

Tabellen


Kontaktpersonen

Hier können die verfügbaren Typen von Kontaktpersonen definiert werden.


Eigene Adresse

Hier kann die eigene Adresse definiert werden.

Die eigene Adresse wird z.B. für die Kopfzeilen in Berichtvorlagen verwendet.

Die eigene Adresse ist entweder Ihre Firmenadresse oder Ihre private Adresse, je nach dem, wie Sie das Programm einsetzen.

Über Erweiterte Einstellungen kann die Verknüpfung auf eine andere, bereits im Programm erfasste Adresse geändert werden.


Makros

Hier können die Adressmakros definiert werden.

Makros werden z.B. für die persönliche Anrede auf Berichtvorlagen verwendet.


Schnellfilter

Hier kann definiert werden, welche Adress-Felder der Schnellfilter zur Suche nach Name und Vorname in die Suche einbeziehen soll.


Klassifizierung

Hier können die Klassifizierungen für die Adressen verwaltet werden. Jeder Klassifizierungsart können mehrere "Funktionen" zugeordnet werden.


Tätigkeitsstatus

Hier kann der Tätigkeitsstatus für Adressen verwaltet werden.


Dubletten-Prüfung

Die Dubletten-Prüfung befindet sich im Hauptmenü unter Tools => Dubletten-Prüfung.

Mit der Dubletten-Prüfung kann anhand verschiedener Kriterien nach doppelt vorhandenen Adressen gesucht werden.

Werden doppelt vorhandene Adressen gefunden, können diese zusammengeführt und bereinigt werden.

siehe auch:

Optionen


Optionen

In den Optionen können verschiedene Kriterien zur Suche nach Dubletten vorgenommen werden.


Dubletten bereinigen

Hier werden alle Dubletten, die anhand der Kriterien gefunden wurden, aufgelistet.

Achtung: Es müssen nicht unbedingt alles Dubletten sein, die hier angezeigt werden!

Hier werden alle Adressen, die anhand der eingestellten Kriterien für identisch befunden wurden, angezeigt. Mit einem Klick auf Zurück können die Kriterien geändert werden und es kann erneut nach Dubletten gesucht werden.

(Hier wurden zwei Dubletten mit jeweils zwei Adressen gefunden)

Mit Rechts-Klick auf eine Adresse kann das Menü zur Bearbeitung der Dubletten aufgerufen werden.

Zum bereinigen der doppelten Adressen muss eine Adresse als Referenz und die anderen zur Löschung markiert werden.

Die Referenz-Adresse wird beibehalten und mit den Daten der anderen (zur Löschung markierten) Adressen ergänzt.

Im Oben gezeigten Bild ist "Petra Müller Müllerei 23" als Referenz markiert und die durchgestrichene Adresse ist zur Löschung markiert. Die Dublette "Hubert Specht 06.06.1965" wurde noch nicht bearbeitet.

Über Änderungen automatisch bestimmen wird automatisch auf allen Dubletten die erste Adresse als Referenz und alle anderen Adressen zur Löschung markiert.

Achtung:

Bitte prüfen Sie unbedingt die automatisch bestimmten Änderungen vor dem Speichern und stellen Sie sicher, dass es sich bei allen Dubletten wirklich um doppelt vorhandene Adressen handelt!

Mit Klick auf Abschliessen werden die vorgenommenen Änderungen gespeichert.


Geburtstagsliste

Die Geburtstagsliste befindet sich im Hauptmenü unter Tools => Geburtstagsliste.

Es werden alle Adressen, die in den nächsten x Tagen Geburtstag haben, angezeigt. Über einen Doppelklick auf die gewünschte Adresse kann diese in der Adressverwaltung geöffnet werden.

Über die Schaltfläche Tage ändern können Sie einstellen, wie viele Tage vor dem Geburtstag eine Adresse in dieser Liste erscheinen soll.

Über die Schaltfläche Markierung bearbeiten können Sie Einträge markieren und demarkieren. Als erledigt markierte Einträge erscheinen erst im nächsten Jahr wieder in der Geburtstagsliste. Wenn Sie Einträge mit dem Status erledigt trotzdem anzeigen möchten, verwenden Sie die Option Erledigte ausblenden/demarkieren. Einträge mit dem Status erledigt werden in der Liste grün angezeigt.

Ist die Option Beim Programmstart automatisch suchen markiert, werden bei jedem Programmstart automatisch Geburtstage gesucht und angezeigt.

Hinweis:

Die Geburtstagsliste kann optional auf der Startseite eingeblendet werden.


einen Serienbrief erstellen?

Die Serienbrief-Funktion in delight address ist die einfacher gehaltene Variante der weit umfangreicheren Serienbrief-Funktionen in den grösseren Programme wie z.B. delight crm oder delight insurance..

Die Serienbrief-Funktion ist nicht in allen Produkten vorhanden. Serienbriefe sind auch in delight address, nicht aber in delight email möglich.

Serienbrief erstellen:

1. Öffnen Sie die Vorlagenverwaltung

2. Wählen Sie in der Baumansicht Adresslisten

Klappen Sie den Ordner Serienbriefe aus und markieren Sie eine bestehende Serienbrief-Vorlage, die Sie als

Basis (Kopie) für ihren neuen Serienbrief verwenden möchten.

Es gibt zwei verschiedene Möglichkeiten/Technologien, um einen Serienbrief zu erstellen. Zum einen können Sie eine Word/OpenOffice Briefvorlage erstellen, oder sie wählen den internen Designer. Mit dem internen Designer ist kein externes Programm (wie z.B. Word oder OpenOffice) erforderlich, das Bearbeiten der Briefvorlage ist allerdings etwas umständlicher als mit Word oder OpenOffice. Bei sehr vielen Serienbriefen (mehreren 1000 Seiten) ist der interne Designer aus Geschwindigkeitsgründen aber unbedingt zu empfehlen.

In dieser Anleitung wird nur das Erstellen eines Word-Serienbriefes in einem für die meisten Anwender einfachsten und passendsten Beispiel beschrieben. Bei der Standard-Installation ist dazu die Vorlage "Serienbrief-Vorlage Word oder OpenOffice (leer)" installiert.

3. Rechts-Klicken sie auf die Vorlage und wählen Sie Kopie erstellen.

4. Geben Sie für die neue oder kopierte Vorlage im Eingabefeld Titel den gewünschten Namen des Serienbriefes an. (z.B. Neujahrsgruss 2010).

5. Führen Sie einen Doppelklick auf die Vorlage aus. Damit wird die Serienbriefvorlage im Office-Paket (Word, OpenOffice...) zu Bearbeitung geöffnet.

Ändern und gestalten Sie die Briefvorlage nach ihren Wünschen.

Zu beachten bei Vorlagen in Word oder OpenOffice:

·Der Text \Scan(a), PAGE\ muss immer ganz zuoberst auf der Seite stehen.

·Der Text \endscan\ muss immer ganz zu unterst auf der Seite stehen.

Um Inhalte (Platzhalter) aus der Adressdatenbank einzufügen, werden sogenannte Makros verwendet. Um z.B. den Namen des Empfängers einzufügen wird das Makro \a:name\ verwendet. Makros stehen immer zwischen zwei \\.

Anmerkung: Welche Makros zur Verfügung stehen, können Sie in der Vorlagenverwaltung mit einem Rechtsklick auf die Vorlage => Feldliste nachschauen. Um das jetzt an dieser Stelle zu tun, müssen Sie die Textverarbeitung (Word, OpenOffice...) wieder schliessen. Haben Sie die Feldliste geöffnet, können Sie bei geöffneter Feldliste die Vorlage wieder mit einem Doppelklick öffnen und weiterbearbeiten. Falls Sie die Makros benötigen, können Sie die Feldliste in Zukunft gleich schon vor Schritt 5 anzeigen.

6. Wenn Sie die Vorlage nach Ihren Wünschen bearbeitet und geschaltet haben, schliessen Sie die Textverarbeitung (Word, OpenOffice...). Beantworten Sie die Frage, ob das Dokument gespeichert werden soll, mit JA.

7. Wechseln Sie in das Menü Adresslisten.

8. Filtern Sie die Adressliste so, dass diese alle Adressen, die einen Serienbrief erhalten sollen, anzeigt. Es ist auch möglich, einzelne Adressen über Mehrfachselektion auszuwählen. Sobald mehr als eine Adresse markiert ist, wird der Serienbrief nur für alle markierten Adressen erstellt.

9. Klicken Sie im Menü auf Berichte => Adresslisten => Serienbriefe und wählen Sie den in Schritt 4 benannten Serienbrief.

10. Ist der Serienbrief erstellt, wird er automatisch im Textverarbeitungsprogramm geöffnet. Sie können den Serienbrief nun prüfen und drucken. Für weitere Änderungen können Sie die Textverarbeitung ohne zu speichern wieder schliessen und nochmals zurück zu Schritt 5 gehen.

siehe auch:

Handbuch Referenz RTF-Berichte

Handbuch Designer


Allgemeines Benutzerhandbuch

In diesem Handbuch werden allgemeine Funktionen zum Programm beschrieben. Informationen zu den einzelnen Programmteilen finden Sie jeweils in einem separaten Handbuch zu jedem Programmteil. Wenn Sie sich im Hilfe & Support Zentrum befinden, können Sie in der Liste links zum gewünschten Handbuch navigieren.

Basierend auf

delight base Framework

by delight software gmbh

siehe auch:

Benutzer am Programm anmelden

Online Update, um Ihre Anwendung auf den neusten Stand zu bringen

Die Programmoberfläche

Konfiguration Ihrer Anwendung


Programmoberfläche

Die Programmoberfläche kann je nach Konfiguration und Ausstattung Ihres Softwarepakets Abweichungen vom unten gezeigten Beispiel haben.

1. | Hauptmenü der Anwendung, um in die verschiedenen Programmbereiche der Anwendung zu navigieren. Je nach dem, in welchem Programmbereich der Anwendung Sie sich gerade befinden, stehen hier unterschiedliche Funktionen zur Verfügung.
2. | Arbeitsbereich der Anwendung, in welchem die verschiedenen Programmbereiche dargestellt werden.
3. | Statusliste mit aktuellen Informationen, wie z.B. der gerade geöffnete Programmbereich oder bei der Netzwerk-Version der angemeldete Benutzer.
4. | In der rechten, unteren Ecke ist der Status der Anwendung ersichtlich. grün = Anwendung hat nichts zu tun und wartet auf eine Aktion des Anwenders. rot = Anwendung ist beschäftigt.
5. | Backstage-Ansicht der Anwendung. Hier sind Handbücher, Hilfe sowie Einstellungen und Konfigurationsmöglichkeiten verfügbar.

siehe auch:

Startseite einstellen

Tabellen

Detailanzeige

Zusatzfunktionen der Datensätze

Konfiguration


Tabellen

Die Anwendung verfügt dank ihrer Bedienerfreundlichkeit über frei modellierbare Tabellen, die sich nach Ihren Wünschen anpassen lassen.

Je nach dem, welche Daten in einer Tabelle angezeigt werden, stehen verschiedene Funktionen und Möglichkeiten zur Verfügung.

Im oberen Bereich befinden sich die Schaltflächen mit den verfügbaren Funktionen. Gleich darunter befindet sich der Gruppierungsbereich. Um nach einer bestimmten Spalte zu gruppieren, können Sie die Spaltenüberschrift mit der Maus in diesen Bereich ziehen.

Weitere Funktionen und Einstellungen für die Tabelle und Spalten erreichen Sie über das Kontextmenü der Spaltenüberschrift.

siehe auch:

Datensätze sortieren

Datensatz editieren

Mehrfach editieren

Datensatz löschen

Datensatz hinzufügen

Tabellen filtern

Zusätzliche Funktionen

Schnellfilter


Datensätze sortieren

Klicken Sie auf eine Spaltenüberschrift, um die Daten nach dem Inhalt der Spalte zu sortieren. Beim ersten Klick werden die Daten aufsteigend sortiert. Bei einem zweiten Klick auf die gleiche Spaltenüberschrift werden die Daten absteigend sortiert. Wenn eine Spalte sortiert ist, wird dies über Pfeile entsprechend dargestellt.

Eine Tabelle kann auch nach mehreren Spalten gleichzeitig sortiert werden. Halten Sie dazu die Shift-Taste (Umschalt-Taste) während dem Klicken gedrückt.

siehe auch:

Sortierung entfernen


Sortierung entfernen

Mit Rechtsklick auf die Spaltenüberschrift kann die Sortierung wieder gelöscht werden.


Datensatz bearbeiten

Die Daten einer Tabelle können wahlweise über ein Bearbeitungsfenster oder direkt in der Tabelle bearbeitet werden.

Um Daten direkt in der Tabelle zu bearbeiten, klicken Sie auf die gewünschte Zelle und drücken Sie [Enter].

Markieren Sie einen Datensatz, und klicken Sie auf Bearbeiten, um einen Datensatz zu bearbeiten.

Führen Sie Ihre Änderungen durch und bestätigen Sie danach mit Speichern, um die Änderungen zu speichern.

Mit Abbrechen können Sie das Fenster ohne zu speichern verlassen.

siehe auch:

Mehrfach editieren


Mehrfach bearbeiten

Es können mehrere Datensätze gleichzeitig bearbeitet werden. Markieren Sie dazu vor dem Bearbeiten alle gewünschten Datensätze.

Sind mehrere Datensätze markiert, werden Sie vor dem Bearbeiten gefragt, ob Sie wirklich alle Datensätze gleichzeitig bearbeiten möchten.

Das gleichzeitige Bearbeiten von Datensätzen funktioniert nur über das Bearbeitungsfenster.

siehe auch:

Mehrere Datensätze markieren


Datensatz löschen

Markieren Sie einen Datensatz und klicken Sie auf Löschen, um einen Datensatz zu löschen.

Wenn mehrere Datensätze markiert sind, werden alle Datensätze gelöscht.

Achtung:

Die markierten Datensätze werden unwiderruflich gelöscht und können nicht wiederhergestellt werden!


Datensatz hinzufügen

Klicken Sie auf die Schaltfläche Hinzufügen, um einen neuen Datensatz anzulegen.

Führen Sie Ihre Eingaben durch und bestätigen Sie danach mit Speichern, um den Datensatz zu speichern.

Mit Abbrechen können Sie das Fenster ohne zu speichern verlassen.


Tabellen filtern

Es gibt mehrere Möglichkeiten, um die Daten einer Tabelle zu filtern.

Folgende Möglichkeiten stehe zur Verfügung:

· Spaltenüberschriften-Filter

· Schnellfilter

· Erweiterte Suche


Filter über Spaltenüberschrift

Über die Spaltenüberschrift können Sie sehr schnell und einfach die gewünschten Datensätze filtern.


Filter

Klicken Sie in der gewünschten Tabelle auf die Schaltfläche Filter um den Schnellfilter oder die Filtervorgaben zu öffnen.


Schnellfilter

Klicken Sie in den Daten-Bereich der Tabelle und drücken Sie die Tastenkombination Ctrl+F, um die Schnellfilteransicht zu öffnen. Alternativ kann dazu auch in der gewünschten Tabelle auf die Schaltfläche Filter => Schnellfilter geklickt werden.

In der Schnellfilteransicht kann die Anzeige der Datensätze gefiltert werden.

Nach Eingabe der gewünschten Suchbegriffe kann die Suche mit [Enter] gestartet werden. Der Schnellfilter sucht nach allen Inhalten, in denen die Suchbegriffe komplett oder teilweise vorkommen. Die Eingabe von * ist nicht erforderlich.

siehe auch

Erweiterte Suche


Filtervorgaben

Um nur bestimmte Datensätze anzuzeigen, können Sie die Datensätze nach sämtlichen, möglichen Kriterien filtern. Diese Filter können als Filtervorgabe gespeichert werden und stehen danach mit einem Klick im Menü Filter zur Verfügung.


Filter bearbeiten

Mit der Schaltfläche Feld hinzufügen können die Suchfelder, nach denen gefiltert werden soll, hinzugefügt werden. Über die Schaltfläche Gruppe hinzufügen können Suchgruppen hinzugefügt werden.

Auf Suchfeldern können folgende Angaben gemacht werden:

Verknüpfung:

Die Verknüpfung legt fest, wie das Suchfeld zum vorhergehenden Suchfeld verknüpft wird.

und | Alle Bedingungen müssen erfüllt sein.
oder | Mindestens eine der Bedingungen muss erfüllt sein.
und nicht | Zusätzlich darf diese Bedingung nicht erfüllt sein.

Bedingung:

Mit der Auswahlmöglichkeit (gleich, grösser als, usw.) legen Sie die Bedingung zwischen Feld und Wert fest.

gleich | Nur Datensätze, die den gleichen Wert im entsprechenden Feld haben.
grösser als | Nur Datensätze, die einen grösseren Wert im entsprechenden Feld haben.
kleiner als | Nur Datensätze, die einen kleineren Wert im entsprechenden Feld haben.
grösser gleich wie | Nur Datensätze, die den gleichen oder einen grösseren Wert im entsprechenden Feld haben.
kleiner gleich wie | Nur Datensätze, die den gleichen oder einen kleineren Wert im entsprechenden Feld haben.
ungleich wie | Nur Datensätze, die nicht den Wert im entsprechenden Feld haben.
ähnlich wie | Nur Datensätze, die einen ähnlichen Wert im entsprechenden Feld haben. Hier kann mit dem Platzhalterzeichen * gearbeitet werden. Der Suchwert PET* würde alle Datensätze zurückgeben, bei denen das entsprechende Feld mit dem Wert PET beginnt.
in verknüpfter Tabelle enthalten | Nur Datensätze, die auf eine andere Datentabelle verknüpft sind. In Wert kann die gewünschte Tabelle und das entsprechende Verknüpfungsfeld ausgewählt werden. Sobald ein Eintrag mit dieser Bedingung markiert ist, stehen unter Feld hinzufügen die Felder der Verknüpfungstabelle zur Auswahl. Damit lässt sich die Verknüpfungstabelle zusätzlich nach bestimmten Kriterien/Feldern filtern.
nicht in verknüpfter Tabelle enthalten | Nur Datensätze, die nicht auf einer anderen Datentabelle verknüpft sind. In Wert kann die gewünschte Tabelle und das entsprechende Verknüpfungsfeld ausgewählt werden. Sobald ein Eintrag mit dieser Bedingung markiert ist, stehen unter Feld hinzufügen die Felder der Verknüpfungstabelle zur Auswahl. Damit lässt sich die Verknüpfungstabelle zusätzlich nach bestimmten Kriterien/Feldern filtern.

Wert:

Geben Sie den gewünschten Wert, den Sie auf dem Suchfeld filtern möchten, im Eingabefeld ein.

Mit den Gruppierungen können Sie Suchfelder gruppieren (Gruppierungen entsprechen Klammern).

Auf einer Gruppe kann wie bei Suchfeldern die Verknüpfung angegeben werden.

Mit Filter anwenden werden die definierten Filter auf die Tabelle angewendet.

siehe auch:

Filter löschen

Filtervorgaben


Filter löschen

Über die Schaltfläche Neu können alle Filtereinträge entfernt werden.


Filtervorgaben

Filterdefinitionen können für die spätere Verwendung als Vorgabe gespeichert werden. In der Netzwerk-Version können Vorgaben zusätzlich auch global für alle Benutzer abgelegt werden. Dazu muss der Anwender die entsprechende Berechtigung besitzen.

Durch Klicken auf eine Vorgabe wird diese geladen und die Schaltfläche Filter anwenden wird aktiviert.

Vorgaben können unten rechts über dem kleinen Pfeil erstellt und bearbeitet werden.

Anmerkung:

Durch Klicken auf eine Vorgabe werden "nur" die Filterdefinitionen der Vorgabe geladen und aktiviert. Wenn die Filtervorgaben danach editiert werden, wird die Vorgabe dadurch nicht beeinflusst. Sofern Sie die Änderungen speichern möchten, müssen Sie die Vorgabe erneut speichern.


Filter importieren & exportieren

Im Menü Import & Export kann der eingestellte Filter exportiert und importiert werden. Es wird nur der Inhalt des Filters exportiert/importiert und nicht die komplette Filtervorgaben. Wenn Sie eine Filter importieren und diesen als Filtervorgaben verwenden möchten, müssen Sie den Filter nach dem Import als Filtervorgaben speichern.


Daten gruppieren

Die Daten einer Tabelle können nach praktisch jedem Feldinhalt gruppiert werden.

Sofern der Gruppierungsbereich noch nicht sichtbar ist, muss dieser mit Rechtsklick auf die Spaltenüberschrift eingeblendet werden.

Ziehen Sie die gewünschte Spaltenüberschrift mit der Maus auf den Gruppierungsbereich oben an der Tabelle.

Um Untergruppen darzustellen können auch mehrere Spaltenüberschriften nacheinander in den Gruppierungsbereich gezogen werden.


Aggregatfunktionen (Summen, Anzahl usw.)

Mit den Aggregatfunktionen können verschiedene Informationen wie z.B. Anzahl, Durchschnitt, Summen usw. in einer Spalte berechnet werden.

Sofern die Fusszeile noch nicht sichtbar ist, muss diese mit Rechtsklick auf die Spaltenüberschrift eingeblendet werden.

Klicken Sie mit der rechten Maustaste auf der Fusszeile unter der gewünschten Spalte und wählen Sie die gewünschte Funktion.


Ansichten

Für jede Tabelle können verschiedene Ansichten erstellt und gespeichert werden. In einer Ansicht werden unter anderem die Spaltenbreiten, Positionen der Spalten, Sortierung, Sichtbarkeit der Spalten, Gruppierungen, Fusszeile und verwendete Aggregatfunktionen gespeichert.

Die Ansichten werden über die Schaltfläche Ansicht verwaltet.


Ansicht speichern

Um eine Ansicht zu speichern, klicken Sie auf Ansicht.

Klicken Sie auf Speichern unter, um die Ansicht zu speichern. Falls Sie die Netzwerk-Version verwenden und die entsprechende Berechtigung besitzen, können Sie die Ansicht mit Speichern unter für alle Benutzer global für alle Benutzer speichern. In diesem Fall steht die Ansicht nach dem Speichern allen anderen Benutzern des System ebenfalls zur Verfügung.


Ansicht laden

Um eine Ansicht zu laden, klicken Sie auf Ansicht.

Wählen Sie die gewünschte Ansicht.

Zur Auswahl stehen alle globalen Ansichten sowie alle, die Sie selbst für diese Tabelle gespeichert haben.


Ansicht zurücksetzen

Mit dem Zurücksetzen der Ansicht wird die Ansicht der Tabelle in den "Werkszustand" zurückgesetzt. Alle Filter, Aggregatfunktionen (Summen, Anzahl usw.) werden entfernt, alle Spalten werden eingeblendet und nach Alphabet sortiert.

Um eine Ansicht zurückzusetzen, klicken Sie auf Ansicht und wählen Sie Ansicht zurücksetzen.


Mehrere Datensätze markieren

In einer Tabelle können mehrere Datensätze markiert werden. Die Markierungsfunktionen entsprechen dem in Windows üblichen Standard.

Markierungsfunktionen:

·Um einzelne Datensätze zu markieren, halten Sie die Ctrl (in deutsch Strg) Taste gedrückt und klicken Sie mit der linken Maustaste alle gewünschten Datensätze an.

·Um ab einem Datensatz bis zu einem bestimmten Datensatz (von-bis) zu markieren, klicken Sie den 1. Datensatz mit der linken Maustaste an, drücken und halten die Shift-Taste (Umschalttaste), während Sie den letzten Datensatz mit der linken Maustaste anklicken.

·Drücken Sie Ctrl (in deutsch Strg) und gleichzeitig A (Ctrl-A/Strg-A), um alle Datensätze zu markieren.


Zusätzliche Funktionen

Markieren Sie einen Datensatz und betätigen Sie die Schaltfläche Funktionen, um alle zusätzlich installierten Funktionen aufzurufen,

die für den Datensatz verfügbar sind.

Funktionen für die ganze Tabelle werden immer angezeigt, unabhängig davon, ob ein Datensatz markiert wurde.

Klicken Sie auf den gewünschten Eintrag, um die entsprechende Funktion zu starten.

Hinweis:

Welche Funktionen Sie zur Verfügung haben hängt von der Ausstattung und Konfiguration Ihrer Anwendung ab.


Zusatzfunktionen der Datensätze

Gewisse Felder besitzen Zusatzfunktionen. Typische Felder mit Zusatzfunktionen sind z.B. Felder mit einer Internetadresse oder einer E-Mail-Adresse.

Bei der Detailanzeige werden die Symbole der Zusatzfunktionen direkt auf dem jeweiligen Feld angezeigt.

Zeigt die Detaildaten des verknüpften Feldes.

Neue Email an die E-Mail-Adresse schreiben.

Öffnet die Internetseite.

Wählt die Telefonnummer.


Detailanzeige eines Datensatzes

In der Detailanzeige werden die Details eines Datensatzes angezeigt.

Klicken Sie auf den Feldtitel oder den Feldwert, um ein Feld zu bearbeiten. Im Eingabemodus können Sie mit der

Tabulator-Taste auf das nächste Feld springen. Mit der Eingabe-Taste (Enter) können Sie die Eingabe speichern.

Mit der ESC-Taste können Sie die Eingabe abbrechen.

Ob die Felder bearbeitet werden können hängt von der jeweiligen Ansicht ab.

Siehe auch:

Zusatzfunktionen der Datensätze


Benutzer am Programm anmelden

Das Programm in der Netzwerk-Version bietet zwei verschiedene Möglichkeiten, einen Benutzer am Programm anzumelden. Die Einzelbenutzer-Version beinhaltet keine Benutzerverwaltung und startet ohne Passwortabfrage.

Anmeldungsarten der Netzwerk-Version:

Normale Anmeldung | Anmeldung mit Benutzername und Passwort.
Windows Anmeldung | Benutzername und Passwort von Windows verwenden.


Normale Anmeldung

Wenn Sie das Programm starten, müssen Sie sich mit Benutzername und Passwort anmelden.

Die einzelnen Benutzer können in der Benutzerverwaltung verwaltet werden.

Hinweis:

Das Handbuch für die Benutzerverwaltung steht nur in der Netzwerk-Version zur Verfügung.


Windows Anmeldung

Wenn Sie die Windows Anmeldung verwenden, müssen Sie sich im Gegensatz zur normalen Anmeldung nicht mit Benutzername und Passwort anmelden.

Die Anwendung verwendet Ihren Benutzernamen und das Passwort, mit dem Sie bei Windows angemeldet sind, und meldet Sie damit automatisch an.

Wenn der Benutzername und das Passwort des Programms mit Ihrer Windows-Anmeldung übereinstimmt, wird automatisch die Windows-Anmeldung verwendet. Die einzelnen Benutzer können in der Benutzerverwaltung verwaltet werden.

Hinweis:

Das Handbuch für die Benutzerverwaltung steht nur in der Netzwerk-Version zur Verfügung.


Startseite

Auf der Startseite des Programms können verschiedene Informationen eingeblendet werden. Jeder Benutzer kann selbst bestimmen, welche Informationen er auf seiner persönlichen Startseite sehen möchte. Grösse und Position der einzelnen Elemente können ebenfalls selbst bestimmt werden.

Zur Startseite gelangen Sie durch klick auf den Button Startseite oben links.


Konfigurieren

Die Startseite kann im Reiter Start konfiguriert werden.

Hinweis:

Welche Informationen auf der Startseite zur Verfügung stehen hängt von der Ausstattung Ihres Software-Paketes ab.


Backstage-Ansicht

In der sogenannten Backstage-Ansicht sind Konfiguration, Einstellungen, Handbücher, Hilfe, Online Update usw. untergebracht.

Die Backstage-Ansicht [image] kann oben links in der Anwendung angezeigt werden.


Hilfe

Im Bereich Hilfe befinden sich Handbücher, Onlinehilfe, Online-Update und weitere Informationen.


Hilfe & Support Zentrum

Über die Backstage-Ansicht => Hilfe => Handbücher und Onlinehilfe können Sie die Handbücher zu Ihrer Anwendung einsehen.


Online Update

Mit dem Online Update können Sie Ihre Anwendung auf den neuesten Stand bringen.

Das Online Update prüft für alle Module, die lizenziert sind, ob eine neuere Version verfügbar ist. Wenn neue Versionen gefunden werden, haben Sie die Möglichkeit, diese herunterzuladen und anschliessend zu installieren.

Sie erreichen die Online Update Funktion der Backstage-Ansicht unter Hilfe => Online Update

siehe auch:

Updates installieren


Updates installieren

1. Starten Sie das Update mit der Update Funktion in der Backstage-Ansicht unter Hilfe => Online Update

2. Klicken Sie auf Weiter. In der Liste "Neue Updates" sehen Sie alle verfügbaren Updates.

Wenn Sie auf "Details" klicken, werden detailliertere Informationen zu den Neuerungen des Updates angezeigt.

3. Klicken Sie erneut auf Weiter. Die Updates werden heruntergeladen und anschliessend installiert.


Online registrieren

Mit der Online-Registrierung können Sie Ihren persönlichen Lizenzschlüssel im Programm registrieren. Wenn es sich bei Ihrem Lizenzschlüssel um eine Vollversion handelt, wird damit die Vollversion der Software freigeschaltet.

Sie erreichen die Online-Registrierung der Backstage-Ansicht unter Hilfe => Online-Registrieren

Anmerkung:

Die Online-Registrierung steht nur für Demo-Versionen zur Verfügung. Bei Vollversionen steht an dieser Stelle der Menüpunkt Lizenz aktualisieren.


Lizenz aktualisieren

Über die Lizenzaktualisierung können Sie Ihre bestehende Lizenz aktualisieren. Dies ist z.B. erforderlich, wenn Sie neue Erweiterungsmodule erworben haben und diese auf Ihrer Lizenz aufgeschaltet wurden, oder wenn die Laufzeitbeschränkung nach Bezahlung der Rechnung aufgehoben wurde. Falls Sie neue Erweiterungsmodule erworben haben, sollten Sie nach der Lizenzaktualisierung ein Online-Update ausführen. Damit werden die neuen Module vollautomatisch installiert.

Sie erreichen die Online-Registrierung der Backstage-Ansicht unter Hilfe => Lizenz aktualisieren

Anmerkung:

Die Lizenzaktualisierung steht nur für Voll-Versionen zur Verfügung. Bei Demo-Versionen steht an dieser Stelle der Menüpunkt Online registrieren.


Module

Hier sehen Sie welche Module in Ihrem System geladen wurden. Zu jedem Modul wird die Lizenzierung und die Versionsnummer angezeigt

Sie finden die Modulinformationen in der Backstage-Ansicht unter Hilfe => Module

Module sind variable "Bausteine" der Anwendung, die dynamisch geladen werden. Jedes Modul stellt bestimmte Funktionalitäten zur Verfügung.

Module können von einem Administrator auf einfache Weise hinzugefügt oder entfernt werden. Durch die Verwendung dieser Technologie ist die Anwendung sehr flexibel, was die Erweiterbarkeit, Übersichtlichkeit und Wiederverwendbarkeit betrifft.

Die meisten Module benötigen eine Lizenzierung. Wenn diese nicht vorhanden ist, kann das Modul nicht verwendet werden.

Informationen zu weiteren verfügbaren Modulen erhalten Sie bei delight software gmbh oder dem Lieferanten Ihrer Software.


Lizenzinformationen

Hier sehen Sie für welche Module Sie eine gültige Lizenz besitzen und wann diese unter Umständen abläuft.

Sie finden die Lizenzinformationen in der Backstage-Ansicht unter Hilfe => Lizenzen

Unter Globale Lizenzangaben sehen Sie Ihre persönlichen Daten der Lizenz.


Konfiguration

Im Bereich Konfiguration können sämtliche Stammdaten, Einstellungen, Berechtigungen, Felder usw. konfiguriert werden.


Programmeinstellungen

In den Programmeinstellungen können allgemeine Einstellungen zum Aussehen und Verhalten der Software konfiguriert werden.

Sie erreichen die Einstellungen der Backstage-Ansicht unter Konfiguration => Programmeinstellungen.

Anmerkung:

Es ist möglich, dass dieser Menüpunkt für Sie nicht sichtbar ist. Ist dies der Fall, haben Sie keine Berechtigung, um darauf zuzugreifen. Wenden Sie sich bitte an Ihren Administrator oder Superuser.

Siehe auch:

Konfiguration Allgemein

Konfiguration Menus


Allgemein

Wenn die Option "Tray Icon verwenden" angekreuzt ist, wird die Anwendung nicht beendet, sondern mit einem Icon neben der Windows Uhr minimiert. Durch einen Klick auf dieses Icon wird die Anwendung wieder angezeigt. Wenn diese Option eingeschaltet ist, können Sie die Anwendung mit dem Tastenkürzel Alt+F4 oder im Menu unter Datei => Beenden beenden.


Menus

Im Bereich Design können Sie die Darstellung der Menüs sowie die Platzierung der Menüeinträge konfigurieren.

Im Bereich Art des Menüs können Sie definieren, wie das Hauptmenü der Anwendung individualisiert dargestellt werden soll.

Zusätzlich können Layout-Einstellungen für die verschiedenen Menü-Arten ausgewählt werden.

Ribbon-Menü | Die Ribbon-Menüs sind bekannt durch Microsoft Office und bieten einfachen und intuitiven Umgang mit der Software.
Seiten-Menü | Zeigt die Unterprogramme in einem Menü auf der linken oder rechten Seite an.
Toolbars | Stellt das Menü als Toolbar dar.

siehe auch:

Menü Struktur


Menü Struktur

Menüeinträge können mit Drag&Drop verschoben werden. Ziehen Sie dazu den gewünschten Menüeintrag mit der Maus auf den Zielbereich.

Eine neue Menügruppierung in einem der drei Bereiche (Menü, Toolbar, Konfiguration) kann mit Rechtsklick im gewünschten Bereich erstellt werden.

Menügruppen, die keine Menüeinträge besitzen, werden nicht gespeichert.


Design

Das Erscheinungsbild der Anwendung kann für jeden Arbeitsplatz individuell eingerichtet werden.

Sie erreichen die Einstellungen der Backstage-Ansicht unter Konfiguration => Design.

Klicken Sie auf Design und wählen Sie das gewünschte Aussehen. Diese Einstellung ist benutzerabhängig, d.h. jeder Benutzer kann seine eigene, persönliche Einstellung wählen.

Anmerkung:

Das Design kann auch in den Programmeinstellungen angepasst werden.


Datenbankfelder

Im Bereich Datenbankfelder können (Datenbank-) Felder und Kategorien verwaltet werden.

Sie erreichen die Einstellungen der Backstage-Ansicht unter Konfiguration => Datenbankfelder.

Wo Konfigurationsmöglichkeiten bestehen, können beliebig viele Datenbankfelder erstellt werden. Jedes Feld kann einer Kategorie zugeordnet und in verschiedenen Ansichten und Ansichtsvorlagen eingeblendet werden.

Links befindet sich eine Baumansicht für den Zugriff auf die einzelnen Konfigurationsbereiche. Auf der ersten Ebene befinden sich die Module (Adressverwaltung, Auftrag, Artikel usw.). Welche Module zur Verfügung stehen, hängt von der eingesetzten Programmversion ab.

Unterhalb der Module befinden sich die einzelnen Bereiche im Modul selbst. In der Adressverwaltung z.B. die Adressfelder. Auf einem Bereich können Felder erstellt, Felder an Kategorien zugeordnet, Ansichtsvorlagen sowie Ansichten verwaltet werden.


Datenbankfelder verwalten

Wählen Sie in der Baumansicht auf der linken Seite den gewünschten Bereich und wechseln Sie danach auf den Reiter Zusatzfelder.


Datenbankfelder erstellen

Klicken Sie auf Hinzufügen, um ein neues Feld zu erstellen.

Wählen Sie einen Titel/Namen sowie einen Datentyp für das neue Feld und klicken Sie auf Speichern.

Im Feld Auswahlliste kann eine Liste mit Vorgabewerten, die später bei der Eingabe zur Verfügung stehen sollen, hinterlegt werden.

Verfügbare Datentypen:

Textfeld

Feld zur Eingabe von Text. In Länge kann die maximale Länge definiert werden. Erlaubter Höchstwert für Länge ist 254.

Zahl (ohne Komma)

Zahlenfeld für ganze Zahlen ohne Nachkommastellen.

Gleitkomma-Zahl

Zahlenfeld für Gleitkommazahlen. In Präzision können die Anzahl Nachkommastellen definiert werden.

Datum

Feld zu Eingabe von Datumswerten ohne Zeitanteil.

Zeit

Feld zu Eingabe von Zeitwerten ohne Datumsanteil.

Datum und Zeit

Feld zu Eingabe von Datumswerten mit Zeitanteil.

Langes Textfeld

Feld für die Eingabe sehr langer Texte (länger als 254 Zeichen). Die Verwendung normaler Textfelder wird empfohlen. Das lange Textfeld sollte nur dann zum Einsatz kommen, wenn das normale Textfeld nicht ausreicht.

Checkbox

Ja/Nein Eingabefeld.

Bild

Eingabefeld, um ein Bild zu speichern.

Key=Value Auswahlliste

Eingabefeld für eine sogenannte Key-Value-Liste in der Form von:

1=Option A

2=Option B

Der Wert vor dem Gleichzeichen (=) wird in die Datenbank gespeichert, der Wert nach dem Gleichzeichen wird zur Anzeige/Auswahl verwendet.

Die Liste wird im Feld Auswahlliste hinterlegt.

Farbauswahl

Eingabefeld für Farbe mit einer Farbauswahl.

Verknüpfung aus XY

Je nach dem, welche Module installiert sind, werden verschiedene Verknüpfungsmöglichkeiten auf andere Datensätze angeboten, z.B.:

Verknüpfung auf Länderstamm - Zeigt ein Eingabefeld zur Auswahl eines Landes, das im Länderstamm hinterlegt ist.

Datensatz aus Detaildaten

Je nach dem, welche Module installiert sind, stehen eventuell noch weitere Verknüpfungsmöglichkeiten zur Verfügung. Ein Detail-Datensatzbereich aus der CRM-Adressverwaltung würde hier z.B. ebenfalls zur Auswahl stehen.

Verfügbare Flags:

Email-Feld | Aktiviert alle Email-Funktionen auf diesem Feld (Email-Archivierung, Email-Anhang, usw. sofern verfügbar)
URL-Feld | Behandelt den Inhalt des Feldes als (Internet-) URL.
Telefon-Feld | Aktiviert alle Telefon-Funktionen auf diesem Feld (Anruferkennung, Wahlhilfe usw. sofern verfügbar)
Mobilnummer-Feld | Aktiviert alle Telefon- und Mobilfunktionen auf diesem Feld (SMS, Anruferkennung, Wahlhilfe usw. sofern verfügbar).
Fax-Feld | Aktiviert alle Fax-Funktionen auf diesem Feld.
Skype-Feld | Aktiviert alle Telefon-Funktionen auf diesem Feld (Anruferkennung, Wahlhilfe usw. sofern verfügbar)


Datenbankfelder löschen

Wählen Sie das gewünschte Feld und klicken Sie auf Löschen.

Anmerkung für Administratoren:

Aus Sicherheitsgründen wird das Feld nur im Programm gelöscht, nicht aber in der Datenbank.


Kategorien der Felder

Wählen Sie in der Baumansicht auf der linken Seite den gewünschten Bereich und wechseln Sie danach auf den Reiter Kategorien.

In der Liste der Kategorien kann jedes Feld einer Kategorie zugeordnet werden. In der Spalte Kategorie kann ein beliebiger Wert gesetzt oder eine bestehende Kategorie ausgewählt werden. Um eine neue Kategorie zu erstellen, kann diese einfach in das gewünschte Feld geschrieben werden.

Die Kategorien werden verwendet, um die Daten in der Detailanzeige eines Datensatzes in den entsprechenden Kategorien anzuzeigen. Welche Felder in welcher Reihenfolge angezeigt werden wird auf den Ansichten definiert.


Ansichtvorlagen

Ansichtsvorlagen

Wählen Sie in der Baumansicht auf der linken Seite den Punkt Ansichtvorlage im gewünschten Bereich.

In jedem Bereich können beliebig viele Ansichtsvorlagen erstellt werden. Bei einer Ansichtsvorlage handelt es sich um die Definition, welche Felder in welcher Kategorie sichtbar sind. Die Ansichtsvorlagen können dann auf den verschiedenen Ansichten verwendet werden.

Die Standard-Ansichtsvorlage wird auf allen Ansichten verwendet, wo nicht explizit eine andere Einstellung vorgenommen wurde.


Ansichtvorlage hinzufügen

Ansichtsvorlage hinzufügen

Klicken Sie auf Hinzufügen, um eine neue Ansichtsvorlage zu erstellen.

Geben Sie der Ansichtsvorlage einen Namen und klicken Sie auf OK.


Ansichtvorlage löschen

Ansichtsvorlage löschen

Wählen Sie die gewünschte Ansichtsvorlage und klicken Sie auf Löschen.

Anmerkung:

Wenn die Ansichtsvorlage noch an einer anderen Stelle im Programm in Verwendung ist, kann die Ansichtsvorlage nicht gelöscht werden.


Felder definieren

Markieren Sie die Ansichtsvorlage, auf welcher Sie die Felder ändern möchten.

Im Bereich Kategorien sind alle verfügbaren Kategorien der Felder aufgelistet. Klicken Sie auf eine Kategorie, um die darin enthaltenen Felder anzuzeigen (rechts).

Markieren Sie alle Felder, die in dieser Kategorie eingeblendet werden sollen. Per Drag&Drop (Klicken&Ziehen) oder mit den Pfeilen [image] können die Felder angeordnet werden.

Anmerkung:

Nicht markierte Felder (=unsichtbar) werden beim Speichern automatisch hinter das letzte sichtbare Feld platziert.


Ansichten

Im Bereich Ansichten für 'XY' befinden sich die eigentlichen Ansichten, die im Programm z.B. bei Detailanzeige eines Datensatzes verwendet werden.

In der Grundeinstellung wird für jede Ansicht die Standard-Ansichtsvorlage verwendet. Da für viele dieser Ansichten oftmals die selben Feldansichten verwendet werden müssen/sollen, kann jeder Ansicht eine Ansichtsvorlage zugewiesen werden.

Wird bei Feldeinstellungen die Auswahl <Individuell> gewählt, können die Felder für die entsprechende Ansicht separat und unabhängig von einer Ansichtsvorlage definiert werden. Die Definition der Felder funktioniert in diesem Fall exakt so wie auch bei den Ansichtsvorlagen.


Programme

Im Bereich Programme werden sämtliche Einstellungen, die durch die installierten Softwaremodule zur Verfügung stehen, aufgeführt. Die Dokumentation der einzelnen Programmbereiche finden Sie im jeweiligen Handbuch.

Sie erreichen die Einstellungen der Backstage-Ansicht unter Konfiguration.


delight base

Diese Anwendung basiert auf

delight base

Version 6.x

Die universelle und leistungsstarke Basis für Datenbankanwendungen

Was ist delight base

delight base ist eine universelle Datenbankbasis, die es ermöglicht, in sehr kurzer Zeit eine komplette Datenbankanwendung für den Endbenutzer zu erstellen.

Datenbankanwendungen basierend auf delight base sind modular aufgebaut. Das bedeutet, dass die anwendungsspezifischen Funktionen in Modulen bereitgestellt werden.

delight base bildet das Bindeglied zwischen Datenbank und den Modulen. Es stellt dabei die Verbindung zur Datenbank her und stellt die Daten daraus den Modulen zu Verfügung.

delight base ist mehrbenutzerfähig.

Bei Datenbankanwendungen basierend auf delight base können sich verschiedene Benutzer mit Benutzername und Passwort anmelden. delight base erkennt den angemeldeten Benutzer und stellt die ihm zustehenden Module und Daten aus der Datenbank zur Verfügung. Der Zugriff auf Daten und Anwendungsfunktionen kann für jeden Benutzer individuell eingeschränkt werden.

delight base ist netzwerkfähig.

Datenbankanwendungen basierend auf delight base, welche auf verschiedenen Computer installiert sind, können über ein Netzwerk oder über das Internet auf die selben Daten einer Datenbank zugreifen.

delight base ist beliebig erweiterbar

Durch den modularen Aufbau können delight base-basierende Datenbankanwendungen im Funktionsumfang, durch Erweiterung der integrierten Module oder durch zusätzliche Module beliebig und schnell erweitert werden.

siehe auch:

delight base Anwendung

Versionen von delight base


Versionen

delight base Einzelbenutzer

Wird als Basis für einfache Datenbankanwendungen verwendet, die von einem Benutzer lokal auf einem Computer angewendet werden kann. Diese Version ist nicht mehrbenutzerfähig.

delight base Netzwerk

Wird als Basis für Datenbankanwendungen verwendet, die auf mehreren Computer installiert sind und die von mehreren Benutzern gleichzeitig verwendet werden können. Die Daten befinden sich zentral auf einem Datenbankserver. Alle Benutzer haben über ein Netzwerk oder über das Internet (z.B. VPN) Zugriff auf diesen zentralen Datenbestand.


Benutzerverwaltung

Verwaltung und Administration der Benutzer und Berechtigungen.

In dieser Dokumentation wird die Verwaltung und Administration der Berechtigungen sowie die Benutzer- und Gruppenverwaltung beschrieben.

siehe auch:

Wo finde ich die Berechtigungen

Benutzer

Gruppen

Berechtigungen


Verwaltung

Die Verwaltung der Berechtigungen wird in der Backstage-Ansicht unter Konfiguration => Benutzerverwaltung aufgerufen.

siehe auch:

Benutzer

Gruppen

Daten


Benutzer

In der Benutzerverwaltung können die Benutzer der Anwendung konfiguriert und verwaltet werden.

Jeder Benutzer kann beliebig vielen Gruppen zugeordnet sein. Anhand der Gruppen, in denen ein Benutzer Mitglied ist, werden die Berechtigungen definiert, die der Benutzer im Programm besitzt. Jeder Benutzer besitzt einen eindeutigen Benutzernamen sowie ein Passwort.

Jeder Benutzer muss einem Adresseintrag zugeordnet sein. Über diese Verknüpfung auf eine Adresse wird dem Programm mitgeteilt, welcher Mitarbeiter welchen Benutzernamen verwendet. Entsprechend werden bei der Adressauswahl nur Mitarbeiter angezeigt (Adressen aus der Zuordnungsart Mitarbeiter in der Adressverwaltung).

Über den Zugriffsmodus kann für jeden Benutzer definiert werden, mit welchen Zugriffsrechten er auf die Daten des Programms zugreifen kann.

Hinweis:

Wenn Benutzername und Passwort mit der Windows-Anmeldung übereinstimmen, wird der Benutzer automatisch am Programm angemeldet.

siehe auch:

Zugriffsmodus

Benutzer hinzufügen

Benutzer löschen

Gruppe hinzufügen

Gruppe löschen


Zugriffsmodus

Der Zugriffsmodus eines Benutzers bestimmt, welche Daten im Programm für ihn sichtbar sind und ob er schreibend oder nur lesend darauf zugreifen kann.

Auf welche Daten ein Benutzer Zugriff hat, wird über "Mitgliedschaft in Gruppen" bestimmt. Jeder Benutzer kann nur die Datensätze sehen, die einer Gruppe zugeordnet sind, in der er Mitglied ist. Datensätze, die keiner Gruppe zugeordnet sind, stehen allen Benutzern zur Verfügung.

Über die Option "Nur Lesezugriff im ganzen Programm" kann der Benutzer auf alle Daten zugreifen (auf die er durch seine Mitgliedschaften Zugriff hat), kann diese aber nicht ändern. Ist diese Option ausgeschaltet, kann über "Zugriffsmodus auf Daten" für jede Mitgliedschaft separat definiert werden, ob der Benutzer Datensätze dieser Gruppe nur lesen oder auch schreiben darf.


Benutzer hinzufügen

Klicken Sie im Abschnitt Benutzer auf Benutzer hinzufügen.

Geben Sie Benutzername und Passwort für den neuen Benutzer ein und wählen Sie danach in der Auswahlliste Adresseintrag eine Adresse aus, die dem neuen Benutzer zugeordnet werden soll.

Klicken Sie auf Speichern, um den Benutzer hinzuzufügen.

Fügen Sie dem neuen Benutzer die gewünschten Gruppen hinzu.

Hinweis:

Bei der Adressauswahl werden nur Mitarbeiter angezeigt (Adressen aus der Zuordnungsart Mitarbeiter in der Adressverwaltung). Sollten Sie die Adresse für den Mitarbeiter noch nicht erfasst haben, müssen Sie zuerst die Adresse in der Adressverwaltung erfassen. Stellen Sie sicher, dass die Adresse des Mitarbeiters in einer Zuordnung mit der Zuordnungsart "Mitarbeiter" aufgenommen wurde.

siehe auch:

Gruppe hinzufügen


Benutzer löschen

Markieren Sie einen Benutzer in der Liste auf der linken Seite.

Klicken Sie im Abschnitt Benutzer auf Löschen.


Gruppe entfernen

Markieren Sie einen Benutzer in der Liste auf der linken Seite.

Markieren Sie bei "Mitgliedschaft in Gruppen" die gewünschte Gruppe und klicken Sie auf Löschen.


Gruppe hinzufügen

Markieren Sie einen Benutzer in der Liste auf der linken Seite.

Klicken Sie unter Gruppenmitgliedschaft auf Gruppe hinzufügen.

Wählen Sie die gewünschte Gruppe und klicken Sie auf Hinzufügen.


Benutzergruppen

In der Gruppenverwaltung können die Gruppen und Ihre Zugriffsrechte verwaltet werden.

Alle Berechtigungen der Anwendung werden über Gruppen definiert und vergeben.

Ist ein Benutzer Mitglied einer Gruppe, besitzt er alle Berechtigungen und Zugriffsrechte dieser Gruppe.

Achtung:

Löschen Sie auf keinen Fall eine Gruppe, wenn Sie nicht genau wissen, welche Auswirkungen dies auf die Anwendung hat.

siehe auch:

Berechtigungen


Berechtigungen

In der Verwaltung der Berechtigungen können die Berechtigungen der Gruppen verwaltet werden.

Ihre Arbeitsoberfläche kann je nach Konfiguration und Ausstattung des Softwarepakets Abweichungen vom unten gezeigten Bild haben.

In der Baumstruktur auf der rechten Seite ist eine Liste mit allen im Programm installierten Modulen.

Welche Berechtigungsoptionen auf einem Modul verfügbar sind ist vom Modul abhängig. Weitere Informationen zu den Berechtigungsoptionen der einzelnen Module entnehmen Sie bitte der entsprechenden Modul-Dokumentation.

siehe auch:

Berechtigung einer Gruppe entziehen

Gruppe berechtigen


Gruppe berechtigen

Öffnen Sie rechts in der Baumstruktur ein Modul.

Markieren Sie die gewünschte Berechtigungsoption, die Sie einer Gruppe zugänglich machen wollen.

Klicken sie im Bereich Berechtigungen auf Gruppe hinzufügen.

Markieren Sie die gewünschte Gruppe aus der Auswahlliste und klicken Sie auf Hinzufügen.

Hinweis:

Sie können eine Gruppe auch per Drag&Drop aus der Liste (link) auf die gewünschte Berechtigungsoption ziehen.


Berechtigung einer Gruppe entziehen

Öffnen Sie rechts in der Baumstruktur ein Modul

Öffnen Sie die gewünschte Berechtigungsoption, die Sie einer Gruppe entziehen wollen.

Markieren Sie die gewünschte Gruppe auf der Berechtigungsoption.

Klicken Sie auf Entfernen, um die Gruppe aus der Berechtigungsoption zu entfernen.


Datenzugriff über Benutzergruppen

Im Bereich Daten kann definiert werden, auf welchen Datensätzen die Zugriffsrechte aktiviert werden sollen.

Im Normalfall sollte an dieser Stelle nur eine Option ausgewählt werden. Die Zugriffsrechte werden auf Datensätze, die miteinander verknüpft sind, vererbt. Ist z.B. die Option "Zuordnungen" ausgewählt, gelten die Zugriffsrechte einer Zuordnung automatisch auch für alle Adressen in dieser Zuordnung.


Datenbank & Netzwerk Installation

Das Programm speichert alle seine Daten in einer sogenannten Datenbank. Nach der Installation verwendet das Programm standardmässig eine eigene, integrierte Datenbank. Vorteil dieser integrierten Datenbank ist es, dass die Installation zusätzlicher Datenbank-Software nicht erforderlich ist. Nach der Installation des Programms kann ohne Installation von zusätzlicher Software direkt damit gearbeitet werden.

Das Programm kann, je nach Anforderung, mit verschiedenen Datenbanken betrieben werden. Müssen sehr viele Daten verwaltet werden oder viele Benutzer damit arbeiten, sollte das Programm auf die Verwendung einer externe Datenbank umgestellt werden. Weitere Information dazu finden Sie im Kapitel Netzwerk Installation.

delight software gmbh bietet dazu ein kostenloses Programm, dass die Umstellung auf eine externe Datenbank mit wenigen Klicks ermöglicht. Die Umstellung auf eine andere Datenbank ist jederzeit möglich und kann auch zu einem späteren Zeitpunkt erfolgen. Bei der Umstellung werden sämtliche bereits erfassten Daten automatisch übernommen.

Hinweis:

Ob die aktuelle Datenbank mit optimaler Geschwindigkeit arbeitet, können Sie mit dem Geschwindigkeitstest im Menü unter Hilfe => Datenbanktest überprüfen (nur Netzwerk-Version).

siehe auch:

Netzwerk Installation

Datenbanken

Installationsanleitungen


Datenbanken

Das Programm unterstützt verschiedene Datenbanken.

Bei der Einzelbenutzer-Version muss die Datenbank auf dem selben Computer wie das Programm installiert sein. Bei der Netzwerk-Version ist die externe Datenbank optimaler weise auf einem zentralen Server installiert.

Unterstütze Datenbanken:

Datenbank | Version | Einzelbenutzer-Version | Netzwerk-Version
MySQL MariaDB | MySQL 5.7.7 + MariaDB 10.3 + | Nur auf dem gleichen Computer wie das Programm (localhost) | Zentraler Server im Netzwerk oder auf dem gleichen Computer wie das Programm.
MSSQL und MSSQL Express | 2012 + | Nur auf dem gleichen Computer wie das Programm (localhost) | Zentraler Server im Netzwerk oder auf dem gleichen Computer wie das Programm.
Integrierte-Datenbank (DBISAM) | 4.x | Auf dem gleichen Computer wie das Programm. | Zentraler Server im Netzwerk oder auf dem gleichen Computer wie das Programm.


MySQL und MariaDB

MySQL ist ein Datenbank-Server der sehr gute Geschwindigkeit beim Zugriff auf die Daten bietet. Der Hersteller bietet eine kostenlose Version, ohne Einschränkungen und mit vollen Funktionsumfang, zum Download an.

MariaDB ist ein Fork/Split-Off (zu deutsch ein Abkömmling) der MySQL-Datenbank. MariaDB ist komplett kompatibel zu MySQL hat aber ein paar sehr interessante Zusatzfunktionen. Insbesondere was die Geschwindigkeit betrifft, hat MariaDB in unseren Test deutlich besser abgeschnitten.

Bei MariaDB und MySQL sind keine zusätzlichen Komponenten auf den Clients notwendig. Alle delight Programm verwenden einen integrierten, nativen Direktzugriff auf diese Datenbanken.


MariaDB

Hersteller: MariaDB Foundation

Download: http://mariadb.org/

Unterstütze Versionen: Version 10.1 oder neuer

Grundsätzlich sollten Sie zum Zeitpunkt der Installation die jeweils aktuellste, stabile Version installieren (current stable GA).

Anmerkungen zur Konfiguration:

·Strict-Mode bei MariaDB sollte nicht verwendet werden.

·Wert max_allowed_packet sollte auf höheren Wert (zB. 64M) gesetzt werden.

·Die Option innodb_flush_log_at_trx_commit sollte auf 2 gesetzt werden.

·Die Option innodb_file_per_table sollte auf 1 gesetzt werden.

·Es wird die Storage-Engine InnoDB verwendet.

·Der MariaDB-User benötigt DROP, ALTER und CREATE Berechtigungen damit der Online-Update korrekt funktioniert. Ist dies nicht erwünscht, sollte der Online-Update deaktiviert werden.

Auszug aus der my.ini mit den empfohlenen Werten:

[mysqld]

sql_mode="NO_ENGINE_SUBSTITUTION"

default_storage_engine=innodb

# http://dev.mysql.com/doc/refman/4.1/en/innodb-parameters.html

# 2=flush every second instead of every query

innodb_flush_log_at_trx_commit=2

max_allowed_packet=64M

innodb_file_per_table=1

# fixes some import errors on newer DB version

innodb_strict_mode=0

# improve performance on schema access for innodb tables

innodb_stats_on_metadata=0

# speed up connections handling if no client host-dns name validation is required (e. g. host is % or localhost on all users)

skip-name-resolve


MySQL

Hersteller: MySQL AB (Oracle)

Download: www.mysql.com/downloads

Unterstütze Versionen: Version 5.6 oder neuer

Grundsätzlich sollten Sie zum Zeitpunkt der Installation die jeweils aktuellste, stabile Version installieren (current stable GA).

Anmerkungen zur Konfiguration:

·Strict-Mode bei MySQL sollte nicht verwendet werden.

·Wert max_allowed_packet sollte auf höheren Wert (zB. 64M) gesetzt werden.

·Die Option innodb_flush_log_at_trx_commit sollte auf 2 gesetzt werden.

·Die Option innodb_file_per_table sollte auf 1 gesetzt werden.

·Es wird die Storage-Engine InnoDB verwendet.

·Der MySQL-User benötigt DROP, ALTER und CREATE Berechtigungen damit der Online-Update korrekt funktioniert. Ist dies nicht erwünscht, sollte der Online-Update deaktiviert werden.

Auszug aus der my.ini mit den empfohlenen Werten:

[mysqld]

sql_mode="NO_ENGINE_SUBSTITUTION"

default_storage_engine=innodb

# http://dev.mysql.com/doc/refman/4.1/en/innodb-parameters.html

# 2=flush every second instead of every query

innodb_flush_log_at_trx_commit=2

max_allowed_packet=64M

innodb_file_per_table=1

# fixes some import errors on newer DB version

innodb_strict_mode=0

# improve performance on schema access for innodb tables

innodb_stats_on_metadata=0

# speed up connections handling if no client host-dns name validation is required (e. g. host is % or localhost on all users)

skip-name-resolve

siehe auch:

Installation MySQL 5.0


MSSQL und MSSQL-Express

MSSQL ist ein Datenbank-Server der sehr gute Geschwindigkeit beim Zugriff auf die Daten bietet. Der Hersteller bietet eine kostenlose Version, mit Einschränkungen in der Datenbankgrösse und der Anzahl Benutzer, unter dem Namen MSSQL-Express zum Download an.

Hersteller: Microsoft

Unterstütze Versionen: Version 2012 oder neuer wird empfohlen! In Version 2012 hat Microsoft sogenannte Paging-Funktionen eingebaut, unsere Software kann diese verwenden was sich positiv auf die Geschwindigkeit auswirkt (vor allem bei grösseren Datenbeständen im Netzwerk).

Für MSSQL-Server muss der sogenannte "Native Client" aus dem Microsoft SQL-Server Feature-Pack installiert werden.

Dieser muss auf jedem Computer/Client installiert sein. Das Installationspaket aus dem Feature-Pack heist "sqlncli.msi" und kann bei Microsoft bezogen werden.

Download Native Client:

SQL-Server 2008: http://www.microsoft.com/en-us/download/details.aspx?id=27596

SQL-Server 2012: http://www.microsoft.com/de-ch/download/details.aspx?id=35580

siehe auch:

Installation MSSQL-Express


Integrierte Datenbank (DBISAM)

Die integrierte Datenbank ist kein Datenbank-Server im eigentlichen Sinne. Die Daten werden als normale Dateien auf der Festplatte gespeichert. Dies kann unter Umständen zu Geschwindigkeits-Problemen mit dem installierten Anti-Virus-Programm führen (je nach dem wie leistungsfähig der Computer ist und wie effizient der Viren-Scanner arbeitet). Der Einsatz im Netzwerk ist nur bedingt zu empfehlen.

Für sehr kleine Netzwerk-Installationen und Datenmengen kann das komplette Programm auf ein Netzwerk-Laufwerk installiert (oder nach der Installation kopiert) werden. Die einzelnen Benutzer können das Programm danach direkt ab dem Netzwerk-Laufwerk starten. Gestartet wird das Programm über die Datei ML2Client.exe. Beachten Sie bitte, dass alle Benutzer Schreib- und Lese rechte auf dem Netzwerk-Laufwerk haben müssen.

Bitte beachten Sie dazu auch das Kapitel Integrierte Datenbank und Antiviren-Programme.

siehe auch:

Empfehlungen

Integrierte Datenbank und Antiviren-Programme


Integrierte Datenbank und Antiviren-Programme

Sollte Ihr Programm nach der Installation gefühlt sehr langsam sein, liegt dies vermutlich an der Konfiguration Ihres Antivirus-Programms.

Einige Antivirus-Programme überprüfen jede Datei, bei jedem Zugriff, auf Viren. Dieses Verhalten kann den Zugriff auf die Daten in der lokalen Datenbank stark verlangsamen. Fügen Sie deshalb unten aufgeführte Datei-Endungen in die Ausschluss-List (Exclude-Liste) ihres Virenscanners hinzu.

Dateiendungen:

*.dat

*.idx

*.blb

*.tmpdat

*.tmpidx

*.tmpblb

Anmerkung:

Tests haben gezeigt, dass gewisse Antivirus-Programm sehr ineffizient arbeiten und Dateien trotz Ausschlussliste prüfen. Sollte dies der Fall sein, sollten Sie die Umstellung auf eine externe Datenbank in Betracht ziehen.

Hinweis:

Wie Sie Datei-Endungen in die Ausschlussliste Ihres Antivirus-Programms aufnehmen, lesen Sie bitte im Handbuch oder der Online-Hilfe ihrer Antivirus-Software nach.


Empfehlungen

Für die Netzwerk-Version und die Einzelbenutzer-Version gibt es unterschiedliche Empfehlungen.


Empfehlungen für die Einzelbenutzer-Version

Sollte die integrierte Datenbank nicht genügen (z.B. Geschwindigkeits-Probleme mit dem installieren Anti-Virus Programm oder bei sehr vielen Daten) ist die kostenlose MariaDB-Datenbank eine sehr gute Alternative zur Integrierten-Datenbank. MariaDB lässt sich einfach installieren, bietet sehr schnelle Datenzugriff und ist nach der Installation ohne umständliches Konfigurieren direkt einsatzbereit.


Empfehlungen für die Netzwerk-Version

Die Integrierte-Datenbank ist nur bedingt netzwerkfähig. Für sehr kleine Installationen bis ca. 5 Benutzer reicht die Leistung in den meisten Fällen aus. Für grössere Installationen (mehr Benutzer, mehr Daten) sollte auf eine externe Datenbank umgestellt werden. Eine externe Datenbank bietet in jedem Fall (auch bei kleinen Installationen) eine bessere Leistung als die Integrierte-Datenbank.

Für die Netzwerk-Version sollte die Datenbank optimalerweise auf einem zentralen Server installiert werden. Falls nicht bereits eine unterstütze Datenbank im Einsatz ist, empfiehlt sich hier die kostenlose MariaDB-Datenbank. MariaDB biete sehr gute Leistung ohne das Anzahl Benutzer oder Datenbankgrösse lizenztechnisch limitiert sind. In unseren Tests schnitt MariaDB in Punkto Geschwindigkeit besser ab als MySQL. Aber auch MySQL und MSSQL liefern bei optimaler Installation&Konfiguration sehr gute und empfehlenswert Werte.

Wenn planen, Berechtigungen auf Datensatz-Ebene zu vergeben, sollte MariaDB der MySQL- und MSSQL-Datenbank vorgezogen werden.


Netzwerk Installation

Für die Installation mehrerer Benutzer ist eine Netzwerk-Version der delight Anwendung erforderlich.

Bei der Netzwerk-Version wird eine zentrale delight Installation auf einem zentralen Server installiert. In dieser zentralen delight Installation auf dem zentralen Server läuft der delight MultiUser-Server als Windows Service sowie der Datenbank-Server, wobei der Datenbank-Server auch auf einer anderen Server-Instanz laufen kann/darf. Auf den einzelnen Clients (Computer / RDS-Instanzen an denen die Benutzer arbeiten) wird ebenfalls eine delight Installation installiert. Diese Client-Installation des delight Programms kommuniziert über das Netzwerk (TCP/IP) mit dem zentralen Datenbank-Server sowie dem zentralen MultiUser-Server.

Üblicher Aufbau der Netzwerk-Installation:

Zentraler Server

·Datenbank-Server (siehe Datenbanken)

·delight Programm mit MultiUser-Server Windows-Service (siehe Installationsanleitung MultiUser-Server)

Clients für Anwender

·delight Programm


Installationsanleitungen

Die Installations-Anleitungen beschreiben Installation und Umstellung des Programms auf eine Netzwerk-Installation für mehrere Benutzer.

Hinweis:

Die jeweilige Installations-Anleitung erklärt ausschliesslich die grundlegenden Installations-Schritte zur Installation. Aspekte wie Sicherheit, Optimierung des Server an die verwendete Hardware/Umgebung usw. werden nicht behandelt. Die Behandlung dieser Themen würde den Umfang dieser Installations-Anleitungen bei weitem sprengen.

Netzwerk Installation mit Datenbank-Server und MultiUser-Server

1.Melden Sie sich mit Administratorrechten auf dem zentralen Server, welcher die Server-Installation von delight beinhalten soll, an.

2.Installieren Sie das delight Programm.

3.Installieren Sie den gewünschten Datenbank-Server (siehe auch Empfehlungen für die Wahl der richtigen Datenbank)
> MySQL-Server Version
> MSSQL-Express-Version

4.Nach der Installation des Datenbank-Servers wird das delight Programm auf die neue Datenbank umgestellt werden. Mit dieser Umstellung werden alle bereits erfassten Daten übernommen.
> Datenbank-Umstellung

5.Falls nicht bereits mit Schritt 4 erledigt, muss das Verzeichnis für die Ablage der Dokumente konfiguriert werden.
> Pfad für Dokumentenablage konfigurieren

6.Falls nicht bereits mit Schritt 4 erledigt, sollte der zentrale MultiUser-Server Windows-Dienst konfiguriert und installiert werden. Die Installation dieses Dienstes ist optional wird aber sehr dringend empfohlen, da ansonsten einige Funktionen des delight Programms nicht zur Verfügung stehen.
> MultiUser-Server Dienst Installation

7.Nun sollte das delight Programm auf dem Server einmal als Administrator gestartet werden (ML2Client.exe im Installationsverzeichnis starten). Damit wird die neu eingerichtete Datenbank geprüft und allfällige Schemaupdates ausgeführt. Ist das delight Programm komplett gestartet (Anmeldung als Benutzer durchgeführt), kann es wieder beendet werden.

8.Nun ist die Installation soweit abgeschlossen und die Installation kann auf die einzelnen Clientcomputer/Instanzen verteilt werden. Sofern das Verzeichnis für die Dokumentenablage nicht im Installationsverzeichnis abgelegt ist, kann nun einfach das komplette Installationsverzeichnis auf die Clients kopiert werden. Alternativ kann das Installationsverzeichnis auch Freigegeben und das Programm direkt ab dem UNC-Pfad gestartet werden.
Gestartet wird das Programm über die Datei ML2Client.exe. Diese Datei kann zB. auf den Desktop des Benutzer verknüpft werden.


Manuell Installation auf Windows Server

Manuell MariaDB-Installation auf Windows Server.

Die aktuelle Installationsroutine kann allenfalls etwas von den hier verwendeten Screenshots abweichen.

1.Downloaden Sie das aktuelle MSI-Installations-Paket ab https://downloads.mariadb.org/

2.Starten Sie das herunter geladene MSI-Paket und klicken Sie auf Next.

3.Lesen ;-) und akzeptieren Sie die Lizenzbedingungen. Kicken Sie auf Next.

4.Klicken Sie auf Next (keine Angaben erforderlich)

5.Geben Sie das Administrator-Passwort für die Datenbank ein.

Wichtig: Sie können dieses Passwort frei bestimmen. Merken Sie sich das Passwort für später
und legen Sie es in Ihren sicheren Unterlagen ab. Sie werden es später noch benötigen!

Markieren Sie die Option Enable access from remote machines for root user.

Klicken sie auf Next.

6.Die vorgeschlagenen Einstellungen sind meistens ok, klicken Sie auf Next.

7.Klicken Sie auf Next.

8.Klicken Sie auf Install.

9.Klicken Sie auf Ja und warten Sie, bis die Installation durchgeführt wurde.

10.Klicken Sie auf Finish

11.Im Windows Start-Menü finden sich nun die neu installierten Einträge von MariaDB.

Öffnen Sie den Eintrag my.ini

12.Ändern Sie den sql_mode auf:
sql_mode="NO_ENGINE_SUBSTITUTION"

13. Fügen Sie folgende Optionen nach der Linie [mysqld] (aber vor der Linie [client]) ein:

innodb_flush_log_at_trx_commit=2
max_allowed_packet=64M
innodb_file_per_table=1
max_connections=1024
innodb_stats_on_metadata=0

14.Speichern Sie die Datei über Menü => Datei => Speichern

15.Öffnen Sie die lokale Dienstverwaltung von Windows.
Windows-Taste-R oder Startmenü = Ausführen und dann "services.msc" eingeben.

16. Suchen Sie den MySQL Dienst, dies ist der übliche Name für den MariaDB-Dienst.

17.Führen Sie einen Rechtsklick auf den Dienst aus und wählen Sie Neu starten. Damit werden die neuen Einstellungen der my.ini aktiviert.

Die Installation und Konfiguration des Datenbank-Servers ist abgeschlossen. Sie können nun das Programm auf die soeben installierte Datenbank umstellen.
Lesen Sie dazu bitte die Installations-Anleitung Datenbank-Umstellung.

Anmerkung:

Im Start-Menü von Windows finden Sie nun ebenfalls das neu installierte Programm HeidiSQL.


Installation auf Azure Database for MariaDB-Server

Installation Azure Database for MariaDB-Server.

Grundvoraussetzung für die Installation ist ein aktives Microsoft Azure Konto sowie Kenntnisse in der Erstellung und Verwaltung von Ressourcen auf Azure.

1.Melden Sie sich bei Azure an.

2.Erstellen Sie eine MariaDB Instanz

3.Erstellen Sie die Ressource mit den gewünschten Leistungsmerkmalen.

4.Öffnen Sie die Serverparameter

5.Entfernen Sie in "sql_mode" die Option "STRICT_TRANS_TABLES"

6.Setzen Sie die Option "innodb_strict_mode" auf "OFF"

7.Setzen Sie "max_connections" wenn möglich auf einen höheren Wert. Pro User sollten ca. 10 aktive Connections gerechnet werden. Wir empfehlen üblicherweise einen Wert von 1024. Bei Azure ist der Maximalwert aber an den ausgewählten Kostenplan gebunden

Weitere Infos dazu: https://docs.microsoft.com/en-us/azure/mariadb/concepts-server-parameters#max_connections

8.Die Installation der Datenbank ist damit abgeschlossen und bereit für den nächsten Schritt: Datenbank-Umstellung.

Wichtig: Bitte beachten Sie die Anmerkungen zur Konfiguration in delight.


Anmerkungen zur Azure MariaDB-Konfiguration in delight

Für die Konfiguration in delight müssen bei Azure MariaDB ein paar Punkte beachtet werden.

·Die Azure MariaDB kann, wie auch eine lokal installierte MariaDB, mit HeidiSQL verwaltet werden: https://www.heidisql.com

·Azure verlangt bei MariaDB ein für MariaDB unübliches Format beim Benutzernamen. Der Benutzername besteht im Fall von Azure aus benutzername@servername.

Bsp: Der korrekte Benutzernamen für die Verbindung mit Azure (Datenbank-Umstellung Schritt 5) lautet im Fall des Benutzers "mydelightuser" auf dem Server "delightmariadbtesting" => "mydelightuser@delightmariadbtesting"

·Das (nächste) allgemeine Kapitel Anmerkungen zur Konfiguration in delight gilt auch für Azure MariaDB.


Anmerkungen zur Konfiguration in delight

Wir empfehlen das Einrichten eines separaten MariaDB-Benutzers der "nur" Berechtigung auf die "delight Datenbank" hat. Der root (Admin-User der Datenbank) sollte nicht direkt mit delight verwendet werden.

Benutzer mit HeidiSQL einrichten:

1.HeidiSQL starten und mit der MariaDB-Datenbank verbinden.

2.Werkzeuge => Benutzerverwaltung öffnen

3.Neuen Benutzer erstellen

4.Benutzername eingeben

5.Zugriff "von überall" definieren

6.Passwort generieren oder eingeben

7.Neues Zugriffsobjekt erstellen

8.Name der delight Datenbank eingeben.

Das muss dem Datenbanknamen in Schritt 5 in Kapitel Datenbank-Umstellung entsprechen.

9.Alle Rechte auf der Datenbank erteilen.

10.Falls Sie eine FullApp-Cloud Variante oder eine SaaS-Datenbank (z. B. Azure, Google, AWS) einrichten, sollte die Option "Nur SSL" auf dem Benutzer aktiviert werden.

11.Abschliessend auf Speichern klicken. Benutzername, Passwort und Datenbankname benötigen Sie nun für die Datenbank-Umstellung von delight.


Installation MySQL

Anmerkung: Dieses Kapitel für MySQL wird nicht mehr gepflegt. Die aktuelle Installationsroutine kann allenfalls etwas abweichen.

Wir empfehlen grundsätzlich die Installation von MariaDB.

Installationsanleitung für MySQL Community Edition

1.Downloaden Sie den MySQL-Server (www.mysql.com/downloads)

2.Datei Setup.exe aus dem ZIP-Archiv entpacken und starten.

Klicken Sie auf Weiter um die Installation zu starten.

3.Installationsart auswählen.

Wählen Sie Typical und klicken Sie auf Weiter.

4.Eingaben prüfen.

Klicken Sie auf Install um die Installation zu starten.

5.Installation läuft.

(Warten Sie bis alle Dateien installiert wurden)

6.Erstellen Sie bei Bedarf einen Account auf MySQL.com.

Dieser Schritt ist freiwillig. Um Ihn zu überspringen klicken Sie Skip Sign-up und anschliessend Weiter.

7.Installation Abgeschlossen.

Stellen Sie sicher, dass Configure the MySQL Server now markiert ist. Klicken Sie anschliessend auf Finish.

8.Server konfigurieren.

Klicken Sie auf Weiter um die Konfiguration des Server zu starten.

9.Detaillierte Konfiguration.

Wählen Sie Detailed Configuration, klicken Sie auf Weiter.

10.Einsatzgebiet wählen.

Wählen Sie Server Machine, klicken Sie auf Weiter.

11.Funktion des Server.

Wählen Sie Multifunctional Database, klicken Sie auf Weiter.

12.Speicher-Ort für InnoDB-Tabellen.

Belassen Sie die Einstellungen wie vorgegeben. Das Programm speichert seine Daten
nicht im InnoDB-Format. Klicken Sie auf Weiter.

13.Anzahl Verbindungen wählen.

Wählen Sie im Zweifelsfall die Einstellung (OLTP).

Hinweis:
Programme verwenden mehrere gleichzeitige Verbindungen pro Benutzer zum Datenbank-Server.
Die effektiv Anzahl hängt von den verwendeten Programm-Teilen ab.

Klicken Sie auf Weiter.

14.Netzwerk-Verbindung und Modus.

Wichtig:
Die Einstellung Enable Strict Mode muss ausgeschaltet werden! Beim Installationsprogramm von MySQL 5.5 ist das deaktivieren des Strict-Mode besonders wichtig, ansonsten schlägt die Installation von MySQL später fehl. Die scheint ein Fehler im MySQL Instance Configuration Wizard zu sein, in Version 5.5 kommt dieser mit dem Strict-Mode nicht mehr zurecht und bricht mit einem Fehler ab.

Belassen Sie die Port Number wie vorgegeben. Klicken Sie auf Weiter.

15.Zeichensatz auswählen.

Belassen Sie alle Einstellungen wie vorgegeben und Klicken Sie auf Weiter.

16.Installation Service.

Belassen Sie alle Einstellungen wie vorgegeben und Klicken Sie auf Weiter.

17.Administrator-Passwort setzen.

Geben Sie ein neues Passwort für die Datenbank ein.

Wichtig:
Notieren Sie sich diese Passwort, Sie werden es später wieder benötigen!

Belassen Sie alle anderen Einstellungen wie vorgegeben und Klicken Sie auf Weiter.

18.Konfiguration ausführen.

Klicken Sie auf Execute.

19.Konfiguration Abgeschlossen.

Der erste Teil der Installation und Konfiguration ist beendet. Klicken Sie auf Finish um das Konfigurationsprogramm zu schliessen.

Hinweis: Wenn Sie hier eine Fehlermeldung erhalten, haben Sie vermutlich bei Schritt 14. den Strict-Mode nicht deaktiviert.

20.Downloaden und installieren Sie nun MySQL Workbench um die Datenbank zu konfigurieren (http://www.mysql.com/downloads/workbench)

21.Starten Sie das soeben installierte Programm MySQL Workbench.

Das Programm kann über das Start-Menü von Windows unter Programme => MySQL gestartet werden.

22.Doppelklicken Sie auf der rechten Seite im Bereich Server Administration auf die Instanz "Local MySQL" um die Server Administration zu starten. Falls ein Benutzername oder Passwort verlangt wird, geben Sie bei Benutzername "root" (ohne "") und bei Passwort das Passwort aus Schritt 17 ein.

23.Wechseln (klicken) Sie in das Menü Options File (links unter CONFIGURATION) und danach weiter auf den Reiter Networking (oben in der Mitte).
Setzen Sie den Hacken bei der Option max_allowed_packet und erhöhen Sie den Wert auf mindestens 64M.

Falls Sie MySQL 5.5 installiert haben, müssen Sie zusätzlich einen Hacken bei der Option skip-name-resolve (weiter unten) setzen. Ansonsten kann es bei MySQL 5.5 zu Verbindungsproblemen mit der Datenbank kommen (Bug in MySQL Version 5.5.9 GA)

Klicken Sie danach auf Apply um die Einstellung zu speichern.

24.Wechseln (klicken) Sie in das Menü Startup /Shutdown (links unter MANAGEMENT) um den Datenbankserver neu zu starten.
Klicken Sie auf die Schaltfläche Stop Server und warten Sie bis der Dienst beendet wurde. Klicken Sie anschliessen auf die Schaltfläche Start Server um den Dienst wieder zu starten.

Die Installation und Konfiguration des Datenbank-Servers ist abgeschlossen. Sie können nun das Programm auf die soeben installierte Datenbank umstellen.
Lesen Sie dazu bitte die Installations-Anleitung Datenbank-Umstellung.


Installation MSSQL-Express

Installationsanleitung für MSSQL Express

1. Downloaden Sie den MSSQL Express-Server (www.microsoft.com/downloads)

2. Starten Sie das Installations-Programm (SQLEXPR_GER.EXE)

3. Installationsvoraussetzungen

Klicken Sie auf Installieren und danach auf Weiter.

4. Start des eigentlichen Installations-Programms

Klicken Sie auf Weiter.

5. Systemprüfung

Klicken Sie auf Weiter wenn keine Fehler gefunden wurden. Andernfalls müssen Sie

zuerst die genannten Fehler beheben.

6. Registrierung

Klicken Sie auf Weiter.

7. Komponenten

Klicken Sie auf Weiter.

8. Authentifizierungsmodus

Klicken Sie auf Weiter.

9. Fehlerberichterstattung

Klicken Sie auf Weiter.

10. Installationsbereit

Klicken Sie auf Installieren.

11. Installation läuft

Klicken Sie auf Weiter und danach auf Fertigstellen wenn alle Produkte installiert wurden.

Die Installation und Konfiguration des Datenbank-Servers ist abgeschlossen. Sie können nun das Programm auf die soeben installierte Datenbank umstellen.

Lesen Sie dazu bitte die Installations-Anleitung Datenbank-Umstellung.


Datenbank-Umstellung

1.Installieren Sie den delight base Datenbank Administrator.

Download von https://www.delight.ch/aktuelle-downloads

Wichtig: Beachten Sie bitte, dass Sie die jeweils zur Produkt-Version kompatible delight base Version downloaden und verwenden müssen.

2.Starten Sie den delight base Datenbank Administrator. Klicken Sie auf Weiter

3.Wählen Sie das installierte Programm das auf die externe Datenbank umgestellt werden soll.

Ist das Programm nicht in der Liste aufgeführt, kann das Installationsverzeichnis über [image] gesucht werden.

Anmerkung: Wenn Sie das Programm nicht auswählen können, verwenden Sie nicht die korrekte, zur Programm-Version passende,
Version des delight base Datenbank Administrators.

Klicken Sie auf Weiter

4.Konfigurieren Sie unter Zieldatenbank den gewünschten Datenbanktyp (MySQL, MariaDB, SQL Server).

5.Konfigurieren Sie den Datenbank-Server (Host)

Netzwerk-Version:
Geben Sie bei Host den Hostnamen oder die IP-Adresse des Datenbank-Servers ein. Diesen Hostnamen müssen die Clients auflösen
können, um eine Verbindung mit dem Datenbank-Server herstellen zu können.

Einzelbenutzer-Version:
Die Datenbank muss auf dem gleichen Computer wie das Programm installiert sein. Die Eingabe Datenbank-Server ist nicht erforderlich.
Falls Sie MSSQL Express für die Einzelbenutzer-Version installieren, sollte Sie die Option Windows NT Anmeldung verwenden einschalten.
Wenn Sie MySQL oder MariaDB für die Einzelbenutzer-Version verwenden, wird automatisch "localhost" verwendet.

Geben Sie Benutzername und Passwort ein. Wenn Sie bei MSSQL die Option Windows NT Anmeldung verwenden einschalten, sind Benutzername
und Passwort nicht erforderlich. Wenn Sie MySQL oder MariaDB anhand der Installations-Anleitung installiert haben, gebe Sie bei Benutzername "root"
und bei Passwort das Passwort, dass Sie bei der Installation verwendet haben, ein.

Der Name der Datenbank im Eingabefeld Datenbankname muss in den meisten Fällen nicht geändert werden. Falls Sie mehrere delight Programm
auf dem selben Datenbank-Datenbank-Server installieren, müssen Sie darauf achten, dass jedes Programm einen eigenen Datenbanknamen bekommt.

6.Wählen Sie unter Optionen Datenbank die Einstellung Datenbank kopieren und Programm konfigurieren.
Die Einstellung Nur Programm konfigurieren sollten Sie nur dann verwenden, wenn Sie die Datenbank bereits erstellt und kopiert haben.

Stellen Sie sicher, dass die Option Datenbank erstellen markiert ist.

Die Option Protokolldaten ausschliessen sollte aktiviert sein. Damit werden die unter Umständen sehr grossen Protokolltabellen nicht kopiert. Das Kopieren dieser Tabellen kann u.U. sehr lange (mehrere Stunden) dauern.

7.Prüfen nun, ob die Verbindung zur neuen Datenbank funktioniert.
Klicken Sie dazu auf
Sollte die Verbindung nicht hergestellt werden können, müssen Sie den Datenbank-Server sowie Ihre Eingaben prüfen.

Klappt die Verbindung, klicken Sie bitte auf Weiter.

8.Optional können Sie an dieser Stelle gleich den Pfad für Dokumentenablage konfigurieren. Weitere Informationen dazu
im Kapitel Pfad für Dokumentenablage konfigurieren in Schritt 5. Sie können diesen Schritt auch überspringen und später durchführen.

9.Optional können Sie an dieser Stelle gleich den MultiUser-Server installieren und konfigurieren. Weitere Informationen dazu
im Kapitel MultiUser-Server Dienst Installation ab Schritt 6. Sie können diesen Schritt auch überspringen und später durchführen.

Klicken Sie auf Weiter.

10.Prüfen Sie nochmals alle Daten und klicken Sie anschliessend auf Weiter um den Kopiervorgang zu starten.

11.Die Daten werden kopiert, warten Sie bis alle Daten auf den Datenbank-Server kopiert wurden.

12.Die Datenbank wurde erstellt und die Daten kopiert. Klicken Sie auf Weiter.

13.Bis zu diesem Schritt wurde die Konfiguration noch nicht gespeichert. Falls beim Kopieren Fehler aufgetreten sind oder
Sie aus einem anderen Grund abbrechen möchten, können Sie das an dieser Stelle gefahrlos tun. Das Programm bleibt
dann auf der alten (aktuellen) Konfiguration.

Klicken Sie auf Weiter um die Konfiguration zu speichern.

14.Die Umstellung ist beendet. Ab jetzt läuft das Programm auf der neu konfigurierten Datenbank.


Pfad für Dokumentenablage konfigurieren

1.Melden Sie sich auf dem Server, auf welchem der zentrale MultiUser-Windows-Service installiert ist an.
Sie benötigen Administratoren-Rechte um die Konfiguration zu bearbeiten.

2.Installieren Sie den delight base Datenbank Administrator

Download von https://www.delight.ch/aktuelle-downloads

Wichtig: Beachten Sie bitte, dass Sie die jeweils zur Produkt-Version kompatible delight base Version downloaden und verwenden müssen.

3.Starten Sie den delight base Datenbank Administrator und wählen Sie die Anwendung, für welche das Verzeichnis konfiguriert
werden soll. Klicken Sie anschliessend auf Weiter.

4.Belassen Sie alle Einstellung wie sie sind und Klicken Sie direkt auf Weiter.

5.Wechseln Sie in den Reiter Dokumenten-Verwaltung

6.Aktivieren Sie den Ablageort delight base MultiUser-Server wenn der MultiUser-Server verwendet wird (empfohlen).

7.Konfigurieren Sie den Pfad für die Ablage der Dokumente.

Wenn Sie den MultiUser-Server verwenden, benötigt nur der MultiUser-Server (sprich der Windows-Benutzer unter welchem der Windows-Dienst läuft)
Schreib- und Lesezugriff auf diesen Pfad. Die Clients/Benutzer benötigen KEINEN Zugriff (auch keinen Lese-Zugriff) auf diesen Pfad.

Wenn der MultiUser-Server nicht verwendet wird, müssen alle Client/Benutzer Schreib- und Lesezugriff auf den Pfad haben.

Grundsätzlich sollte eine Verzeichnis ausserhalb des Installationsverzeichnisses gewählt werden!

Klicken Sie anschliessend auf Weiter.

8. Klicken Sie auf Weiter um die Konfiguration zu speichern.

9.Falls der MultiUser-Server bereits installiert und gestartet wurde, muss der Dienst neu gestartet werden.

Anmerkung:

Die bereits erstellen Dokumente aus dem alten Ablagepfad müssen Sie selbst, manuell vom alten Ort in den neuen Ablagepfad kopieren!


MultiUser-Server Dienst Installation

1.Melden Sie sich auf dem Server, auf welchem der zentrale MultiUser-Windows-Service installiert werden soll, an.
Sie benötigen Administratoren-Rechte um einen neuen Windows-Dienst zu installieren.

2.Installieren Sie den delight base Datenbank Administrator

Download von https://www.delight.ch/aktuelle-downloads

Wichtig: Beachten Sie bitte, dass Sie die jeweils zur Produkt-Version kompatible delight base Version downloaden und verwenden müssen.

3.Starten Sie den delight base Datenbank Administrator und wählen Sie die Anwendung, für welche der Windows-Dienst auf
dem Server, auf dem Sie jetzt arbeiten, installiert werden soll. Klicken Sie anschliessend auf Weiter.

4.Belassen Sie alle Einstellung wie sie sind und Klicken Sie direkt auf Weiter.

5.Wechseln Sie in den Reiter MultiUser-Server

6.Aktivieren Sie MultiUser-Server verwenden.

7.Definieren Sie einen Schlüssel für die Kommunikation. Nur Client-Anwendungen mit dem gleichen Schlüssel können später
mit dem Server kommunizieren.

8.Geben Sie bei Host den Hostnamen oder die IP-Adresse dieses Servers ein. Diesen Hostnamen müssen die Clients auflösen
können, um eine Verbindung mit dem MultiUser-Server herstellen zu können.

9.Klicken Sie auf Windows Service installieren um den Service auf diesem Server zu installieren.
Klicken Sie anschliessen auf Weiter.

Anmerkung: Der Dienst kann auch manuell per Parameter installiert und deinstalliert werden:
> {Installdir}\MLMultiUserServerSVC.exe -install
> {Installdir}\MLMultiUserServerSVC.exe -uninstall

10. Klicken Sie auf Weiter um die Konfiguration zu speichern.

11. Sie finden den neuen Windows-Dienst nun in der lokalen Dienst-Verwaltung von Windows. Sofern die Datenbankumstellung und die
Konfiguration des Dokumenten-Ablagepfades abgeschlossen sind, kann der Dienst nun in der Dienstverwaltung von Windows gestartet werden.

Wichtig:

Der Windows-Service benötigt Zugriff auf den Dokumenten-Ablagepfad der Dokumenten-Verwaltung. Stellen Sie sicher, dass der Windows-Benutzer, unter welchem der Dienst läuft, Schreib- und Leserechte auf diesen Pfad besitzt!

Bedenken Sie, dass Freigaben die als Laufwerk verbunden sind IMMER auf einen bestimmen Benutzer verbunden sind. Wenn der Dokumentenpfad auf einem anderen Server abgelegt ist, sollte der direkte UNC-Pfad konfiguriert werden und der Dienst unter einem Benutzer mit Schreib- und Lesezugriff auf den UNC-Pfad ausgeführt werden.


Datenimport

Mit dem Datenimport-Modul können Daten von verschiedenen Formate wie z.B. CSV, VCard, usw. importiert werden.

Eine Schritt-für-Schritt Anleitung zur Bedienung des Import Assistenten finden Sie im Kapitel Import Assistent.

siehe auch:

Wie kann ich...


Import starten

Der Datenimport wird von verschiedenen Modulen verwendet und steht im Menübereich Import & Export zur Verfügung.

Klicken Sie auf den gewünschten Menüpunk um den Import zu starten und folgen Sie dem Import-Assistenten.

siehe auch:

Wie kann ich eine Excel-Datei importieren?

MLXML-Datei importieren

MLXML-Datei exportieren

Anmerkung:

Der MLXML-Export Wizard und der MLXML-Import Wizard steht nur in Produkten welche die MLXML Business Integration enthalten zur Verfügung. Eine Dokumentation zum Wizard finden Sie im entsprechenden Handbuch.


Import Assistent

1. Wählen Sie die Datei mit den Daten die Sie importieren möchten.

Wählen Sie bei Dateityp das Format in dem die zu importierende Datei vorliegt, wählen Sie die Datei aus und klicken Sie auf Öffnen.

2. Der Import-Assistent wird gestartet.

Über die Schaltfläche Konfiguration können Sie Einstellungen zum ausgewählten Import-Format vornehmen. Diese Einstellungen hängen vom ausgewählten Import-Format ab und müssen normalerweise nicht verändert werden.

Klicken Sie auf Weiter um fortzufahren.

3. Zuordnung der Felder

Auf dieser Seite werden die verfügbaren Ziel-Felder den verfügbaren Spalten der Import-Datei gegenübergestellt. Ordnen Sie alle Spalten (die Sie importieren möchten) der Import-Datei einem Feld auf der linken Seite zu.

Klicken Sie anschliessend auf Weiter.

4. Import Modus bestimmen.

Wenn Sie Alles importieren möchten, wählen Sie Alle Datensätze neu Einfügen. Wenn Sie nur neue Datensätze importieren möchten, müssen Sie unter Schlüsselfelder alle Felder, die für den Vergleich verwendet werden sollen, auswählen.

5. Import Optionen bestimmen

Wenn Sie aus einem Format importieren, das in der ersten Zeile Spaltenüberschriften enthalten kann (z.B. CSV) können Sie die Option Ersten Datensatz überspringen markieren damit die Spaltenüberschrift nicht importiert wird. Alle anderen Einstellungen müssen normalerweise nicht verändert werden.

6. Datenmanipulation vor dem Import

Hier kann für jedes Feld definiert werden, ob und wie die zu importierenden Daten vor dem Import manipuliert werden sollen.

Wenn Sie z.B. Postleitzahlen im Format "CH-9000" importieren möchten, können Sie hier das "CH-" entfernen.

Normalerweise müssen Sie hier keine Einstellungen vornehmen.

7. Bedingte Regeln

Hier können Sie erweiterte Kriterien für den Import von Datensätzen konfigurieren. Es kann z.B. definiert werden, dass Datensätze die eine gewisse Bedingung erfüllen nicht importiert werden oder der Wert eines Feldes durch den Wert eines anderen Feldes ersetzt wird.

Normalerweise müssen Sie hier keine Einstellungen vornehmen.

8. Import Start - Kontrolle der Konfiguration

Hier können Sie alle Einstellungen überprüfen. Wenn alle Einstellungen in Ordnung sind, können Sie den Import mit Weiter starten.

9. Import Beendet

Nach Abschluss des Datenimportes erhalten Sie eine ausführliche Aufstellung aller durchgeführten Aktionen. Falls Fehler aufgetreten sind, können Sie mit Zurück die Einstellungen entsprechend anpassen um die Fehler zu korrigieren.


Wie kann ich...

Wie kann ich...

...eine Excel-Datei importieren?


...eine Excel-Datei importieren?

Wenn Sie ein Produkt ohne MLXML Business Integration haben, müssen Sie die Excel Datei vor dem Import in eine CSV-Datei umwandeln. Ist die MLXML Business Integration verfügbar, steht zusätzlich noch der direkte Weg über den deutlich flexibleren und umfangreicheren MLXML-Import Wizard zur Verfügung.

Tip:

Wenn Sie eine normale, einfache Adressliste importieren möchten, ist der hier beschriebene Weg über das CSV-Format (auch wenn die MLXML Business Integration verfügbar ist) durchaus zu empfehlen. Der Import über CSV ist relative einfach zu bewerkstelligen und es gibt sehr wenig Fallstricke.

Import über CSV:

1. Öffnen Sie die gewünschte Datei in Excel

2. Klicken Sie im Menü Datei => Speichern unter...

3. Wählen Sie bei Dateityp das Format "CSV (Trennzeichen-getrennt) (*.csv)"

4. Speichern Sie die Datei mit Speichern

5. Diese Datei können Sie nun mit dem Import Assistent importieren.


Email Marketing

Mit dem Emailmarketing-Modul können Sie personalisierte Serien-Emails wie Newsletter, Infomails, Einladungen usw. an Personen aus Ihrem Adressdatenbestand senden.


Versand

Im Bereich Versand können personalisierte Emails und SMS-Nachrichten erstellt und diese an die jeweilige Verteilerliste gesendet werden.

Die Emails können in Ordner und Unterordner abgelegt werden.

siehe auch:

Email-Liste

Email-Editor

Textbausteine

Datei-Anlagen

Versand

Versand-History


Email-Liste

In der Email-Liste werden alle bereits erstellten Emails aufgelistet. Emails können kopiert oder abgeändert werden. Bereits gesendete Emails können zu einem späteren Zeitpunkt erneut gesendet oder ein weiteres mal gestartet werden. Die einzelnen Emails können in Ordner abgelegt werden.

Anmerkung:

Die SMS-Nachrichten werden ebenfalls in dieser Liste aufgeführt. Eine SMS-Nachricht unterscheidet sich von einem Email lediglich durch einen anderen Wert in der Spalte Format (SMS).

siehe auch:

Daten

Email hinzufügen

Email löschen

Email bearbeiten

Vorschau

Versand Starten

Versand Zeitplaner

Versand Abbrechen

Editor

Anlagen


Daten

Eine Email (oder eine SMS-Nachricht) beinhaltet folgende Daten:

Datenfeld | Beschreibung | benötigt
Emailname: | Name der Email oder der SMS-Nachricht (frei wählbar) | JA
Verteilerliste: | Verteilerliste an welche das Email oder das SMS gesendet werden soll. | JA
Format: | Format der Email. Es kann zwischen HTML-Email, Text-Email und Quellcode-Email ausgewählt werden. Für eine SMS-Nachricht wird der Status SMS verwendet. | JA
Status: | Status der Email oder der SMS-Nachricht. | JA

Der Inhalt der Email kann im Editor erstellt und geändert werden.

Datei-Anlagen, welche als Anhang mit der Email mitgesendet werden, können in Anlagen der Email hinzugefügt werden.

siehe auch:

Email hinzufügen

Email löschen

Email bearbeiten

Vorschau

Versand Starten

Versand Zeitplaner

Versand Abbrechen

Editor

Anlagen


Email hinzufügen

Klicken Sie auf die Schaltfläche Hinzufügen.

Es erscheint ein Eingabefenster in dem Sie die Daten, der neu zu erstellenden Email, eingeben können.

Klicken Sie auf "Speichern", um die Email mit den eingegebenen Daten zu erstellen.

Oder Sie klicken auf "Schliessen" und folgen dem erscheinenden Dialog um die eingegebenen Daten zu verwerfen oder anzunehmen.

Der Inhalt der Email kann im Editor erstellt und geändert werden.

Datei-Anlagen, welche als Anhang mit der Email mitgesendet werden, können unter Datei-Anlagen der Email hinzugefügt werden.

siehe auch:

Daten

Email löschen

Email bearbeiten

Vorschau

Versand Starten

Versand Zeitplaner

Versand Abbrechen

Email-Editor

Datei-Anlagen


Email löschen

Wählen Sie die zu löschende Email in der Email-Liste an.

Klicken Sie auf die Schaltfläche Löschen.

Folgen Sie dem erscheinenden Dialog um die Email zu löschen.

siehe auch:

Daten

Email hinzufügen

Email bearbeiten

Vorschau

Versand Starten

Versand Zeitplaner

Versand Abbrechen

Email-Editor

Datei-Anlagen


Email bearbeiten

Wählen Sie das zu bearbeitende Email in der Email-Liste an.

Klicken Sie auf die Schaltfläche Bearbeiten.

Es erscheint ein Eingabefenster in dem Sie die Daten, der zu bearbeitenden Email, ändern können.

Klicken Sie auf "Speichern", um die geänderten Daten zu übernehmen.

Oder Sie klicken auf "Abbrechen" und folgen dem erscheinenden Dialog um die geänderten Daten zu verwerfen oder anzunehmen.

Der Inhalt der Email kann im Email-Editor erstellt und geändert werden.

siehe auch:

Daten

Email hinzufügen

Email löschen

Vorschau

Versand Starten

Versand Zeitplaner

Versand Abbrechen

Email-Editor

Datei-Anlagen


Vorschau

Vor dem Versenden einer Email an eine Verteilerliste, können alle Emails an alle Empfänger generiert und in einem Vorschaufenster angesehen werden.

siehe auch:

Vorschau erstellen

Vor und Zurück

HTML

Text

Anlagen

Email-Liste


Vorschau erstellen

Wählen Sie eine Email in der Email-Liste an.

Klicken Sie auf die Schaltfläche Vorschau.

Wählen Sie die gewünschte Vorschau.

Über Versand... werden alle Emails für alle Empfänger der Verteilerliste generiert (nicht versendet!) und in einem Vorschaufenster angezeigt.

Über Erneuter Versand an... werden alle Emails, die bei einem erneuten Versand versendet werden, in einem Vorschaufenster angezeigt.

siehe auch:

Vor und Zurück

HTML

Text

Anlagen


Vor und zurück

Mit den Schaltflächen Vor und Zurück kann die nächste oder die vorhergehende Email angezeigt werden.

siehe auch:

Vorschau erstellen

HTML

Text

Anlagen


HTML

Im Reiter HTML wird das generierte Email im HTML-Format angezeigt.

Achtung:

Der Reiter HTML wird nur bei Emails mit den Formaten "HTML-Email" und "Quelltext-Email" angezeigt.

siehe auch:

Vorschau erstellen

Vor und Zurück

Text

Anlagen


Text

Im Reiter Text wird das generierte Email im Text-Format angezeigt.

siehe auch:

Vorschau erstellen

Vor und Zurück

HTML

Anlagen


Anlagen

Im Reiter Anlagen werden alle mit der Email mitgesendeten Datei-Anlagen aufgelistet. Die Datei-Anlagen können durch einen Doppelklick geöffnet werden.

Achtung:

Wenn Sie eine personalisierte Datei-Anlage öffnen und manuell abändern, werden die Änderungen nicht gespeichert. Personalisierte Datei-Anlagen werden beim Versenden der Email neu generiert.

siehe auch:

Vorschau erstellen

Vor und Zurück

HTML

Text


Versand Starten

Wählen Sie eine Email in der Email-Liste an.

Klicken Sie auf Versand.

Klicken Sie in der erscheinenden Auswahl auf Starten. Wenn Sie ein bereits versendetes Email erneut versenden möchten, klicken Sie auf Erneut versenden.

Folgen Sie dem erscheinenden Dialog um den Versand zu starten oder abzubrechen.

Emails bei welchen ein Versand läuft, werden in der Email-Liste grün dargestellt. Die aktuellen Versand-Details werden im Reiter Versand dargestellt.

siehe auch:

Erneuter Versand

Daten

Email hinzufügen

Email löschen

Email bearbeiten

Vorschau

Versand Zeitplaner

Versand Abbrechen

Email-Editor

Datei-Anlagen


Erneuter Versand

Über den erneuten Versand können Sie ein Email, abhängig vom letzten Versand-Erfolg/Misserfolg, weitere Male versenden.

Ein erneuter Versand ist nur möglich, wenn das Email bereits versendet wurde.

Bevor Sie ein Email ein weiteres Mal, anhand des letzten Versand-Erfolges/Misserfolges, versenden können, müssen Sie in der Versand-History das gewünschte Versand-Datum des letzten Versandes auswählen.

Ausgehend vom Versand an diesem Datum können Sie das Email nun ein weiteres Mal an alle Empfänger senden. Entweder an alle Empfänger die nicht zugestellt werden konnten oder an alle Empfänger die erfolgreich zugestellt werden konnten.

Wählen Sie eine Email in der Email-Liste an.

Öffnen Sie die Versand-History

Wählen Sie links in der Baumansicht Versand das letzte Versanddatum

Klicken Sie auf Versand.

Wählen Sie Erneut versenden.

Klicken Sie auf An alle fehlgeschlagenen um das Email erneut an alle Empfänger (die beim letzten Versand nicht zugestellt werden konnten) zu versenden.


Versand Zeitplaner

Mit dem Zeitplaner können Sie Emails zu einem späteren Zeitpunkt (z.B. über Nacht) versenden. Der Versand einer Email an die entsprechende Verteilerliste wird somit automatisch am angegebenen Zeitpunkt gestartet.

Emails bei welchen ein automatischer Versand geplant ist, werden in der Email-Liste grün dargestellt. Der geplante Versand-Zeitpunkt wird im Reiter Versand angezeigt.

Achtung:

Damit der Versand automatisch gestartet werden kann, muss delight email zum angegebenen Zeitpunkt auf Ihrem Computer gestartet sein.

siehe auch:

Automatischer Versand planen

Geplanter Versand abbrechen

Versand


Automatischer Versand planen

Wählen Sie eine Email in der Email-Liste an.

Klicken Sie auf Versand.

Klicken Sie in der erscheinenden Auswahl auf Zeitplaner.

Aktivieren Sie Versand automatisch starten am und wählen Sie das Datum und die Zeit an dem der Versand automatisch gestartet werden soll.

siehe auch:

Geplanter Versand abbrechen

Versand Zeitplaner


Geplanter Versand abbrechen

Automatischer Versand abbrechen

Wählen Sie eine Email bei welcher ein Versand geplant ist. (Wird in der Email-Liste grün dargestellt).

Klicken Sie auf Versand.

Klicken Sie in der erscheinenden Auswahl auf Abbrechen.

Folgen Sie dem erscheinenden Dialog um den Versand abzubrechen.

siehe auch:

Automatischer Versand planen

Versand Zeitplaner


Versand Abbrechen

Wählen Sie eine Email bei welcher ein Versand läuft ist. (Wird in der Email-Liste grün dargestellt).

Klicken Sie auf Versand.

Klicken Sie in der erscheinenden Auswahl auf Abbrechen.

Folgen Sie dem erscheinenden Dialog um den Versand abzubrechen.

siehe auch:

Daten

Email hinzufügen

Email löschen

Email bearbeiten

Vorschau

Versand Starten

Versand Zeitplaner

Editor

Anlagen


Email-Editor

Im Editor kann Inhalt und Betreff, der in der Email-Liste angewählten Email, eingegeben oder abgeändert werden.

siehe auch

Email-Liste

Text-Email

HTML-Email

Quelltext-Email

SMS-Nachricht

Textbausteine

Makros

Datei-Anlagen

Versand

Versand-History


Text-Email

Der Editor für Text-Emails wird angezeigt, wenn bei der angewählten Email "Text-Email" als Format gewählt wurde. Bei diesem Format stehen keine Textverarbeitungsfunktionen zur Verfügung. Der Inhalt der Email besteht aus reinem Text (plain-text).

Der Text-Format Editor steht auch bei den Formaten HTML-Email und Quellcode-Email zur Verfügung. Bei diesen zwei Formaten ist der Text-Teil optional. Wenn Sie keinen Text eingeben, wir der Text beim Versenden automatisch erstellt.

siehe auch:

Makros


HTML-Email

Der Editor für HTML-Emails wird angezeigt, wenn bei der angewählten Email "HTML-Email" als Format gewählt wurde. Bei diesem Format stehen diverse Textverarbeitungsfunktionen zur Verfügung, mit welchen der E-Mail-Inhalt beliebig formatiert werden kann. Es können z.B. Bilder, Tabellen und Links auf Webseiten eingefügt werden. Beim Text können Schriftart, Schriftgrösse und Farbe geändert werden. Es können auch RTF-Dokumente welche zB. in MS-Word erstellt wurden importiert werden.

siehe auch:

Makros


Quelltext-Email (Text/HTML)

Der Editor für Quelltext-Emails wird angezeigt, wenn bei der angewählten Email "Quelltext (Text/HTML)" als Format gewählt wurde. Bei diesem Format stehen keine Textverarbeitungsfunktionen zur Verfügung. Der Inhalt der Email besteht aus HTML-Quelltext. Sie können dieses Format verwenden, wenn Sie Ihre HTML-Emails ohne den integrierten Editor schreiben möchten.

Tip:

Durch die Verwendung von Textbausteinen können Sie auch in HTML-Quelltext-Emails die Textverarbeitungsfunktionen nutzen.

siehe auch:

Makros

Inline Bilder

Inline Anhang

Externe Bilder


Eingebettete Bilder in HTML-Quelltext

Es gibt zwei Möglichkeiten Bilder in einem HTML-Email einzubetten. Bilder aus Textbausteinen werden automatisch eingebettet.

Möglichkeiten Bilder einzubetten:

Inline Bilder

Externe Bilder


Inline Bilder

Inline-Bilder werden fast von jedem Mail-Programm angezeigt. Der Nachteil an Inline-Bildern ist, im Gegensatz zu extern verlinkten Bildern, die Grösse der einzelnen Emails. Inline-Bilder werden als Anhang an jedes Email angehängt.

HTML-Quelltext für ein Inline-Bild:

<img src="cid:Bild1.jpg">

Das Inline-Bild muss dem Email als Inline-Anhang angefügt werden.


Externe Bilder

Die externe Verlinkung auf ein Bild im Internet ist nicht optimal, da viele Email-Programme zum Schutz der Privatsphäre die extern verlinkten Bilder nicht anzeigen. Oft muss der Anwender das Anzeigen von externen Bildern explizit erlauben. Dies führt dazu, dass externe Bilder vom Empfänger oftmals nicht betrachtet werden.

Das extern verlinkte Bild wird zum Schutz der Privatsphäre vom Email-Programm nicht angezeigt.

Das Inline-Bild ist immer sichtbar.

HTML-Quelltext für ein extern verlinktes Bild:

<img src="http://www.delight.ch/delight.ch/images/page/1444740104.png">


Beispiel HTML-Quelltext

<html><head></head>

<body bgcolor="#ffffff" leftmargin=5 topmargin=5 rightmargin=5 bottommargin=5>

<font size=3 color="#000000" style="background-color:;" face="Times New Roman">

<div align=left>

[Geschaeftliche Anrede]<br>

<br>

<b>Beispiel HTML-Email im Quelltext</b><br>

<br>

<b><u>Tipp zur Verwendung von Bildern</u></b>

<br>

Ein Bild als Link einzufügen ist nicht optimal, da viele Email-Programme die extern verlinkten Bilder nicht anzeigen.

Oft muss der Anwender das Anzeigen von externen Bildern explizit erlauben.<br>

Dies führt dazu, dass externe Bilder vom Empfänger oftmals gar nicht betrachtet werden.<br>

<br>

Inline-Bilder werden fast von jedem Mail-Programm angezeigt.<br>

Der Nachteil an Inline-Bildern im Gegensatz zu verlinkten Bildern ist die Grösse des Emails.<br>

Inline-Bilder werden als Anhang an jedes Email angehängt.<br>

<br>

<b><i>Bild als "Inline Anhang"</i></b><br>

<img src="cid:Bild1.jpg"><br>

<br>

<b><i>Extern verlinktes Bild</i></b><br>

<img src="http://www.delight.ch/delight.ch/images/page/1444740104.png"><br>

</div>

</font>

</body></html>


SMS-Nachricht

Der Editor für SMS-Nachrichten wird angezeigt, wenn bei der angewählten Email "SMS" als Format gewählt wurde. Bei diesem Format stehen keine Textverarbeitungsfunktionen zur Verfügung. Der Inhalt der SMS besteht aus reinem Text.

siehe auch:

Makros


Makros

Makros sind Platzhalter, welche beim versenden der Email mit den im Makro hinterlegten Daten ersetzt werden. Sie werden benötigt um personalisierte Emails und personalisierte Datei-Anlagen zu erstellen.

siehe auch:

Makros in Email einfügen

Empfänger-Makros

Allgemeine Makros

Verteilerlisten-Makros

System-Makros

Textbausteine

Personalisierte Datei-Anlagen

Email-Editor


Makros in Email einfügen

Makros können angewählt und mit gedrückter linker Maustaste in den Email-Editor einer Text-Email oder HTML-Email oder in die Betreffzeile verschoben und an der gewünschten Stelle durch loslassen der Maustaste eingefügt werden (Drag&Drop). Makros werden im Email-Editor und in der Betreffzeile in eckigen Klammern wie z.B. [Name] dargestellt.

Textbausteine können in gleicher Art und Weise platziert werden.

siehe auch:

Empfänger-Makros

Allgemeine Makros

Verteilerlisten-Makros

System-Makros


Empfänger-Makros

Empfänger-Makros beinhalten Daten des E-Mail-Empfängers wie z.B. Name, Vorname usw. Empfänger-Makros werden vom Programm zur Verfügung gestellt und können nicht abgeändert oder erweitert werden.

siehe auch:

Makros in Email einfügen

Allgemeine Makros

Verteilerlisten-Makros

System-Makros


Allgemeine Makros

Allgemeine Makros können selbst erstellt und für alle Emails verwendet werden.

siehe auch:

Makros in Email einfügen

Empfänger-Makros

Verteilerlisten-Makros

System-Makros

Makros erstellen


Verteilerlisten-Makros

Verteilerlisten-Makros können selbst erstellt werden. Sie sind verteilerlistenbezogen und können nur für Emails verwendet werden, die an die jeweilige Verteilerliste gesendet werden.

siehe auch:

Makros in Email einfügen

Empfänger-Makros

Allgemeine Makros

System-Makros

Makros erstellen


System-Makros

System-Makros beinhalten System-Daten wie z.B. Datum, Uhrzeit usw. System-Makros werden vom Programm zur Verfügung gestellt und können nicht abgeändert oder erweitert werden.

siehe auch:

Makros in Email einfügen

Empfänger-Makros

Allgemeine Makros

Verteilerlisten-Makros


Textbausteine

Textbausteine können verwendet werden, um Inhalt und Design einer Email zu trennen.

Textbausteine sind vor allem bei Quelltext-Emails sehr praktisch. Der eigentliche Inhalt der Email kann als Platzhalter im Quelltext eingefügt und im komfortablen Editor des Textbausteines erfasst und geändert werden.

Textbausteine können, wie Makros, mit einem Platzhalter auf dem Email eingefügt werden.


Datei-Anlagen

Datei-Anlagen sind Dateien welche mit der in der Email-Liste angewählten Email als Anhang mitgesendet werden. Es können beliebig viele Datei-Anlagen hinzugefügt werden. Datei-Anlagen können mit den zur Verfügung stehenden Makros personalisiert werden.

Im rechten Bereich können weitere Einstellungen zur Personalisierung der angehängten Datei vorgenommen werden. Welche Einstellungen zur Verfügung stehen, hängt vom Typ (Dateiendung) der Datei ab.

siehe auch:

Daten

Neue Datei-Anlage hinzufügen

Datei-Anlage entfernen

Datei-Anlage öffnen

Personalisierte Datei-Anlagen


Daten

Eine Datei-Anlage beinhaltet folgende Daten:

Datenfeld | Beschreibung | benötigt
Dateiname: | Name der Datei-Anlage. Wird in der Email als Name der mitgesendeten Anlage angezeigt. | JA
Lokale Datei: | Datei welche mit der Email mitgesendet wird. | JA
Datei-Personalisierung: | Bei einer personalisierten Datei-Anlage, wählen Sie "Personalisieren" damit die in der Datei-Anlage eingefügten Makros beim versenden ersetzt werden. Bei einer normalen Datei-Anlage wählen Sie "Nicht Personalisieren" um den Versand zu beschleunigen. | JA
Inline | Wenn Sie ein Bild im HTML-Quelltext eines Quellcode-Emails verwenden möchten, muss das Bild als "Inline Anhang" mitgesendet werden. Inline-Anhänge werden vom Email-Programm als Bild im Email angezeigt, sind aber nicht als Anhang sichtbar. | nur bei Quellcode-Emails

siehe auch:

Neue Datei-Anlage hinzufügen

Datei-Anlage entfernen

Datei-Anlage öffnen

Personalisierte Datei-Anlagen

Anlagen


Neue Datei-Anlage hinzufügen

Wählen Sie eine Email in der Email-Liste an.

Klicken Sie auf die Schaltfläche Hinzufügen.

Es erscheint ein Fenster in dem Sie die gewünschte Datei auswählen können.

Klicken Sie auf Öffnen, um die Datei als Datei-Anlage (zu der in der Email-Liste angewählten Email) hinzuzufügen.

Hinweis:

Wenn Sie eine personalisierte Datei-Anlage hinzufügen möchten, müssen Sie anschliessend in der Datei-Anlagen-Liste, bei der hinzugefügten Datei-Anlage, im Eingabefeld Datei-Personalisierung die Option "Personalisieren" auswählen.

siehe auch:

Daten

Datei-Anlage entfernen

Datei-Anlage öffnen

Personalisierte Datei-Anlagen


Datei-Anlage entfernen

Wählen Sie die zu entfernende Datei-Anlage an.

Klicken Sie auf die Schaltfläche Entfernen.

Folgen sie dem erscheinenden Dialog um die Datei-Anlage zu entfernen.

Hinweis:

Die Datei-Anlage wird nur aus der Email entfernt. Die Datei auf dem Datenträger wird nicht gelöscht.

siehe auch:

Daten

Neue Datei-Anlage hinzufügen

Datei-Anlage öffnen

Personalisierte Datei-Anlagen


Datei-Anlage öffnen

Wählen Sie die zu öffnende Datei-Anlage an.

Klicken Sie auf die Schaltfläche Anzeigen.

Die Anlage-Datei wird im entsprechenden Programm geöffnet.

siehe auch:

Daten

Neue Datei-Anlage hinzufügen

Datei-Anlage entfernen

Personalisierte Datei-Anlagen


Personalisierte Datei-Anlage

Die zur Verfügung stehenden Makros können zur Personalisierung von Datei-Anlagen in den Formaten .rtf (Rich Text Format), .txt (Textdatei) und .pdf sowie im Dateinamen aller angefügten Datei-Anlage verwendet werden.

Makros in Datei-Anlagen und in Dateinamen müssen manuell eingegeben werden und sind in eckigen Klammern (z.B. [Name]) zu schreiben.

Hinweis:

Wenn Sie eine personalisierte Datei-Anlage hinzufügen möchten, müssen Sie anschliessend in der Datei-Anlagen-Liste, bei der hinzugefügten Datei-Anlage, im Eingabefeld Datei-Personalisierung die Option "Personalisieren" auswählen.

siehe auch:

Daten

Neue Datei-Anlage hinzufügen

Datei-Anlage entfernen

Datei-Anlage öffnen


PDF-Personalisierung

Zur Personalisierung von PDF-Dokumenten kann delight email optional das kostenlose Programm "PDFTK" verwenden. Durch die Installation von PDFTK stehen deutlich mehr Optionen zur Personalisierung von PDF-Datei-Anlagen zur Verfügung. Wenn keine PDF-Dateien personalisiert werden müssen, ist dieses Programm nicht erforderlich.

Die Personalisierung eines PDF-Dokumentes kann über Formular-Felder im PDF-Dokument gelöst werden. Makros, die in der PDF-Datei ersetzt werden sollen, müssen als Inhalt in einem Formular-Feld eingefügt werden. Die Namen der einzelnen Formular-Felder dürfen weder Umlaute (ä, ö, ü, ß u.s.w.) noch Leerzeichen enthalten. Ansonsten sind die Namen der Formular-Felder irrelevant für die Personalisierung und können frei gewählt werden.

Ist PDFTK nicht installiert, wird dies entsprechend angezeigt und es kann mit einem Klick installiert werden.

Bitte beachten Sie die Lizenzbestimmungen zu PDFTK auf www.accesspdf.com/pdftk


Versand

Im Reiter Versand werden Versand-Details der in der Email-Liste angewählten Email angezeigt. Versand-Details sind nur sichtbar solange ein Versand läuft oder ein automatischer Versand geplant ist. Emails bei welchen ein automatischer Versand geplant ist, werden in der Email-Liste grün dargestellt.

siehe auch:

Versand Starten

Versand Zeitplaner

Versand Abbrechen


Versand-History

Im Reiter History wird die Versand-History zur angewählten Email angezeigt.

Über den erneuten Versand können Sie das Email erneut an alle Empfänger, die unter Fehlgeschlagen oder Erfolgreiche aufgeführt sind, versenden.

siehe auch:

Email-Liste

Email-Editor

Datei-Anlagen

Versand

Erneuter Versand


Import/Export

Über das Menü Export kann die ausgewählte Email-Vorlage in eine Datei exportiert werden.

Über das Menü Import kann eine Email-Vorlage aus einer Datei importiert werden.


Verteilerlisten

Im Bereich "Verteilerlisten" können Sie beliebig viele Verteilerlisten erstellen. Für jede Zuordnung der Adressverwaltung wird automatisch eine Verteilerliste erstellt.

Verteilerlisten sind dynamisch aufgebaut und beinhalten nicht ein fixe Anzahl Empfänger-Adressen, sondern eine auf Filter basierende Empfänger-Selektion. Erfüllt eine Adresse aus der Adressverwaltung die Kriterien der Empfänger-Selektion wird die Adresse automatisch in die Verteilerliste aufgenommen. Erfüllt eine Adresse durch eine Adressänderung die Kriterien der Empfänger-Selektion nicht mehr, wird sie automatisch aus der Verteilerliste entfernt.

siehe auch:

Empfänger

Absender

Server

Makros

Versand


Empfänger

Im Reiter Empfänger können die Empfänger-Details der angewählten Verteilerliste eingegeben werden.

siehe auch:

Empfänger Email-Adresse

Empfänger-Selektion

Verteilerlisten


Empfänger Email-Adresse

Hier können Sie wählen an welche Email-Adresse die Email gesendet werden soll. Wenn Sie mehrere Email-Adressen auswählen, wird die Email an die erste Email-Adresse gesendet. Falls die erste Email-Adresse in der Adressverwaltung nicht ausgefüllt wurde, wird die nächste Email-Adresse verwendet.

Das selbe gilt für Mobil-Nummern beim SMS-Versand.

siehe auch:

Empfänger


Empfänger-Selektion

In der Empfänger-Selektion können Sie die Kriterien festlegen, welche für die Aufnahme einer Adresse aus der Adressverwaltung in die Verteilerliste massgebend sind.

Weitere Informationen zur Verwendung der Empfänger-Selektion finden Sie im Allgemeinen Handbuch im Kapitel Filter.

siehe auch:

Empfänger


Absender

Im Reiter Absender können Sie die Absender Email-Adresse der angewählten Verteilerliste festlegen.

Wenn Sie "Globale Adresse als Absender verwenden" anwählen, wird die Adresse verwendet, welche Sie in den Einstellungen der Adressverwaltung als globale Adresse festgelegt haben.

Wenn Sie "Globale Adresse als Absender verwenden" nicht anwählen, können Sie ein beliebiger Absender festlegen.

siehe auch:

Verteilerlisten

Empfänger

Server

Makros

Versand


Server

Im Reiter Server können Sie Mailserver-Einstellungen für die angewählte Verteilerliste vornehmen.

Wenn Sie Versand über integrierten Mailserver anwählen, werden die Emails vom Computer aus direkt versendet.

Diese Einstellung ist nur zu empfehlen, wenn Sie ein fixe IP-Adresse besitzen. Andernfalls landen vermutlich viele der versendeten Emails im Spam-Ordner des Empfängers oder der Empfang wird vom Empfänger verweigert.

Wenn Sie Versand über externen SMTP-Mailserver anwählen, werden die Emails über den angegebenen externen SMTP-Mailserver versendet.

Bitte beachten Sie, dass gewisse SMTP-Server auf eine maximale Anzahl von Emails pro Stunde limitiert sind. Ist dies der Fall, muss der Versand gestaffelt werden.

Wenn Sie Versand über Outlook anwählen, werden die personalisierten Emails direkt in den Postausgang von Outlook gespeichert. Das Versenden der einzelnen Emails übernimmt dann Outlook. Wählen Sie dazu bei "MAPI-Profil" das gewünschte Email-Profil über das die Emails versendet werden sollen. In den meisten Fällen nennt sich dieses Profil "Outlook"

Anmerkung: Der Versand über Outlook funktioniert nicht mit Outlook Express.


Makros

Im Reiter Makros können Sie Verteilerlisten-Makros und Allgemeine Makros erstellen.

Makros sind Platzhalter, welche beim versenden der Email mit den im Makro hinterlegten Daten ersetzt werden. Sie werden benötigt um personalisierte Emails zu erstellen.

siehe auch:

Allgemeine Makros

Verteilerlisten-Makros

Makrobedingungen


Allgemeine Makros

Allgemeine Makros können selbst erstellt und für alle Email verwendet werden.

Wählen Sie den Reiter Allgemeine Makros an.

Klicken Sie auf die Schaltfläche Hinzufügen.

Geben Sie dem neuen Makro unter Makro Einstellungen einen Namen.

Definieren Sie unter Makrobedingungen die Bedingungen des neuen Makros.

siehe auch:

Verteilerlisten-Makros

Makrobedingungen

Makros


Verteilerlisten-Makros

Verteilerlisten-Makros können selbst erstellt werden. Sie sind verteilerlistenbezogen und können nur für Email verwendet werden, die an die jeweilige Verteilerliste gesendet werden.

Wählen Sie den Reiter Verteilerlisten-Makros an.

Klicken Sie auf die Schaltfläche Hinzufügen.

Geben Sie dem neuen Makro unter Makro Einstellungen einen Namen.

Definieren Sie unter Makrobedingungen die Bedingungen des neuen Makros.

siehe auch:

Allgemeine Makros

Makrobedingungen

Makros


Makrobedingungen

In Bedingungen können Sie die Bedingungen und den Makro-Bedingung des angewählten Makros definieren. Beim Versenden einer personalisierten Email, werden die verwendeten Makros durch den Makro-Ergebniswert ersetzt, wenn die jeweilige Bedingung erfüllt ist.

Es können mehrere Bedingungen pro Makro definiert werden. Dabei wird die erste Makro-Bedingung verwendet, bei welcher die Bedingung zutrifft. Trifft keine der definierten Bedingungen zu, bleibt der Makro-Ergebniswert leer.

Beispiel:

-In einem personalisierten Email verwenden Sie das Makro [Geschäftliche Anrede]. (Die Makro-Bedingungen sehen Sie im Bild oben)

-Beim Versenden Ihrer Email wird das Makro [Geschäftliche Anrede] durch den Makro-Ergebniswert "Sehr geehrter Herr [Name]" ersetzt, wenn die Anrede des Empfängers (Bedingungs-Wert1) gleich Herr (Bedingungs-Wert2) ist.

-Ist die Anrede des Empfängers gleich Frau, wird das Makro durch Sehr geehrte Frau [Name] ersetzt. usw.

-Wobei [Name] den Nachnamen des jeweiligen Empfängers beinhaltet.

siehe auch:

Bedingung hinzufügen

Allgemeine Makros

Verteilerlisten-Makros

Makros


Bedingung hinzufügen

Wählen Sie ein Makro an.

Klicken Sie im Bereich Makrobedingung auf Hinzufügen.

Es erscheint ein Dialogfenster in dem Sie die Bedingung definieren können:

Bedingungswert 1:

Sie können ein Datenbankfeld oder ein fixer Wert als Bedingungswert 1 festlegen.

Bedingung:

Ist die Vergleichsfunktion, mit welcher der Bedingungswert 1 und Bedingungswert 2 verglichen werden.

Bedingungswert 2:

Sie können ein Datenbankfeld oder ein fixer Wert als Bedingungswert 2 festlegen.

Makro-Ergebniswert:

Ergebniswert des Makros wenn die Bedingung von Bedingungswert 1 und Bedingungswert 2 mit der definierten Vergleichsfunktion übereinstimmt.

siehe auch:

Makrobedingungen

Allgemeine Makros

Verteilerlisten-Makros

Makros


Versand

Im Reiter Versand können Sie Versand-Einstellungen für die angewählte Verteilerliste vornehmen.

Über die Staffelung kann der Versand der Emails gestaffelt werden.

Über "Anzahl Threads zum Versenden" können mehrere Staffeln gleichzeitig (parallel) gesendet. Die ist vor allem beim Versand von sehr vielen Email sinnvoll. Falls Sie einen externen SMTP-Server verwenden, sollten nicht mehrere Staffeln gleichzeitig versendet werden.

Falls der externe SMTP-Server ihres Providers auf eine maximale Anzahl von Email pro Stunde limitiert ist, könne Sie über "Pause nach jeder Staffel" die entsprechende Wartezeit für das Versenden der nächsten Staffel eingeben. Eine Wartezeit macht nur Sinn, wenn "Anzahl Threads zum Versenden" auf "1" gesetzt ist.

Die Option Pause nach jedem Email (Throttle) verteilt die Wartezeit (Pause nach jeder Staffel) beim Versand zwischen die einzelnen Emails.

Die Option Chaotischer Versand versucht die Emails anhand der Domäne (zB. @delight.ch) möglichst chaotisch zu sortieren. Chaotisch bedeutet, dass möglichst grosse Abstände zwischen dem Versand an die gleiche Domäne entstehen. Diese Funktion sollte üblicherweise verwendet werden, da damit das Risiko als SPAM eingestuft zu werden etwas minimiert wird.

Hinweis zu Thread Prioritäten:

Diese Einstellungen sind von Experten und Systemadministratoren vorzunehmen.

Im Normalfall können die Vorgabeeinstellungen übernommen werden.

siehe auch:

Verteilerlisten

Empfänger

Absender

Server

Makros


Einstellungen

In den Emailmarketing-Einstellungen können Sie Programmeinstellungen für das Email-Marketing vornehmen.

Die Einstellungen werden in der Backstage-Ansicht unter Konfiguration => Email Marketing aufgerufen.

siehe auch:

Email

Absender

Interner Mailserver

SMS


Email

Im Reiter Email können Sie verschiedene Status definieren, welche Sie bei Emails setzen können. Weiter können Sie festlegen welcher Status automatisch gesetzt werden soll.


Absender

Im Reiter Absender können Sie das Email-Feld der Globalen Adresse auswählen, welche als Absender-E-Mail-Adresse verwendet wird, wenn bei der Verteilerliste Globale Adresse als Absender verwenden angewählt ist.

siehe auch:

Absender


Interner Mailserver

Hinweis:

Diese Einstellungen sind von Experten und Systemadministratoren vorzunehmen. Im Normalfall können die Vorgabeeinstellungen übernommen werden.


SMS

Im Reiter SMS können Sie die Zugangsdaten Ihres SMS-Providers konfigurieren.


MLXML Business Integration

Mit der MLXML Business Integration können Daten automatisiert mit anderen Anwendungen ausgetauscht werden. Die Erweiterung beinhaltet verschiedene Konverter und Transportprotokolle zum ausliefern und importieren von Daten.

MLXML beschreibt ein XML-Schema, das alle (durch MLXML unterstützen) Daten der Software in einem einheitlichen XML-Format notieren kann. Eine MLXML-Datei kann verschiedene Daten (z.B. Adressen, Journal-Einträge, Skripte, Stammdaten wie Postleitzahlenstamm oder Bankenstamm usw.) in einer Datei beinhalten. MLXML-Dateien können an einem zentralen Punk in der Software importiert werden, egal welche Daten die Datei beinhaltet.

Mit geeigneten Konvertern kann praktische jede Datenquelle in ein MLXML-Dokument konvertiert werden. Optional merkt sich der Import zu jedem importieren Datensatz die Herkunft und eine eindeutige Datensatznummer (z.B. Primärschlüssel des Datensatzes in der Quell-Datenbank). Somit können verschiedene Daten aus verschiedenen Datenquellen automatisiert zusammengezogen und aktualisiert/synchronisiert werden.

siehe auch:

MLXML-Business Wizard

Import

Transport

Konverter

MLXML-Format


MLXML-Business Wizard

Der MLXML-Business Wizard bietet eine Oberfläche zur Bearbeitung von Import- und Exportkonfigurationen. Diese Konfigurationen können in einem Textformat gespeichert und jederzeit wieder ausgeführt werden. Optional können die gespeicherten Konfigurationen über den Taskplaner geplant und automatisiert im Hintergrund ausgeführt werden.

Es steht jeweils ein separater Wizard für Import- und Export zur Verfügung. Da beide Wizards sehr ähnlich sind und sich nur in kleinen Details unterschieden, dokumentiert dieses Handbuch die Grundlegenden Funktionen beider Wizards gemeinsam in einem Kapitel.

Die Wizards werden im Menübereich Import & Export gestartet.

Wählen Sie eine vordefinierte Einstellung oder erstellen Sie eine neue Konfiguration.

In der Auswahl vordefinierte Einstellungen stehen im Lieferumfang enthaltene sowie selbst erstelle Konfigurationen zur Verfügung. Über Neue Konfiguration kann eine neue Konfiguration für einen bestimmten Konverter erstellt werden.

Wird eine vordefinierte Einstellung ausgewählt, die den direkten Start ohne weitere Konfigurationsschritte erlaubt, kann die Aktion über Import/Export starten gestartet werden.

Mit klick auf Konfiguration kann die ausgewählte Einstellung konfiguriert werden.


Konfiguration

Die Konfiguration ist sehr umfangreich, je nach Konverter stehen unterschiedliche Einstellungen zur Verfügung.

Folgende Bereiche sind verfügbar:

Einstellungen | Einstellungen zum Konverter und zur Ein- und Ausgabe der Daten.
MLXML/BI-Optionen | Allgemeine Optionen sowie globale Optionen für MLXML.
Verarbeitung | Einstellungen zur Verarbeitung der Daten.


Einstellungen

Im Bereich Einstellungen werden spezifische Einstellungen zum Konverter sowie zur Ein- und Ausgabe der Daten konfiguriert.

Allgemein | Allgemeine Angaben zur Konfiguration.
Einstellungen zum Konverter | Einstellungen zum gewählten Konverter den die Konfiguration verwendet.
Ausgabe | Einstellungen zur Datenausgabe.


Allgemein

Im Bereich Allgemein werden allgemeine Einstellungen zur Konfiguration zur vorgenommen.

Titel | Titel/Bezeichnung der Konfiguration. Wird im Wizard auf der Startseite angezeigt.
Quell-Applikation | Freier Bezeichner für den Ursprung bzw. die Herkunft der Daten.
MLXML-Part | Definiert um welche Daten im Programm es sich handelt. Beim Import das Ziel der Daten, beim Export die Daten welche exportiert werden sollen.
MLXML-ItemPart | Bezeichner für die Daten im MLXML-Format. Kann in der Regel leer belassen werden.
MXC-Identifier | Schlüssel der die Konfiguration einem bestimmten Bereich im Programm zuordnet. Kann in der Regel leer belassen werden.
Parameter | Parameter für die Konfiguration. Kann in der Regel leer belassen werden.
UID | Eindeutiger Schlüssel für die Konfiguration. Jede Konfiguration sollte eindeutig identifiziert werden können. Wird eine Konfigurationsdatei kopiert, sollte mit Erzeugen ein neuer Schlüssel definiert werden.


Einstellungen zum Konverter

Im Bereich mit den Einstellungen zum Konverter kann der verwendete Konverter konfiguriert werden. Jeder Konverter hat seine eigenen Einstellungen.

Dieses Handbuch dokumentiert die wichtigsten Konverter:

ADODB/OLEDB | Import/Export sämtlicher ADO/OLEDB Datenbanken.
CSV (Comma-separated) | Import von CSV (Trennzeichen getrennt) Dateien.
Base | Import von DBASE-Datenbanken.
LDAP | Import von LDAP Directories.
Magento-Shop | Import/Export von und zu Magento Commerce Online Shop.
MySQL Database | Nativer Import/Export von/zu MySQL-Datenbanken.
Direct Database Access | Nativer Import/Export von/zu allen gängigen Datenbanken: ·Access ·Advantage ·ASE ·DB2 ·InterBase ·MySQL ·ODBC ·Oracle ·PostgreSQL ·SQL Server ·SQLite
XSLT Transformation | Transformiert ein beliebiges XML-Dokument mit einem XSL-Stylesheet.


ADODB/OLEDB

Der ADODB/OLEDB Konverter importiert/exportiert von sämtlichen ADO/OLEDB Datenbanken.

Im Eingabefeld Verbindungs-String kann der ADO/OLE Verbindungsstring definiert werden. Über die Schaltfläche [image] kann der Verbindungsstring aufgebaut werden.

In Tabelle kann die Daten-Tabelle ausgewählt werden.

Alternativ kann über Abfrage ein SQL-Query zur Datenabfrage definiert werden. Das SQL-Query kann optional auch in eine Datei ausgelagert werden. Der Dateiname wird dabei in folgender Form eingegeben: @{@DATEINAME}

Bsp:

Anmerkung:

Der Platzhalter $APP$ wird zur Laufzeit durch den Installationspfad ersetzt.


CSV (Comma-separated)

Der CSV Konverter importiert CSV-Dateien.


DBase

Der DBase Konverter importiert Daten aus einer DBASE-Datenbank. Für diesen Konverter stehen keine spezifischen Einstellungen zur Verfügung.


LDAP

Der LDAP Konverter importiert Daten aus einem LDAP Directory.


Magento-Shop

Der Magento-Shop Konverter steht für die Kommunikation mit Magento Commerce Online Shop zur Verfügung.

Die Schnittstelle zu Magento Commerce Online Shop benutzt ua. diesen Konverter.


MySQL Database

Der MySQL Konverter importiert Daten aus einer MySQL-Datenbank. Der Zugriff erfolgt direkt, die MySQL-Client-Libraries sind nicht erforderlich.

In den Eingabefelder Host, Benutzername, Passwort und Datenbank wird der gewünschte MySQL-Server konfiguriert.

In Tabelle kann die Daten-Tabelle ausgewählt werden.

Alternativ kann über Abfrage ein SQL-Query zur Datenabfrage definiert werden. Das SQL-Query kann optional auch in eine Datei ausgelagert werden. Der Dateiname wird dabei in folgender Form eingegeben: @{@DATEINAME}

Bsp:

Anmerkung:

Der Platzhalter $APP$ wird zur Laufzeit durch den Installationspfad ersetzt.


Direct Database Access

Der Direct Database Access Konverter bietet Zugriff auf die meisten, gängigen Datenbanken.

Über Konfiguration kann der zu verwendende Datenbank-Server konfiguriert werden.

In den Eingabefelder Host, Benutzername, Passwort und Datenbank werden die Zugriffsdaten des Servers konfiguriert.

In Tabelle kann die Daten-Tabelle ausgewählt werden.

Alternativ kann über Abfrage ein SQL-Query zur Datenabfrage definiert werden. Das SQL-Query kann optional auch in eine Datei ausgelagert werden. Der Dateiname wird dabei in folgender Form eingegeben: @{@DATEINAME}

Bsp:

Anmerkung:

Der Platzhalter $APP$ wird zur Laufzeit durch den Installationspfad ersetzt.

Unterstütze Datenbanken:

·Access

·Advantage

·ASE

·DB2

·InterBase

·MySQL

·ODBC

·Oracle

·PostgreSQL

·SQL Server

·SQLite


XSLT Transformation

Der XSLT Transformation Konverter transformiert ein beliebiges XML-Dokument mit einem XSL-Stylesheet.


Ausgabe

Im Bereich Ausgabe wird definiert, wie die konvertierten Daten (im MLXML-Format) weiter behandelt werden sollen.

Importieren | Daten normal ins Programm importieren.
Nur in Datei umleiten | Daten nur in eine externe Datei speichern aber nicht importieren.
Importieren und Kopie in Datei umleiten | Daten normal ins Programm importieren und eine Kopie der Daten in eine externe Datei speichern.
Ausgabedatei | Falls die Daten in eine externe Datei umgeleitet werden, kann hier Dateiname und Pfad auf die Ausgabedatei gesetzt werden.
Errorlogdatei | Dateiname und Pfad für externe Datei in welche allfällige Fehler beim konvertieren gespeichert werden.


MLXML/BI-Optionen

Im Bereich MLXML/BI-Optionen werden allgemeine Einstellungen zur Konfiguration sowie Optionen für die MLXML-Daten verwaltet.


Allgemein

Im Bereich Allgemein werden allgemeine Einstellungen zur Konfiguration verwaltet.

Im Eingabefeld Eingabedatei kann ein fix definierter Dateipfad hinterlegt werden. Die Eingabedatei kann über alle verfügbaren Transport-Protokollen (Festplatte, FTP, HTTP) bezogen werden. Soll die Eingabedatei vor jedem Import abgefragt werden, kann stattdessen die Option Dateiauswahl-Dialog für Eingabedatei anzeigen aktiviert werden. Um die Dateiauswahl auf einen bestimmten Dateityp zu beschränken, kann die Dateiendung der Eingabedatei im Eingabefeld Dateiendung der Eingabedatei definiert werden.


Optionen

Im Bereich Optionen können Optionen und Steuerkommandos für die spätere Verarbeitung der MLXML-Daten definiert werden.


Verarbeitung

Im Bereich Verarbeitung kann die eigentliche Import-Konfiguration vorgenommen werden.

Die Verarbeitung ist in folgende Bereich aufgeteilt:

Feldmapping | Zuweisung der Felder.
Konstanten | Konstante Werte, Makros und Skripte definieren.
Datentypen | Datentype für die Importfelder definieren.
Ersetzen | Nach Inhalt in Felder suchen und ersetzen.
Datum/Zeit Format | Format für Datum um Zeit im Textformat.
Feldaufteilung | Aufteilung der Daten in mehrere Felder.
Datenmanipulation | Daten anhand verschiedener Kriterien manipulieren/verändern.
Filter | Daten filtern.
Schlüsselfelder | Schlüsselfelder zur Suche nach bereits vorhandenen Datensätzen.
Datenverarbeitung | Einstellungen zur Verarbeitung der konvertierten Daten.
RTF/HTML Konvertierung | Einstellungen zur Konvertierung der Daten von RTF <> HTML.
Virtuelle Felder | Erstellen von virtuellen Felder.
Detaildaten | Konfiguration der Detaildaten/Unterimports.


Feldmapping

Im Bereich Feldmapping können die Felder der Quelle den Feldern des Ziels zugewiesen werden.

Über Automatisch Zuordnen versucht das Programm die Zuweisung automatisch, über die Namen der Felder, auszuführen.

Anmerkung:

Felder denen bereits ein konstanter Wert zugewiesen wurde, stehen hier nicht zur Verfügung.


Konstanten

Im Bereich Konstanten kann für Zielfelder ein konstanter Wert hinterlegt werden.

Um einen konstanten Wert für ein Feld zu definieren, muss die Option Konstante auf dem Feld aktiviert werden. Danach kann der Wert in der Spalte Wert erfasste werden. Es ist auch möglich, den Wert eines Zielfeldes oder den Wert eines virtuellen Feldes aus einem Makro als Wert zu übernehmen. Für komplexere Aufgaben können sogar Werte über ein Skript berechnet werden.

Anmerkung:

Felder denen bereits ein Zielfeld im Feldmapping zugewiesen wurde, stehen hier nicht zur Verfügung.


Makros in Konstanten

Für gewisse Aufgaben ist es manchmal erforderlich, gewisse Feldwerte in mehrere Felder zu importieren oder mehrere Werte in einem Feld zusammen zu führen. Dazu können in den konstanten Werten sogenannte Makros verwendet werden. Markos sind im Grunde Platzhalter für Werte. Makros stehen sowohl für gemappte Zielfelder wie auch für virtuellen Felder zur Verfügung. Für die Makros müssen die Feldnamen (nicht die übersetzten Feldtitel!) verwendet werden.

Um Makros zu verwenden, muss das Spezial-Kommando @{} verwendet werden. Die Zeichen @{} werden in diesem Fall nicht importiert, der Inhalt zwischen den Klammern {} wird beim importieren ausgewertet, alle Makros darin ersetzt und das Ergebnis importiert.

Methode 1: Wert eines bestimmten Feldes (in diesem Bsp. countryid) 1:1 übernehmen.

@{[countryid]}

Methode 2: Den Wert eines oder mehrerer Felder (in diesem Bsp. surname und countryid) in einem Text(wert) einbetten/ersetzen.

@{'[surname] aus dem Land [countryid]'}

Hat das Feld countryid den Wert "Schweiz" und das Feld surname den Wert "Müller" wäre das Ergebnis wie folgt:

Methode 1: Schweiz

Methode 2: Müller aus dem Land Schweiz

Anmerkung:

Der Inhalt des Spezial-Kommandos @{} wird nicht durch den Konverter sondern erst später beim Import der MLXML-Daten ausgewertet.


Werte in Skripten berechnen

Für komplexe Aufgaben ist es manchmal erforderlich, gewisse Feldwerte per Skript anhand von verschiedene Kriterien und Grundlagen zu berechnen oder auszuwählen. Dazu können in den konstanten Werten sogenannte Skripte verwendet werden. Das Skripting ist sehr umfangreich, in diesem Handbuch wird die allgemeine Programmierung von Skripten nicht weiter behandelt.

Um Skripte zu verwenden, muss das Spezial-Kommando @{} verwendet werden. Die Zeichen @{} werden in diesem Fall nicht importiert, das Skript zwischen den Klammern {} wird beim importieren ausgeführt und das Ergebnis importiert.

Beispiel um die Funktion GetNote in der Skriptdatei WebFormUtil.pas auszuführen.

@{GetNote@$APP$mlxml\scripts\WebFormUtil.pas}

Der Platzhalter $APP$ wird automatisch durch den Installationspfad des Programms ersetzt.

Das Skript in der Datei WebFormUtils.pas könnte in diesem Fall wie folgt aussehen:

[Pascal-Code]

function GetNote(const Data: TXMLDataWrapper): Variant;

begin

Result := Data.ValueByName('comment') + #13#10 +

#13#10 +

'Raumfläche: ' + Data.ValueByName('roomarea') + #13#10 +

'Baubegin: ' + Data.ValueByName('buildstart') + #13#10 +

'Bauende: ' + Data.ValueByName('buildend');

end;

Anmerkung:

Der Inhalt des Spezial-Kommandos @{} wird nicht durch den Konverter sondern erst später beim Import der MLXML-Daten ausgewertet.


Datentypen

Im Bereich Datentypen kann der Datentyp für die einzelnen Spalten eines Textformats definiert werden.

Da in Textformaten wie zB. CSV nicht definiert ist, welcher Typ von Daten (Datum, Zeit, Zahl, Text) sich in einer Spalte befindet, kann hier jeder Spalte ein Datentyp zugewiesen werden.


Ersetzen

Im Bereich Ersetzen können bestimme Werte in einem Feldinhalt durch andere Werte ersetzt werden.

Für jedes Importfeld kann eine Liste mit Werten hinterlegt werden. Wählen Sie das gewünschte Importfeld in welchem der Inhalt ersetzt werden soll und klicken sie auf die Schaltfläche mit dem Plus [image] (unten Links).

Es werden nicht nur ganze Wörter sondern auch Teilinhalte gesucht und ersetzt. Wenn explizit nur komplette Feldinhalte (keine Teilinhalte) gesucht und ersetzt werden müssen, kann der Suchbegriff in Suchen nach in geschweifte Klammern gesetzt werden.

Beispiel:


Datum/Zeit Format

Im Bereich Datum/Zeit Format werden die Formate zur Umwandlung von Text in Datum- Zeit- und Zahlenwerte konfiguriert.

Im Eingabefeld Zeitzone wird definiert, in welcher Zeitzone die Datum- und Zeitwerte der Importquelle vorliegen. Die restlichen Angaben sind nur bei Textimportformaten wie zB. CSV erforderlich. Mit ihnen wird definiert, in welchem Format die Daten in der Textdatei abgelegt wurden.


Feldaufteilung

Im Bereich Feldaufteilung können die Spalten (Felder) der Quelle zusätzlich anhand von bestimmten Zeichen, im Inhalt, auf mehrere Spalten aufgeteilt werden.

Über Anzahl Teilungen kann für jedes Feld bestimmt werden, in wie viele Felder (Spalten) das entsprechende Feld aufgeteilt werden soll. Der Inhalt der Felder wird an der Stelle von Separator-Zeichen aufgeteilt.

Wird z.B. das Feld Land einmal mit dem Separatorzeichen 0x20 (Leerzeichen) aufgeteilt, stehen im Feldmapping danach zwei Landes-Felder zur Verfügung: Land und Land_PART1

Hat bei einem Datensatz das Landes-Feld den Inhalt "CH Schweiz", steht im Feld Land der Wert "CH" und im Feld Land_PART1 der Wert "Schweiz".


Datenmanipulation

Im Bereich Datenmanipulation können die Werte der Felder nach bestimmten Kriterien korrigiert bzw. umgewandelt werden.


Filter

Im Bereich Filter können die Datensätze der Quelle anhand von Perl-Regular Expressions gefiltert werden.

Auf jedem Feld kann eine sogenannte RegEx hinterlegt werden. Der Datensatz wird nur importiert/exportiert wenn die RegEx auf allen Feldern positiv/wahr zutrifft. Über [...] im Editiermodus am Ende des Eingabefeldes kann der integrierte RegEx-Editor zum testen der RegEx aufgerufen werden.

Eine aktuelle Dokumentation zu Regular Expressions finden Sie auf http://perldoc.perl.org/perlre.html

Weitere Informationen:

http://de.wikipedia.org/wiki/Regulärer_Ausdruck

http://en.wikipedia.org/wiki/Regular_expression


Schlüsselfelder

Im Bereich Schlüsselfelder können Felder zur Überprüfung, ob ein Datensatz bereits vorhanden ist, definiert werden.

Wird in der Datenverarbeitung die Option Existierende Datensätze suchen/aktualisieren verwendet, können hier die gewünschten Suchfelder definiert werden. Ein Datensatz gilt dann als identisch, wenn die Werte aller Schlüsselfelder übereinstimmen.


Datenverarbeitung

Im Bereich Datenverarbeitung kann definiert werden, wie die Daten aktualisiert oder importiert werden.

Existierende Datensätze suchen

Definiert ob nach bereits vorhandenen Datensätzen gesucht werden soll. Ist diese Option nicht aktiv werden alle Datensätze importiert.

Existierende Datensätze aktualisieren

Wird Option Existierende Datensätze suchen verwendet, kann über diese Option gesteuert werden, ob bereits existierende Datensätze überschrieben werden sollen.

Datensätze mit Baumstruktur

Liegen die Daten in einer Baumstruktur vor, können diese durch Aktivierung dieser Option entsprechend verschachtelt importiert werden.

Wird diese Option aktiviert, müssen die Quelldaten über ein SQL-Query mit Parameter so selektiert werden, dass jeweils die Unterknoten eines Datensatzes selektiert/importiert werden. Der Konverter importiert/selektiert so lange Unterknoten, bis keine Knoten mehr gefunden werden.

Wird diese Option auf Daten die keine Baumstruktur repräsentieren aktiviert, kann der Konverter in eine Endlosschlaufe laufen!

Bsp:

SELECT NAME, GROUPID, PARENTGROUPID FROM TBL_GROUP

WHERE (PARENTGROUPID = :GROUPID) or (PARENTGROUPID IS NULL)

Modus

Der Modus ist nur für Detaildaten relevant:

Detaildaten | Daten werden als Detaildaten der übergeordneten Daten (Hauptdaten) importiert.
Vor Hauptdaten | Daten werden vor den übergeordneten Daten (Hauptdaten) auf der gleichen Eben (nicht als Detaildaten) importiert. Kann zB. verwendet werden um vor dem Import der Hauptdaten gewisse Stammdaten, die beim Import der Hauptdaten referenziert werden, zu importieren.
Nach Hauptdaten | Daten werden nach dem Import der übergeordneten Daten (Hauptdaten) auf der gleichen Eben (nicht als Detaildaten) importiert.

Felder zur Prüfung auf Änderung

Wenn die Optionen Existierende Datensätze suchen und Existierende Datensätze aktualisieren aktiviert sind, wird ein Datensatz normalerweise komplett überschrieben. Werden hier Felder markiert, prüft der Import zusätzlich ob eines der markierten Felder geändert hat. Der Datensatz wird dann nur bei einer Änderung überschrieben.

Felder zur Aktualisierung bei Änderung

Wird hier kein Feld markiert, werden beim aktualisieren/überschreiben eines Datensatzes alle in der Konfiguration definierten Felder in den Datensatz geschrieben/überschrieben. Sind hier Felder ausgewählt werden nur die betreffenden Felder aktualisiert.


RTF/HTML Konvertierung

Im Bereich RTF/HTML Konvertierung können Optionen, zur Konvertieren von RTF nach HTML, definiert werden.


Virtuelle Felder

Im Bereich Virtuelle Felder können zusätzliche, virtuelle Felder erstellt werden.

Den hier unter Virtuelle Zielfelder erfassten Felder können im Feldmapping die Felder aus der Datenquelle (Importfelder) zugewiesen werden. Diese virtuellen Felder werden sinngemäss nicht importiert/exportiert, können aber als Makro in den Konstanten oder in Import-Skripts verwendet werden.


Detaildaten

Im Bereich Detaildaten können beliebig viele, zusätzliche Datentabellen als Detaildaten oder normale zusätzliche Daten importiert werden.

Über die Schaltfläche mit dem Plus [image] (unten Links) können neue Unter/Detailkonfigurationen erstellt werden. Über Bearbeiten können bestehende Konfigurationen bearbeitet werden. Auf einer Detailkonfiguration stehen wie auf der Hauptkonfiguration sämtliche Konfigurationsmöglichkeiten zur Verfügung. Eine Detailkonfiguration muss den selben Konverter wie die Hauptkonfiguration verwenden, kann aber zB. beim Direct Database Access Konverter auf eine komplett andere Datenbank zugreifen. Damit könnten zB. in einer Konfiguration Daten aus verschiedenen Datenbanken und Systemen zusammen gezogen und importiert werden.


Konfiguration Speichern

Nach Abschluss der Konfiguration kann diese in einer Datei als vordefinierte Einstellung gespeichert werden. Klicken Sie dazu rechts Unten auf Weiter.

Anschliessend kann die Konfiguration mit Konfiguration in Datei speichern gespeichert werden.

Wählen Sie den gewünschten Speicherort um die Datei zu speichern.

Mit Speichern unter wird der anschliessende Speichern-Dialog mit dem Datenverzeichnis zum Speichern der vordefinierte Einstellungen geöffnet.

Mit Speichern unter Programmverzeichnis wird der anschliessende Speichern-Dialog mit dem Programmverzeichnis zum Speichern der vordefinierte Einstellungen geöffnet. In diesem Verzeichnis haben üblicherweise nur Administratoren Schreibrechte.

Anmerkung:

Sollten Sie eine Zugriffsfehlermeldung beim Speichern erhalten, fehlen ihnen die benötigten Schreibrechte im Verzeichnis. Verwenden Sie in diesem Fall Speichern unter um die Konfiguration im Datenverzeichnis zu speichern.


MLXML-Datei importieren

1. Klicken Sie im Menübereich Import & Export im Bereich auf Import => MLXML Datei.

2. Suchen Sie über [image] die Datei die Sie importieren möchten.

Datei: Wenn Sie die Datei lokal auf Ihrem Computer gespeichert haben, klicken Sie auf die

Schaltfläche [...] am Ende des Eingabefeldes MLXML-Datei und wählen Sie die gewünschte

Datei.

URL: Wenn Sie eine URL (z.B. http://mirror01.delight.ch/banks/german_blz_20060605.mlxml)

importieren möchten, geben Sie den URL im Eingabefeld MLXML-Datei ein.

Klicken Sie anschliessend auf Start um den Import zu starten.

3. Falls Sie einen URL eingegeben haben wird die Datei nun heruntergeladen.

4. Wenn Sie die Datei zum ersten Mal importieren, können Sie den Update-Modus deaktivieren um den Import zu beschleunigen.

Um den Update-Modus zu deaktivieren, entfernen Sie die Markierung bei Bereits vorhandene Datensätze suchen.

Klicken Sie anschliessend auf Weiter um den Import zu starten.

Hinweis:

Liegen sehr viele Daten vor, kann der Import einige Zeit in Anspruch nehmen. (z.B. beim Import von über 39'000 französischen Postleitzahlen).

Sollten Sie den Import zwischendurch abbrechen (nicht empfohlen!) müssen Sie bei einem zweiten Import den Update-Modus für den Import verwenden!

siehe auch:

Transport

Konverter


MLXML-Datei exportieren

1. Klicken Sie im Menübereich Import & Export im Bereich auf Export => MLXML-Exportieren.

2. Wählen Sie über [image] die Zieldatei in die Sie exportieren möchten und markieren Sie in Daten für den Export die gewünschten Daten die exportiert werden sollen.


Transport

Der MLXML-Import und Export unterstützt verschiedene Transport-Protokolle um die Daten zu übertragen. So ist es z.B. möglich, Daten direkt ab einem FTP-Server oder Web-Server (HTTP) zu importieren. Analog können die Daten beim Export entsprechend auch auf eine FTP-Server hochgeladen werden.

Protokoll | Beschreibung | Download | Upload
Lokale Datei und UNC | Import/Export einer Datei die auf der lokalen Festplatte oder auf einer Netzwerkfreigabe (UNC) liegt. | Ja | Ja
HTTP | Import direkt ab einem Internet-Link. Beispiel: http://www.meineseite.ch/Adressen.mlxml | Ja | Nein
FTP | Import/Export ab einem FTP-Server. Beispiel: ftp://benutzer:passwort@ftp.meineseite.ch/Adressen.mlxml | Ja | Ja


Konverter

Mit dem entsprechenden Konverter kann praktische jede Datenquelle in ein MLXML-Dokument konvertiert und importiert werden.

Konverter | Beschreibung | Parameter | Kurzbezeichnung
ADODB Converter | Kann ADO/ODBC Datenbanken nach MLXML konvertieren. | INI-Datei mit der Konfiguration für den Konverter. | ado-c
CSV Converter | Kann CSV (Komma-Getrennte Textdateien) nach MLXML konvertieren. | INI-Datei mit der Konfiguration für den Konverter. | csv-c
XSLT Transformation | Kann ein beliebiges XML-Dokument anhand eines XSL-Stylesheets nach MLXML transformieren. | XSL-Stylesheet-Datei für die Transformierung. | xslt-c
DBase Converter | Kann DBASE-Datenbanken nach MLXML konvertieren. | INI-Datei mit der Konfiguration für den Konverter. | dbase-c
LDAP Converter | Kann LDAP Directories nach MLXML konvertieren. | INI-Datei mit der Konfiguration für den Konverter. | ldap-c
Magento-Shop Converter | Import-Konverter für die Kommunikation mit Magento Commerce Online Shop. | INI-Datei mit der Konfiguration für den Konverter. | magento-c
MySQL Database Converter | Kann native auf MySQL Datenbanken zugreifen und nach MLXML konvertieren. | INI-Datei mit der Konfiguration für den Konverter. | mysql-c
Direct Database Access Converter | Native-Zugriff auf verschiedene Datenbanken zur Konvertierung nach MLXML: ·Access ·Advantage ·ASE ·DB2 ·InterBase ·MySQL ·ODBC ·Oracle ·PostgreSQL ·SQL Server ·SQLite | INI-Datei mit der Konfiguration für den Konverter. | directdb-c


Konfigurationsdatei

Einige Konverter benötigen eine Konfigurationsdatei mit Einstellungen. In der Konfiguration werden Feldzuweisungen, MLXML-Einstellungen sowie individuelle Einstellungen für den jeweiligen Konverter konfiguriert. Die Konfiguration wird in einer INI-Datei gespeichert.

Dieses Kapitel beschreibt nicht den kompletten Umfang der Möglichkeiten. Zur Erstellung der Konfigurationen sollte der MLXML-Business Wizard verwendet werden.

Bereich [Settings]

Name | Beispiel-Wert | Beschreibung | Konverter
SkipRows | 0 | Anzahl der Zeilen die zu Beginn des Dokumentes übersprungen werden sollen | csv-c
UseHeader | 1 | Muss auf 1 gesetzt werden, wenn die CSV-Datei Spaltenüberschriften in der 1. Zeile enthält | csv-c
Separator | ; | Zeichen das als Spalten-Trenner verwendet wird | csv-c
QuoteChar | " | Zeichen das den Inhalt der Spalten abgrenzt | csv-c
DateFormat | dd-mm-yyyy | Format der Datumswerte | csv-c
TimeFormat | hh:mm:ss | Format der Zeitwerte | csv-c
DateSeparator | . | Trennzeichen für Datumswerte | csv-c
TimeSeparator | : | Trennzeichen für Zeitwerte | csv-c
DecimalSeparator | . | Dezimal-Trennzeichen für Kommazahlen | csv-c
ThousandSeparator | ' | 1000er-Trennzeichen für Zahlenwerte | csv-c
ConnectionString |  | ADO-Verbindungszeichenfolge für den Verbindungsaufbau zur Datenbank | ado-c
TableName | addresses | Name der SQL-Tabelle*, alternativ können die Daten auch per SQL-Query selektiert werden | ado-c
Query | SELECT [id], [name], [surname], [adress], [zip], [city], [phone1] FROM [addresses] | SQL-Query*, alternativ kann auch die komplette Tabelle über TableName definiert werden | ado-c

* Es sollte jeweils TableName oder Query verwendet werden, nicht aber beides gleichzeitig.

Bereich [MLXML]

Name | Beispiel-Wert | Beschreibung | Konverter
Application | Datenbank XY | Name der Anwendung (Freitext) | csv-c, ado-c
PartName | crm_address | MLXML-Part, bezeichnet die Art der Daten. Für Adressen muss crm_address angegeben werden. | csv-c, ado-c
ItemName |  | MLXML-ItemPart, bezeichnet die einzelnen Daten. Wird kein Wert angegeben, wird der Wert automatisch bestimmt | csv-c, ado-c
PreProcessor |  | Nur zur internen Verwendung bestimmt, muss nicht definiert werden. |
FileExtension |  | Nur zur internen Verwendung bestimmt, muss nicht definiert werden. |
UserCaption |  | Nur zur internen Verwendung bestimmt, muss nicht definiert werden. |
MXCIdentifier |  | Nur zur internen Verwendung bestimmt, muss nicht definiert werden. |
Parameter |  | Nur zur internen Verwendung bestimmt, muss nicht definiert werden. |

Bereich [MLXML Options]

Die verfügbaren Optionen unter [MLXML-Options] hängen von der Anwendung und der zu importierenden Datenart (z.B. Adressen, Postleitzahlen, Banken u.s.w.) ab.

Name | Beispiel-Wert | Beschreibung | Datenart/PartName
journalnotemode | 2 | 0: Journal-Eintrag für neue Adressen hinzufügen 1: Journal-Eintrag für neue und aktualisierte Adressen hinzufügen 2: Keinen Journal-Eintrag erstellen Diese Option ist nur für delight crm verfügbar. | crm_address
updatecheck | 1 | Definiert ob beim Importieren auf bereits importierte Daten geprüft werden soll. 1: Prüfen 2: Nicht prüfen | (alle)
modifyexisting | 1 | Definiert ob bereits vorhanden Datensätze aktualisiert werden sollen. Ist nur relevant bei modifyexisting=1. 0: Bereits importierte Datensätze ignorieren. 1: Bereits importierte Datensätze aktualisieren. | (alle)
attachmentpath |  | Pfad für den Import von externen Dateien auf einen Journal-Eintrag. Diese Option ist nur für delight crm verfügbar. | crm_address

Bereich [Mapping]

In diesem Bereich werden die Felder der Datenquelle den Feldern der Anwendung zugeordnet. Auf der linken Seite (Name) steht jeweils der Feldname aus der Datenquelle, auf der rechten Seite (Wert) der Feldname der Anwendung.

Beispiel:

[Mapping]

Name=name

Vorname=surname

Firma=companyname

Strasse=adress

PLZ=zip

Ort=city

Tel_P=phone1

autonummer=crm_address_ident

Bereich [ConstantValues]

In diesem Bereich können für gewisse Felder konstante Werte definiert werden. Auf der linken Seite (Name) steht der Feldname der Anwendung, auf der rechten Seite (Wert) der konstante Wert.

Beispiel:

[ConstantValues]

acomment=ADO MLXML Import Test

crm_address_source=Demo.mdb

Bereich [DataFormats]

Dieser Bereich wird nur für den csv-c Konverter benötigt. Er definiert, in welchem Format die einzelnen Spalten in der CSV-Datei gespeichert sind. Es werden die Feldnamen nach dem Mapping verwendet (Feldname der Anwendung). Auf der linken Seite (Name) steht der Feldname, auf der rechten Seite (Wert) das Format.

Der Konverter ado-c kann die Datentypen der einzelnen Spalten automatisch bestimmen.

Beispiel:

[DataFormats]

crm_journal_note=Blob

level=Integer

amount=Float

birthday=Date

creadate=DateTime

Bereiche [Replacements_XY]

Um Zeichen oder ganze Zeichenfolgen vor dem Importieren durch Andere zu ersetzen, kann für ein Feld, in dem die Werte ersetzte werden sollen, ein eigener Replacement-Bereich erstellt werden. Auf der linken Seite (Name) steht der Wert der ersetzte werden soll, auf der rechten Seite der neuen Wert.

Beispiel:

[Replacements_countryid]

CH=Schweiz

FR=Frankreich

IT=Italien

Bereich [DeleteSources]

In diesem Bereich können Daten mit einem bestimmten Wert im Quellen-Feld vor dem Import gelöscht werden. Dieser Bereich kann verwendet werden, wenn mit jedem Importlauf andere Daten importiert werden müssen und die vorgängig importierten Daten nicht mehr benötigt werden. Auf der linken Seite (Name) werden die einzelnen Einträge nummeriert, auf der rechten Seite (Wert) steht das Quellen-Feld mit dem jeweiligen Wert.

Beispiel:

[DeleteSources]

1=crm_address_source=Demo.mdb

Bereich [SyncSources]

In diesem Bereich können alle Daten die nicht synchronisiert wurden (mit einem bestimmten Wert im Quellen-Feld) nach dem Import gelöscht werden. Dieser Bereich kann verwendet werden, wenn mit jedem Importlauf Daten die in der Quelle nicht mehr vornanden sind gelöscht werden müssen. Auf der linken Seite (Name) werden die einzelnen Einträge nummeriert, auf der rechten Seite (Wert) steht das Quellen-Feld mit dem jeweiligen Wert. Gelöscht werden alle Datensätze mit dem Wert des Quellen-Feldes die beim aktuellen Importlauf nicht aktualisiert oder neu importiert wurden. Als Prüfschlüssel wird wie beim Update das Schlüssel-Feld verwendet.

Beispiel:

[SyncSources]

1=crm_address_source=Demo.mdb

siehe auch:

Datenabgleich


MLXML-Format

MLXML beschreibt ein XML-Schema, das alle (durch MLXML unterstützen) Daten der Software in einem einheitlichen XML-Format notieren kann. Eine MLXML-Datei kann verschiedene Datenparts (z.B. Adressen, Journal-Einträge, Skripte, Stammdaten wie Postleitzahlenstamm oder Bankenstamm u.s.w.) in einer Datei beinhalten.

Welche Datenparts verfügbar sind, hängt vom Lieferumfang der Software bzw. vom eingesetzten Produkt ab.

Aufbau:

<?xml version="1.0" encoding="utf-8"?>

<mlxmldata application="Quelle XY" version="1">

<part_name art1="1" atrn="2">

<part_item_name value1="a" value2="" valuen="" />

<part_item_name value1="b" value2="" valuen="" />

<part_item_name value1="c" value2="" valuen="" />

<part_item_name value1="d" value2="" valuen="" />

</part_name>

</mlxmldata>

Beispiel:

<?xml version="1.0" encoding="utf-8"?>

<mlxmldata application="Quelle XY" version="1">

<crm_address count="1">

<crm_address_item crm_journal_type="" countryid="Schweiz" name="Elias" surname="Zurschmiede" adress="Unterstrasse 39" zip="9000" city="St. Gallen" crm_journal_note="Text für den Eintrag im Journal der beim Importieren erstellt wird."/>

</crm_address>

</mlxmldata>


Datenabgleich

Damit das Abgleichen von Daten (Prüfung ob ein Datensatz aus einer bestimmten Quelle bereits importiert wurde) funktioniert, muss jeder Datensatz mit einer Quelle und einem eindeutigen Schlüssel bestückt werden. Als eindeutigen Schlüssel bietet sich der Primär-Key aus der Tabelle der Quell-Datenbank an.

Da es theoretisch möglich ist, in einer MLXML-Datei Daten aus verschiedenen Quellen zu speichern, muss Quelle und Schlüssel auf jedem Eintrag definiert werden. Die Name dieser beiden Felder in MLXML hängen von der Datenart, die man importieren möchte, ab.

Auszug der verfügbaren MLXML-Parts:

PartName | PartItemName | Quellen-Feld | Schlüssel-Feld | Bemerkungen
crm_address | crm_address_item | crm_address_source | crm_address_ident |
crm_journal | crm_journal_item | crm_address_source | crm_journal_ident | Nur delight crm
crm_address | crm_contactperson | crm_address_source | crm_contactperson_ident |
address_zip | zip | address_zip_source | address_zip_ident |
address_zip | canton | address_zip_source | address_zip_ident |
address_bank | bank | address_bank_source | address_bank_ident |
script | script_item | script_source | script_ident |

Anmerkung: Diese Liste ist nicht vollständig, was genau verfügbar ist hängt vom eingesetzten Produkt ab. Alle verfügbaren Parts sind im MLXML-Business Wizard ersichtlich.

Beispiel für ado-c und csv-c Konverter:

Diese Beispiel zeigt einen Auszug aus der Konfigurationsdatei für die Konverter ado-c und csv-c. Mit dieser Konfiguration werden Adressen (PartName=crm_address) aus einer Datei oder Datenbank (je nach Konverter) importiert.

Im Bereich [Mapping] wird die Spalte mit der Datensatznummer (auto_nummer), aus der Tabelle die Importiert werden soll, dem entsprechenden Schlüssel-Feld (crm_address_ident) zugewiesen. Im Bereich [ConstantValues] wird dem Quellen-Feld ein fixer Wert (Demo.mdb) zugewiesen.

[MLXML]

Application=Demo.mdb

PartName=crm_address

[Mapping]

Name=name

Vorname=surname

...

...

auto_nummer=crm_address_ident

[ConstantValues]

crm_address_source=Demo.mdb

[SyncSources]

1=crm_address_source=Demo.mdb

Anmerkung:

Der Abschnitt SyncSources ist optional und bewirkt, dass nach dem Import alle Datensätze, die nicht mehr in der Quelle vorhanden sind, gelöscht werden. Damit können Sie sicherstellen das immer aktuelle Datensätze vorhanden sind - auch wenn in der Quelle Datensätze gelöscht werden.

Der Wert für crm_address_ident muss nicht zwingend eine Nummer sein. Zeichenfolgen (z.B. wenn als Primär-Schlüssel eine GUID verwendet wird) sind ebenfalls erlaubt.


BI Connector

Der Business Integration Connector stellt eine moderne JSON REST-API sowie einen legacy SOAP-Webservice, für den Zugriff von externen Programmen, zur Verfügung.

In der Netzwerk-Version des Produktes enthält jeder Client einen separaten, lokalen Connector. Damit ist es möglich, externe Anwendungen direkt mit dem jeweiligen Client-Programm zu verbinden. Ein Anwendungsbeispiel wäre die Archivierung von E-Mail aus einem externen E-Mailprogramm.


Konfiguration

Die Einstellungen werden in der Backstage-Ansicht unter Konfiguration => BI Connector aufgerufen.

In der Business Integration Connector Konfiguration kann der TCP/IP Port für die REST-API sowie den legacy SOAP-Server konfiguriert werden.


Lokaler Benutzer

Im Reiter Lokaler Benutzer kann der TCP/IP Port für den aktuellen Benutzer definiert werden. Diese Einstellung wird Benutzer- und Computerabhängig gespeichert. In der Netzwerk-Version kann der Port alternativ auch direkt in der Benutzerverwaltung auf dem jeweiligen Benutzer definiert werden.

Wenn Sie mehrere delight Programme parallel auf dem selben Computer (oder auf einem Terminal-Server) betreiben, muss in jedem Programm ein individueller Port definiert werden. Über diesen Port können die externen Programme (zB. Add-Ins in externen E-Mailprogrammen) auf das delight Programm zugreifen.

Wir bei Port der Wert 0 eingetragen, wird die Schnittstelle deaktiviert.


SSL Zertifikat aktivieren

Dieses Kapitel richtet sich an Systemtechniker und Experten

Für die lokale Benutzer REST-API muss auch im produktiven Betrieb nicht unbedingt ein SSL-Zertifikat aufgeschaltet werden. In der Regel wird der Benutzer REST API Service "nur" von localhost verwendet.

Bei Bedarf können auch selbst signierte Zertifikate oder kostenlose Zertifikate von Let's Encrypt aufgeschaltet werden.

HTTPS wird nur im sogenannten HTTP.sys Kernel-Modus unterstützt. Bei Microsoft's HTTP.sys können Zertifikate über die Befehlszeile "netsh http add sslcert" installiert werden. Das Zertifikat muss dazu im "Computer lokalen" Windows Zertifikatsspeicher installiert sein. Um den Prozess etwas zu vereinfachen, kann ein im Zertifikatsspeicher installiertes Zertifikat in delight per Klick ausgewählt und aktiviert werden.

Zertifikat per Klick installieren

Für diese Installation werden Administratorrechte benötigt.

1.Das gewünschte Zertifikat muss im Windows Zertifikatsspeicher installiert sein und Sie müssen im Besitz des PrivateKey's sein.

2.Starten Sie die ClientApp (ML2Client.exe) auf dem Computer des Benutzers.

3.Öffnen Sie Konfiguration => BI Connector > Lokaler Benutzer

4.Konfigurieren Sie zuerst den REST TCP/IP Port. Das müssen Sie unbedingt VOR der Aktivierung des Zertifikats tun, da bei HTTP.sys ein Zertifikat immer auf einen bestimmten TCP/IP Port installiert wird.
Wenn Sie den Port ändern, müssen Sie das SSL-Zertifikat erneut aktivieren.

5.Setzen Sie den Hacken bei SSL verwenden

6.Klicken Sie auf Lokales SSL-Zertifikate für REST-API konfigurieren

Wenn eines oder mehrere verwendbare Zertifikat installiert sind, kommt eine Auswahl. Wählen Sie das gewünscht Zertifikat und bestätigen Sie mit OK.

7.Nach dem Klicken wird eine zweite Instanz der Anwendung im Konfigurationsmodus gestartet. Allenfalls kommt eine Aufforderung der Windows-Elevation die Sie bestätigen müssen.


Server

Dieses Kapitel richtet sich an Systemtechniker und Experten

Im Reiter Server befinden sich die zentralen Server-Einstellungen zur REST-API sowie zur legacy SOAP-Schnittstelle.

Die hier definierten TCP/IP Ports stehen im zentralen delight Windows-Dienst zur Verfügung.

Der REST-API Port wird z. B. für delight App & Portal benötigt. Im produktiven Einsatz wird dringend empfohlen, die SSL-Verschlüsselung zu verwenden.

Der legacy SOAP-Port wird nur in Ausnahmefällen benötigt.

Wir bei Port der Wert 0 eingetragen, wird die Schnittstelle deaktiviert.

Benutzername und Passwort
Zugangsdaten für den Super-Admin Zugang. Dieses Angaben sollten Sie in produktiven Umgebungen leer lassen (=deaktiviert). Verwenden Sie stattdessen das Menü BI-Konten.

Wichtig:

Diese Einstellung sollte nur für Administratoren sichtbar sein.


Öffentliche REST API

Dieses Kapitel richtet sich an Systemtechniker und Experten

In vielen Fällen, z. B. auch für den Betrieb der delight App oder des delight Kunden-Portals, wird eine öffentliche, extern im Internet verfügbare REST-API benötigt. Die Server REST-API von delight ist für diesen Zweck ausgelegt.

Beachten Sie dazu bitte folgenden Punkte zum Thema Datenschutz und Sicherheit:

·Alle Benutzerkonten müssen mit einem starken Passwort geschützt sein. Dies gilt insbesondere auch für die normalen Benutzerkonten der Mitarbeiter.

·Prüfen Sie auch allfällige "admin" Benutzer. Wir stellen immer wieder fest, dass das Standard-Passwort nicht geändert wurde oder gar leer ist.

·Die REST-API muss unbedingt mit einer SSL-Verschlüsselung konfiguriert werden.

·Sollten Sie API-User mit der Rolle "Systembenutzer" benötigen, schützen Sie diese ebenfalls mit sehr starken Passwörtern und definieren Sie die Erlaubten API Methoden.

·Deaktivieren Sie den Super-Admin Zugang.

·Schränken Sie den Kreis der Mitarbeiter, welche externe Kundenzugriffe bearbeiten können, auf eine Minimum ein.

Überlegungen und Empfehlungen zur Installation:

·Verwenden Sie für die API einen hohen TCP/IP Port. z. B. unseren Standard-Port Vorschlag 9090. i. d. R. ist der HTTP/SSL-Port 443 bereits durch eine andere Anwendung besetzt.

·Verwenden Sie ein offizielles, verifizierbares SSL-Zertifikat. Keine self-signed Zertifikate. Unsere Empfehlung: Verwenden Sie kostenlose Let's Encrypt Zertifikate.

·Sollten der CRM-Server-Standort keine fix IP-Adresse habe, ist auch ein DynDNS möglich. Wir würden in diesem Fall neben dem DynDNS-Eintrag noch einen weiteren DNS-Eintrag auf Ihrer eigenen Domäne empfehlen.
Bsp. Wenn Ihre Website www.mycompany.ch wäre und der DynDNS des CRM-Server Standorts "mycompany.dyndns.org" wäre, sollten Sie zusätzlich folgenden CNAME-Eintrag erstellen: delightapi.mycompany.ch typ CNAME auf mycompany.dyndns.org
Der API-Endpunkt (der z. B. in die delight App&Portal-Konfiguration übernommen werden muss) wäre in diesem Bsp. dann https://delightapi.mycompany.ch:9090

Der Vorteil dieser Lösung: Sollte der CRM-Server irgend wann einmal umziehen (z. B. in eine Cloud oder ein eigenes RZ, anderer DynDNS-Provider weil Hardware wechselt) muss nur der DNS-Eintrag delightapi.mycompany.ch angepasst werden. Eine Neukonfiguration aller externen System welche die API verwenden ist nicht erforderlich.

·Installieren Sie das SSL-Zertifikat wie hier beschrieben für HTTP.sys, verwenden Sie kein SSL offloading auf der Firewall.

·Die delight REST-API basiert auf Micosoft's Kernel HTTP.sys. Nach unseren Tests sind damit auf einfachen Servern bereits sehr hohe Durchsätze bis zu 35'000 Requests / Sekunden und mehr möglich. Der Flaschenhals liegt hier oftmals bei der Datenbank. d. h. für Optimierungen ist dort der erste Ansatzpunkt.

·Im delight App&Portal Hosting ist zusätzlich eine API-Cache Projekt integriert. Sollten Sie ausgewählte Daten öffentlich über eine API zur Verfügung stellen wollen, sollte dies über den API-Cache konfiguriert werden. Der API-Cache ist nicht Teil dieser Dokumentation und wird nur im Rahmen unseres Entwickler-Supports zur Verfügung gestellt bzw. supported.


SSL Zertifikat aktivieren

Dieses Kapitel richtet sich an Systemtechniker und Experten

Für die zentrale Server REST-API sollte im produktiven Betrieb unbedingt ein SSL-Zertifikat aufgeschaltet werden.

Externe App & Portal Anwendungen können aus Sicherheitsgründen nicht ohne SSL betrieben werden und benötigen ein offizielles SSL-Zertifikat auf der REST-API. Selbst signierte Zertifikate sind für App und Portal nicht geeignet. Kostenlose Zertifikate von Let's Encrypt funktionieren problemlos.

HTTPS wird nur im sogenannten HTTP.sys Kernel-Modus unterstützt. Bei Microsoft's HTTP.sys können Zertifikate über die Befehlszeile "netsh http add sslcert" installiert werden. Das Zertifikat muss dazu im "Computer lokalen" Windows Zertifikatsspeicher installiert sein. Um den Prozess etwas zu vereinfachen, kann ein im Zertifikatsspeicher installiertes Zertifikat in delight per Klick ausgewählt und aktiviert werden.

Zertifikat per Klick installieren

Für diese Installation werden Administratorrechte benötigt.

1.Das gewünschte Zertifikat muss im Windows Zertifikatsspeicher installiert sein und Sie müssen im Besitz des PrivateKey's sein.

2.Starten Sie die ClientApp (ML2Client.exe) direkt auf dem Server auf dem der delight Window Service installiert ist und läuft.

3.Öffnen Sie Konfiguration => BI Connector > Server

4.Konfigurieren Sie zuerst den REST TCP/IP Port. Das müssen Sie unbedingt VOR der Aktivierung des Zertifikats tun, da bei HTTP.sys ein Zertifikat immer auf einen bestimmten TCP/IP Port installiert wird.
Wenn Sie den Port ändern, müssen Sie das SSL-Zertifikat erneut aktivieren.

5.Setzen Sie den Hacken bei SSL verwenden

6.Klicken Sie auf Lokales SSL-Zertifikate für REST-API konfigurieren

Wenn eines oder mehrere verwendbare Zertifikat installiert sind, kommt eine Auswahl. Wählen Sie das gewünscht Zertifikat und bestätigen Sie mit OK.

7.Nach dem Klicken wird eine zweite Instanz der Anwendung im Konfigurationsmodus gestartet. Allenfalls kommt eine Aufforderung der Windows-Elevation die Sie bestätigen müssen.

8.Warten Sie, bis die Konfiguration durchgeführt wurden und klicken Sie anschliessend auf HTTP-Modus abfragen. Wenn darauf die Meldung kommt, dass der Server im HTTP.sys (fast) Modus arbeite, dürfte es geklappt haben.

9.Die Funktion der API kann mit einem simplen Aufruf in jedem gängigen Webbrowser geprüft werden.

Bsp: https://mydelight.mysite.ch:9090/services/system/GetVersion
(natürlich muss der DNS-Name und der Port durch die korrekten Werte Ihrer Installation angepasst werden)

Liefert dieser Aufruf ein eine Error-Response im JSON Format, funktioniert die API:
{
"errorCode":401,
"errorText":"#0 Session not found or expired!"
}


Externer Kundenzugriff

Auf den Details jeder Adresse kann das Konto für den Kundenzugriff verwaltet werden.

Grundsätzlich sollten Sie für jeden Kunden nur ein Konto erfassen. Es können aber problemlos auch mehrere erfasst werden. Alle hier erfassten Konten sind auch gesammelt in der Kontenübersicht verfügbar.


Berechtigung

Ob der Block Externer Kundenzugriff für bestimmte Benutzer verfügbar ist, kann über die Berechtigung BI Connector => Zugriff auf Adressdetails.Externer Kundenzugriff konfiguriert werden.


Konfiguration

Die Einstellungen werden in der Backstage-Ansicht unter Konfiguration => BI-Konten aufgerufen.


Kontenübersicht

In der BI-Kontenübersicht werden alle Zugriffskonten der REST-API aufgelistet und verwaltet.

Rolle

Die Rolle des Kontos definiert, welche Berechtigungen und Zugriffe über die API möglich sind. Für Kundenzugriffe wird die Rolle "Kunde" verwendet. Diese Konten erhalten automatisch nur Zugriff auf die Kundendaten die unter "Person" angegeben sind. Die Rolle Systemvollzugriff erhält Vollzugriff. Entsprechend sollten Sie solche Konten nicht leichtfertig erstellen und in der Spalte "Erlaubte API Methoden" Einschränkungen auf das nötigste vornehmen.

Die Rolle "System Benutzer" kann nicht ausgewählt werden, da für normale Programm-Benutzer an dieser Stelle keine Konten erfasst werden. Normale System-Benutzer (Mitarbeiter) erhalten automatisch API-Zugriff über ihren Benutzer der normalen Benutzer-Verwaltung. Damit erhalten alle Mitarbeiter automatisch Zugriff auf die delight App.

Person

Verknüpfung auf die Person. i. d. R. Kunde der Rolle.

Erlaubte API Methoden

siehe Erlaubte API Methoden


Erlaubte API Methoden

Dieses Kapitel richtet sich an Systemtechniker und Experten

Im Feld Erlaubte API Methoden kann der Zugriff des Kontos auf bestimmte API-Methoden eingeschränkt und zusätzlich parametrisiert werden.

Wird bei der Rolle "Kunde" nicht benötigt. Bei Rolle "Systemvollzugriff" empfohlen.

Wenn dieses Feld leer ist, sind alle API-Methoden erlaubt (=Vollzugriff). Sobald Einschränkungen eingetragen werden, kann nur noch auf die eingetragenen Methoden zugegriffen werden.

Auf jeder Zeile kann eine API-Methode definiert und mit einem JSON-Wert parametrisiert werden:

die/api/methode={json-parameter}

Die genaue Funktionsweise ist nicht Teil dieser Dokumentation und wird nur im Rahmen unseres Entwickler-Supports zur Verfügung gestellt bzw. supported.

siehe auch

Publicdata-User.


Der "publicdatauser"

Dieses Kapitel richtet sich an Systemtechniker und Experten

Für gewisse externe Anwendungen wird eine öffentlicher Benutzer benötigt. Über diesen Benutzer müssen öffentlich verfügbare Daten abgefragt werden können. Da die delight REST API grundsätzlich keine Daten ohne spezifischen Benutzer liefert, muss für solche Fälle eine eigener Benutzer erstellt werden. Diesen Benutzer wird Publicdata-User genannt und sollte nur dann erstellen, wenn er auch tatsächlich benötigt wird.

Aktuell wird dieser Benutzer im delight Kunden-Portal immer dort benötigt, wo Aktionen ohne Login möglich sind. Aktuell ist dies nur im Zusammenhang mit dem delight Support-Ticketsystem der Fall.

Der sogenannte "publicdatauser" muss bei Bedarf wie folgt konfiguriert werden:

Benutzername: publicdatauser

Passwort: 1234

Erlaubte API Methoden:

database/table/QueryRecords={"SchemaName": {"grant": ["@table:ticketsystem_ticketphases"]}}

ticketsystem/PublicDataService/QueryTicketData={}

ticketsystem/PublicDataService/AddTicket={}

ticketsystem/PublicDataService/ExecuteTicketFunction={}


Verbindung

Damit externe Programme eine Verbindung herstellen können, müssen Sie im externen Programm (oder Add-In) den Verbindungs-URL eintragen. Der Verbindungs-URL wird in der Konfiguration angezeigt.

Authentifizierung:

Netzwerk-Version: Benutzername und Passwort zum verbinden sind die selben wie bei der Anmeldung am delight Programm.

Einzelbenutzer-Version: Benutzername und Passwort müssen leer sein.


WDSL

Dieses Kapitel richtet sich an Systemtechniker und Experten

Wenn Sie Anwender sind, ist das sogenannte WDSL für Sie nicht von Interesse.

Das WDSL des legacy SOAP-Webservices kann über {Verbindungs-URL}?wdsl (zB. http://localhost:8090/?wdsl) aufgerufen werden.

Wichtig: Für neue Anwendungen verwenden Sie bitte die JSON REST-API. Die SOAP API ist deprecated seit v2021.


Taskplaner

Mit dem Taskplaner-Modul können wiederkehrende Aufgaben und Prozesse geplant und automatisch im Hintergrund ausgeführt werden.


Konfiguration

Die Einstellungen werden in der Backstage-Ansicht unter Konfiguration => Taskplaner aufgerufen.


Taskliste

 Top Letztes

In der Taskliste können alle geplanten Tasks verwaltet werden. Ein Task führt eine geplante Aktion regelmässig zum gewünschten Zeitpunkt aus.

In der Liste Geplante Tasks im oberen Bereich werden alle Tasks, aller Benutzer aufgeführt. Für jeden Task kann definiert werden, ober er nur auf einem bestimmen Benutzer, für alle Benutzer oder zentral ausgeführt werden soll.

Status

Aktiviert oder deaktiviert den Task. Der Task wird automatisch ausgeführt wenn er auf Status Aktiv ist.

Beschreibung

Beschreibung des Tasks.

Ausführung am

Datum und Zeit des nächsten Ausführungstermins.

Ausführen auf

Definiert wo der Task ausgeführt wird.

Client - Führt den Task im Client-Programm aus wenn der in Ausführen für eingetragene Benutzer angemeldet ist.

Client alle Benutzer - Führt den Task im Client-Programm bei jedem angemeldeten Benutzer aus.

Server - Führt den Task unabhängig von Benutzern auf dem zentralen Server aus. Diese Option sollte nur gewählt werden, wenn der zentrale Server installiert/verwendet wird.

Aktion

Aktion die ausgeführt werden soll.

Queue

Definiert die Priorität und Warteschlange zur Ausführung des Tasks. Jede Warteschlange läuft unabhängig. Üblicherweise sollte hier Hintergrundaufgaben mit normaler Priorität verwendet werden.


Berichtsgeneratoren

Ein Berichtgenerator ist ein Modul für das Erstellen eines Berichtes.

Es sind Berichtgeneratoren für RTF-Berichte, XLS-Berichte und FastReport-Berichte verfügbar.


filtern

Eine Liste oder Tabelle filtern bedeutet, dass nur Daten, die einem bestimmten Kriterium entsprechen, angezeigt werden.

So kann z.B. die Adressliste nach dem Land "Switzerland" gefiltert werden, um alle Adressen aus der Schweiz zu erhalten.